No puedo agregar un plasmoide binario (en KDE) que instalé desde código fuente (Solucionado).

Imagen de Jose Luis 1320
232 puntos

Espero que alguien pueda ayudarme a contestar esta pregunta, que tal vez sea algo más interesante...

El problema que tengo es este:

Me atrajo mucho el hacer la instalación de un plasmoide el cual me muestra la información de mi sistema como lo hace conky, pero esta vez con la estética que ofrece plasma desktop, es decir este: http://kde-look.org/content/show.php?content=109367

según las instrucciones del mismo, debo extraer el contenido y hacer lo que sigue:

mkdir build
cd build 
cmake -DC-PREFIX_INSTALL=`kde4-config --prefix` -DCMAKE_BUILD_TYPE=release ..
make
sudo make install
kbuildsycoca4

Se compiló sin errores, se instaló correctamente, pero el widget no aparece cuando accedo a "agregar elementos graficos" ya sea desde el menú contextual del escritorio, desde cualquier panel, ni de ningún lugar en donde se pueden agregar plasmoides; Ni reiniciando puedo ver o acceder a ese plasmoide que instalé.

quisiera saber ¿por que? lo único que encuentro que puede ser releevante a ese comportamiento tan vacío de plasma desktop es en el archivo .xsession-errors en donde hay varias líneas como esta, pero ni idea si se refiera al plasmoide que acabo de instalar, por que instale de la misma manera varios más:

plasma-desktop(29102)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability 

Todo esto en Ubuntu 12.04 usando KDE 4.8.3

Imagen de Jose Luis 1320
+1
0
-1

Estaba compilando el plasmoide con estos paramentros:

cmake -DC-PREFIX_INSTALL=`kde4-config --prefix` -DCMAKE_BUILD_TYPE=release ..

Y en realidad deberían ser estos:

cmake -DCMAKE_PREFIX_INSTALL=`kde4-config --prefix` -DCMAKE_BUILD_TYPE=release ..

Por eso no se hacía una instalación correcta, cabeza hueca :).

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro