[Solucionado] Paquetes retenidos

Imagen de karcelero
0 puntos

Hola a todos

Ejecuto un apt-get upgrade y me sale esto:

Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Los siguientes paquetes se han retenido:
linux-generic-pae linux-headers-generic-pae linux-image-generic-pae
0 actualizados, 0 se instalarán, 0 para eliminar y 3 no actualizados.

¿Que significa y como lo puedo resolver?

Gracias

Imagen de cuentos
+1
0
-1

Pueden estar retenidos por alguna dependencia (archivo) que falte o que tengas instalado y de conflicto.
que te dice al final:

sudo apt-get update
+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de karcelero
+1
0
-1

Carga todos los repositorios y al final pone esto
Leyendo lista de paquetes... Hecho

Es posible que haya algun repositorio que entre en conflicto?

+1
0
-1
Imagen de Goyo
+1
0
-1

Significa (supongo) que esos paquetes han quedado bloqueados en su versión actual y no se actualizarán a nuevas versiones.

Con synaptic puedes bloquear/desbloquear paquetes. Con apt también, pero no me sé la sintaxis.

+1
0
-1
Imagen de 11.10Elcelote
+1
0
-1

sudo apt-get update
sudo apt-get distro update

con eso tendrías
Saludos.

+1
0
-1
Imagen de Scorpyo82
+1
0
-1

Esos paquetes por mi experiencia se quedan retenidos por lo que sea y no se vuelven a instalar desde un upgrade de consola normal...

Yo lo soluciono tan sencillo como (en tu caso):

sudo apt-get install linux-generic-pae linux-headers-generic-pae linux-image-generic-pae

Un saludo.

PD: Si hubiese algún problema de dependencias te avisaría antes de instalar, que no creo que vaya a ser el caso. Además, eso pinta de que los instalaste a mano pero quedaron pendientes por algo.

EDITO: Yo lo soluciono así, que no quiere decir que sea lo correcto...

+1
0
-1

Si entro en Window$ estoy más tenso que en el bautizo de un gremlin.
Linux user: 545.017
Por favor, si solucionas el hilo añade [Solucionado] al título.

Imagen de karcelero
+1
0
-1

...y ahora parece que corre bien ¡Gracias!

+1
0
-1
Imagen de faunaurbana
+1
0
-1

Tenia el mismo problema y lo destrabe desde Synaptic, estaban pendientes de actualizacion pero por consola no lo lograba

+1
0
-1
Imagen de vikotoro
+1
0
-1

**/Moderado/**

Favor de leer las normas del foro. No puedes hacer consultas en hilos que no son de tu autoría gracias.

+1
0
-1

Vikotoro