[Solucionado] Paquetes retenidos

Imagen de karcelero
0 puntos

Hola a todos

Ejecuto un apt-get upgrade y me sale esto:

Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Los siguientes paquetes se han retenido:
linux-generic-pae linux-headers-generic-pae linux-image-generic-pae
0 actualizados, 0 se instalarán, 0 para eliminar y 3 no actualizados.

¿Que significa y como lo puedo resolver?

Gracias

Imagen de cuentos
+1
0
-1

Pueden estar retenidos por alguna dependencia (archivo) que falte o que tengas instalado y de conflicto.
que te dice al final:

sudo apt-get update
+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de karcelero
+1
-1
-1

Carga todos los repositorios y al final pone esto
Leyendo lista de paquetes... Hecho

Es posible que haya algun repositorio que entre en conflicto?

+1
-1
-1
Imagen de Goyo
+1
0
-1

Significa (supongo) que esos paquetes han quedado bloqueados en su versión actual y no se actualizarán a nuevas versiones.

Con synaptic puedes bloquear/desbloquear paquetes. Con apt también, pero no me sé la sintaxis.

+1
0
-1
Imagen de 11.10Elcelote
+1
-1
-1

sudo apt-get update
sudo apt-get distro update

con eso tendrías
Saludos.

+1
-1
-1
Imagen de josebarakat
+1
0
-1

Hay una ligera equivocación en la segunda línea.
Cambia: sudo apt-get distro update por sudo apt-get dist-upgrade

Más información en Ubuntu Manpage para apt-get

+1
0
-1

Recursos adicionales:
Ubuntu Manpages (en Inglés) o escribir en la Terminal: ~$ man [comando a consultar]
Imagen de Scorpyo82
+1
+3
-1

Esos paquetes por mi experiencia se quedan retenidos por lo que sea y no se vuelven a instalar desde un upgrade de consola normal...

Yo lo soluciono tan sencillo como (en tu caso):

sudo apt-get install linux-generic-pae linux-headers-generic-pae linux-image-generic-pae

Un saludo.

PD: Si hubiese algún problema de dependencias te avisaría antes de instalar, que no creo que vaya a ser el caso. Además, eso pinta de que los instalaste a mano pero quedaron pendientes por algo.

EDITO: Yo lo soluciono así, que no quiere decir que sea lo correcto...

+1
+3
-1

Si entro en Window$ estoy más tenso que en el bautizo de un gremlin.
Linux user: 545.017
Por favor, si solucionas el hilo añade [Solucionado] al título.

Imagen de karcelero
+1
0
-1

...y ahora parece que corre bien ¡Gracias!

+1
0
-1
Imagen de josebarakat
+1
0
-1

Generalmente cuando uno o más paquetes se retienen (es decir no se pueden instalar por primera vez o no se pueden actualizar), es debido a que entra(n) en conflicto con otro(s) paquete(s) que ya está(n) instalado(s).

En mi caso (Ubuntu 16.04):

jose@jose-Lenovo-G400s:~$ sudo apt-get dist-upgrade
[sudo] password for jose: 
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
Calculando la actualización... Hecho
Los siguientes paquetes se han retenido:
  libjpeg-turbo-progs
0 actualizados, 0 nuevos se instalarán, 0 para eliminar y 1 no actualizados.

Lo he solucionado (como lo propone Scorpyo82):

jose@jose-Lenovo-G400s:~$ sudo apt-get install libjpeg-turbo-progs
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
Los siguientes paquetes se ELIMINARÁN:
  libjpeg-progs
Se actualizarán los siguientes paquetes:
  libjpeg-turbo-progs
1 actualizados, 0 nuevos se instalarán, 1 para eliminar y 0 no actualizados.
Se necesita descargar 57,3 kB de archivos.
Se liberarán 209 kB después de esta operación.
¿Desea continuar? [S/n] s
Des:1 http://archive.ubuntu.com/ubuntu xenial/universe amd64 libjpeg-turbo-progs amd64 1.4.2-0ubuntu3 [57,3 kB]
Descargados 57,3 kB en 2s (25,6 kB/s)          
(Leyendo la base de datos ... 450073 ficheros o directorios instalados actualmente.)
Desinstalando libjpeg-progs (1:9b-1) ...
Procesando disparadores para man-db (2.7.5-1) ...
(Leyendo la base de datos ... 450054 ficheros o directorios instalados actualmente.)
Preparando para desempaquetar .../libjpeg-turbo-progs_1.4.2-0ubuntu3_amd64.deb ...
Desempaquetando libjpeg-turbo-progs (1.4.2-0ubuntu3) sobre (1.3.0-0ubuntu2) ...
Procesando disparadores para man-db (2.7.5-1) ...
Configurando libjpeg-turbo-progs (1.4.2-0ubuntu3) ...
jose@jose-Lenovo-G400s:~$ 

En este caso libjpeg-turbo-progs es un conjunto de utilidades para manejar imágenes en formato JPEG (al igual que libjpeg-progs) solo que su código ha sido modificado para acelerar la compresión/descompresión en varios tipos de arquitecturas. Debido a sus dependencias, la instalación entra en conflicto con el paquete anteriormente instalado y al forzar su instalación con ~$ sudo apt-get install libjpeg-turbo-progs se elimina el paquete conflictivo. Al final he terminado con una librería más eficiente, es decir un "upgrade".

Creo que cada caso de paquetes retenidos podría ser aislado y sería mejor investigar sobre los paquetes a sustituir.

+1
0
-1

Recursos adicionales:
Ubuntu Manpages (en Inglés) o escribir en la Terminal: ~$ man [comando a consultar]
Imagen de faunaurbana
+1
0
-1

Tenia el mismo problema y lo destrabe desde Synaptic, estaban pendientes de actualizacion pero por consola no lo lograba

+1
0
-1
Imagen de vikotoro
+1
0
-1

**/Moderado/**

Favor de leer las normas del foro. No puedes hacer consultas en hilos que no son de tu autoría gracias.

+1
0
-1

Vikotoro

Imagen de isaga
+1
0
-1

La solución es la que pone el amigo 11.10Elcelote.
Comentar que el comando correcto sería : sudo apt-get dist-update pero muchas gracias amigo!

+1
0
-1

-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-ATENCIÓN IMPORTANTE
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado) antes del titulo, para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.

Imagen de Banyeres
+1
0
-1

isaga, a mí también me ha funcionado la solución de 11.10Elcelote, pero tecleando:

sudo apt-get dist-upgrade

Gracias a todos por vuestras ayudas.

+1
0
-1
Imagen de raftorres
+1
0
-1

Yo también instalé Ubuntu Studio 14.04 y en el terminal me decia:
Los siguientes paquetes se han retenido:
linux-generic-lts-utopic linux-headers-generic-lts-utopic
linux-headers-lowlatency linux-headers-lowlatency-lts-utopic
linux-image-generic-lts-utopic linux-image-lowlatency
linux-image-lowlatency-lts-utopic linux-lowlatency
linux-lowlatency-lts-utopic
luego puse
sudo su
(pasword)
sudo apt-get dist-upgrade
sudo apt-get update

Otra vez gracias, encontre la respuesta antes de preguntar :p

+1
0
-1

Los pajaros nacidos en jaula creen que volar es una enfermedad.
Alejandro Jodorowsky

Imagen de bilbma
+1
-1
-1

Solucionado,Synaptic como # ¡¡genial!!
gracias

+1
-1
-1
Imagen de bilbma
+1
-1
-1

¿por qué es tan recurrente este problema?

+1
-1
-1