Precise y Nvidia (más perdido que caballo arriba del techo)

Imagen de negrolito
0 puntos

Hola gente.

Tengo problemas con NVidia. Más bien con mi ignorancia sobre el tema. He instalado Ubuntu Precise en una máquina que tiene el siguiente hard:


00:00.0 Host bridge: NVIDIA Corporation Device 07c3 (rev a2)
00:00.1 RAM memory: NVIDIA Corporation nForce 630i memory controller (rev a2)
00:01.0 RAM memory: NVIDIA Corporation nForce 630i memory controller (rev a1)
00:01.1 RAM memory: NVIDIA Corporation nForce 630i memory controller (rev a1)
00:01.2 RAM memory: NVIDIA Corporation nForce 630i memory controller (rev a1)
00:01.3 RAM memory: NVIDIA Corporation nForce 630i memory controller (rev a1)
00:01.4 RAM memory: NVIDIA Corporation nForce 630i memory controller (rev a1)
00:01.5 RAM memory: NVIDIA Corporation nForce 630i memory controller (rev a1)
00:01.6 RAM memory: NVIDIA Corporation nForce 630i memory controller (rev a1)
00:02.0 RAM memory: NVIDIA Corporation nForce 630i memory controller (rev a1)
00:03.0 ISA bridge: NVIDIA Corporation MCP73 LPC Bridge (rev a2)
00:03.1 SMBus: NVIDIA Corporation MCP73 SMBus (rev a1)
00:03.2 RAM memory: NVIDIA Corporation MCP73 Memory Controller (rev a1)
00:03.4 RAM memory: NVIDIA Corporation MCP73 Memory Controller (rev a1)
00:04.0 USB controller: NVIDIA Corporation GeForce 7100/nForce 630i USB (rev a1)
00:04.1 USB controller: NVIDIA Corporation MCP73 [nForce 630i] USB 2.0 Controller (EHCI) (rev a1)
00:08.0 IDE interface: NVIDIA Corporation MCP73 IDE (rev a1)
00:09.0 Audio device: NVIDIA Corporation MCP73 High Definition Audio (rev a1)
00:0a.0 PCI bridge: NVIDIA Corporation MCP73 PCI Express bridge (rev a1)
00:0b.0 PCI bridge: NVIDIA Corporation MCP73 PCI Express bridge (rev a1)
00:0c.0 PCI bridge: NVIDIA Corporation MCP73 PCI Express bridge (rev a1)
00:0d.0 PCI bridge: NVIDIA Corporation MCP73 PCI Express bridge (rev a1)
00:0e.0 IDE interface: NVIDIA Corporation MCP73 IDE (rev a2)
00:0f.0 Ethernet controller: NVIDIA Corporation MCP73 Ethernet (rev a2)
00:10.0 VGA compatible controller: NVIDIA Corporation C73 [GeForce 7050 / nForce 610i] (rev a2)

Yo ignoraba que Nvidia proveía hard para varias funciones de la máquina, siempre pensé que se dedicaba a los monitores y nada más. El tema es que Ubuntu se cuelga y se tilda en esta configuración. He buscado sobre el siguiente hard del monitor:


00:10.0 VGA compatible controller: NVIDIA Corporation C73 [GeForce 7050 / nForce 610i] (rev a2)

Pero no lo que no he encontrado es una aclaración si el mismo se trata de una aceleradora gráfica o simplemente es una placa integrada común (el dueño ignora si la máquina tiene aceleradora gráfica). He dejado por defecto Unity 2d pero los problemas persisten.
En dicha búsqueda me he instruido sobre los problemas que hay de NVidia con el software libre. Así que agradecería también saber cuál es el criterio vigente para el driver más conveniente para dicho hard.

Desde ya muchas gracias y disculpen las molestias.

Imagen de BrusBilis
+1
0
-1

Es un bug del driver 295.40 de nvidia.
Puedes usar el viejo 173 :
sudo dpkg -P nvidia-173
sudo apt-get --purge remove nvidia-cg-toolkit nvidia-settings nvidia-settings-updates
sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get install nvidia-current

o volver al 295.33
https://launchpad.net/ubuntu/precise/amd64/nvidia-current/295.33-0ubuntu1 (o el de 32 bits segun cual uses)

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

No es instalable y si lo logras instalar puedes romper el sistema.

Y nvidia no se dedican a los monitores, ellos hacen trajetas de vídeo, Fabricantes de monitores, tienes a Philips, Samsung, AOC, etc.

Para activar la aceleración en tu tarjeta, debes primero instalar los drivers que el compañero ya dijo como, salvo no le hagas caso de los drivers 173, no son recomendables en Ubuntu 12.04 (son muy viejos, empieza en donde el compañero te pone "sudo add-apt-repository..."), y luego editas el archivo (como root, Alt + F2 y escribe gksudo gedit /etc/environment): /etc/environment y agregas la línea:

UNITY_FORCE_START=1

reinicias sesión en "Ubuntu" y vualá debes tener Unity 3D.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de negrolito
+1
0
-1

Gracias chicos por responder.

El tema es que sigo sin saber si esa es una placa aceleradora o no lo es. ¿Hay algún comando para averiguar si es aceleradora?

Gracias.

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

dale a:

glxinfo | grep direct
+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de negrolito
+1
0
-1

Hola.
Ok, ahora estoy más o menos agarrando la onda. Una cosa es la controladora y otra el monitor. Yo pensé que a un monitor le correspondía una placa específica, si no no andaba.
Te comento que tengo dos máquinas. Una Asus notebook que si tiene aceleradora y una pc de escritorio celeron d vieja de la cual estoy segurísimo que no tiene aceleradora.
Para usar el comando que me especificás he tenido que instalar el paquete "mesa-utils" (parte del aprendizaje) y me puse a probar en ambas máquinas. El tema es que "glxinfo | grep direct" me tira: "direct rendering: Yes" en ambas máquinas. ¿A qué se puede deber?
La pc de escritorio tiene instalado un Debian Squeeze con un Gnome2 (creo).
Gracias, me sigo desburrando con este asunto de los monitores.

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

Si te dice que Yes, es que si tienes aceleración. Lee la documentación, por favor. El sistema no define si tienes aceleración o no, es el hardware que tiene esa capacidad.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro