Problemas con las extensiones en gnome shell 3.4

Imagen de Alberto Aru
0 puntos

El título lo dice todo, antes tenía gnome 3.2 y todo genial. Luego, me vi obligado a reinstalar ubuntu por problemas que no vienen al caso. Entonces decidí instalar directamente la 3.4 y cuál es mi sorpresa al ver que sólo me carga algunas extensiones (windows native placement, alternate tab, workspace indicator, dock, system monitor, ...) sin embargo otras tan básicas como la función de hibernado, mover el reloj o el indicador meteorológico no me deja instalarlas. No sé qué hacer.
También he tenido problemas al no cargarme la barra de abajo, el selector de tareas tan cómodo. No recuerdo si eso se debía a una extensión o no.

Imagen de Jose Luis 1320
+1
0
-1

y ¿como instalaste la versión 3.4 de gnome shell? El selector de tareas que mencionas es un extensión. Gnome-shell por defecto no lo incluye.

Y sobre todo ¿Como tratas de instalar esas extensiones?.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de Alberto Aru
+1
0
-1

Desde Unity escribí en la terminal:
sudo add-apt-repository ppa:ricotz/testing
sudo add-apt-repository ppa:gnome3-team/gnome3
sudo apt-get update && sudo apt-get dist-upgrade
sudo apt-get install gnome-shell

Las extensiones las he intentado instalar por terminal y por extensions.gnome.org

Muchas gracias por comentar, Jose Luis 1320

+1
0
-1

~ Un viaje de mil leguas comienza con un paso. ~

Imagen de Jose Luis 1320
+1
0
-1

Las extensiones las he intentado instalar por terminal y por extensions.gnome.org

¿Desde el mismo repositorio de ricotz/testing tratas de instalar las extensiones?.

Independientemente de las extensiones, no confíes en ese repositorio, bórralo. Ese repositorio es de software que esta en pruebas, supongo yo que estas usando Ubuntu 11.10, esta versión incluye Gnome 3.2, y en ese repositorio estan los backports (inestables) de gnome 3.4 para Ubuntu 11.10.

Ese repositorio no es apto para tí, te voy a decir algo que sí me funcionó, usando Ubuntu 11.10 y Gnome 3.2;

las extensiones las instalé desde este repositorio y me funcionaron SIN problemas;

http://www.webupd8.org/2011/10/official-gnome-shell-extensions.html

Pero, si estas usando Ubuntu 12.04, entonces ¿para que te complicas con ese repositorio?, bórralo cuanto antes!!!, NO lo necesitas.

Espero que no tengas problemas.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de Alberto Aru
+1
0
-1

Perdona por volver a contestar, uso 12.04 actualizado de 11.10. El mensaje de abajo lo he editado varias veces, si te ha llegado un correo con cada editado, te debo una disculpa, no era mi intención.

+1
0
-1

~ Un viaje de mil leguas comienza con un paso. ~

Imagen de Alberto Aru
+1
0
-1

Estoy pensando en reinstalar gnome 3.4 ¿algún consejo antes de hacerlo o no hacerlo?

+1
0
-1

~ Un viaje de mil leguas comienza con un paso. ~

Imagen de Jose Luis 1320
+1
0
-1

Francamente a nadie le importa, si yo ya no te respondí, es por que ya no puedo ayudarte, yo te dije todo lo que supe y sé.

Estas instalando gnome shell de un repositorio externo al de Ubuntu, eso siempre estará bajo tu riesgo.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de Alberto Aru
+1
0
-1

Perdona si he sido algo borde, no era mi intención, sólo que me desesperaba no optener respuesta. Gracias por todo. ¡Un saludo!

+1
0
-1

~ Un viaje de mil leguas comienza con un paso. ~

Imagen de Alberto Aru
+1
0
-1

Muchas gracias por comentar, he encontrado 2 líneas en los orígenes. Las he borrado y he pulsado Alt+F2 y he introducido r, sigue sin cambios. He reiniciado y nada. Los repositorios que me indicas ya los tenía instalados, he puesto en la terminal sudo apt-get update y tampoco, nada. Sólo se me ha abierto el gestor de actualizaciones.

+1
0
-1

~ Un viaje de mil leguas comienza con un paso. ~

Imagen de Alberto Aru
+1
0
-1

Como no pude solucionar un problema con las extensiones, he intentado reinstalar gnome shell desde el centro de software, sin embargo, al intentar instalarlo de nuevo me encuentro esto:

Los siguientes paquetes tienen dependencias incumplidas:

gnome-shell: Depends: libgjs0- pero es un paquete virtual
Depends: libpulse-mainloop-glib0 (>= 1:0.99.1) pero 1:1.1-0ubuntu15.1 no está instalado
Depends: libpulse0 (>= 1:0.99.1) pero 1:1.1-0ubuntu15.1 no está instalado
Depends: libxfixes3 (>= 1:5.0) pero 1:5.0-4ubuntu4 no está instalado
Depends: gnome-shell-common (= 3.4.1-0ubuntu2) pero 3.5.4+git20120721.r1.dd80f390-0ubuntu1~12.04~ricotz1 no está instalado

He intentado instalar las dependencias desde synaptic. Las dos primeras lineas bien, las 2 últimas me dan error y no me deja instalarlo. He seguido tu consejo, Jose Luis, (el de usar ppa-purge) y he intentado "purgar" los repositorios. Pero no lo consigo porque no lo encuentra en la lista. He mirado en la lista de "orígenes de software" y, como me dijste que los borrara, los borré. Pero no entiendo cómo puede darme problemas eso ahora y mucho menos cómo arreglarlo. Gracias por moderar mi comentario en el otro hilo, creía que podía comentar ahí para evitar tener tantos hilos, pero a partir de ahora haré otros nuevos siempre que no tengan que ver con esto. Gracias también por comentar. Un saludo.

+1
0
-1

~ Un viaje de mil leguas comienza con un paso. ~

Imagen de Jose Luis 1320
+1
0
-1

Vuelvelo a agregar desde orígenes del software y luego lo desagregas con ppa-purge.

Puede ser que sólo hayas desinstalado gnome-shell y algunas dependencias, pero no todos los paquetes que instalaste desde el repositorio de ricotz-testing.

Entonces vuelves a agregar el repositorio, y luego usas ppa-purge para borrar el repositorio y desinstalar todos los paquetes que tengan su origen en el, ppa-purge desinstala los paquetes de forma automática.

Suerte!.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de Alberto Aru
+1
0
-1

He intentado instalar los repositorios, pero no me los acepta:

aru@acer:~$ sudo add-apt-repository ppa:ricotz/testing
[sudo] password for aru:
You are about to add the following PPA to your system:
=== IMPORTANT NOTICE ===
Please downgrade your cogl packages to 1.10.5+ !!! You need to do i manually if your package manager doesnt offer you that option. Or even use ppa-purge and re-add this ppa. http://ubuntuforums.org/showthread.php?t=1987216

=== WARNING ===
Make sure you know what you are doing! You are getting bleeding edge snapshots!
You should have a stable experience most of the time, but there will be problems!

=== IMPORTANT for Precise/12.04 ==
WHILE USING THIS PPA MAKE SURE YOU ALSO ADDED THE GNOME3 PPA!
ppa:gnome3-team/gnome3 (https://launchpad.net/~gnome3-team/+archive/gnome3)

Using this ppa could break your system or make it unstable!
So you need to know how to repair it using something like ppa-purge.

Currently supported: Precise/12.04, Quantal/12.10
More info: https://launchpad.net/~ricotz/+archive/testing
Press [ENTER] to continue or ctrl-c to cancel adding it

Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /tmp/tmp.Ca274YZnhH --trustdb-name /etc/apt/trustdb.gpg --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver hkp://keyserver.ubuntu.com:80/ --recv 38AE4F60E356CE050312FA1775CFD31C9E5DB0C8
gpg: solicitando clave 9E5DB0C8 de hkp servidor keyserver.ubuntu.com
gpg: clave 9E5DB0C8: «Launchpad PPA for Rico» sin cambios
gpg: Cantidad total procesada: 1
gpg: sin cambios: 1

Con el segundo repositorio:

aru@acer:~$ sudo add-apt-repository ppa:gnome3-team/gnome3 -y
Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /tmp/tmp.CfUT4BJBO9 --trustdb-name /etc/apt/trustdb.gpg --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver hkp://keyserver.ubuntu.com:80/ --recv 9D542E3D52C801D9F8E31682F1773AF13B1510FD
gpg: solicitando clave 3B1510FD de hkp servidor keyserver.ubuntu.com
gpg: clave 3B1510FD: «Launchpad PPA for GNOME3 Team» sin cambios
gpg: Cantidad total procesada: 1
gpg: sin cambios: 1

Purga del primero:

aru@acer:~$ sudo ppa-purge ppa:ricotz/testing
Updating packages lists
E: Tipo «ain» desconocido en la línea 3 de lista de fuentes /etc/apt/sources.list.d/gnome3-team-gnome3-precise.list
E: No se pudieron leer las listas de fuentes.
Warning: apt-get update failed for some reason
PPA to be removed: ricotz testing
Warning: Could not find package list for PPA: ricotz testing

+1
0
-1

~ Un viaje de mil leguas comienza con un paso. ~

Imagen de Jose Luis 1320
+1
0
-1

Tienes un desorden total en los repositorios y para acabar de fregarla más feo, no solo agregaste un repositorio, sino 2 y eso nunca lo dijiste... 2 repositorios que NO necesitas, tampoco los necesitabas en Ubuntu 11.10, puesto que se podían instalar extensiones 100 % funcionales, las tengo en Fedora 16 (usa gnome shell 3.2).

El ppa-purge no encuentra listas de paquetes por que no las ha podido cargar, despues de agregar los repositorios, siempre actualizas la lista de paquetes, pero hagamos otra cosa; lee lo que dice aquí:

E: Tipo «ain» desconocido en la línea 3 de lista de fuentes /etc/apt/sources.list.d/gnome3-team-gnome3-precise.list

entonces vas a editar el archivo que te indica, y que puse en negritas; Alt + F2 y escribe: gksudo gedit /etc/apt/sources.list.d/gnome3-team-gnome3-precise.list

¿que tienes en ese archivo?.

Y los repositorios si los agregó, no hay nada que indique que el sistema haya fallado en agregar repositorio alguno, sólo indica que no hubo cambios en las claves de esos repositorios.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de Alberto Aru
+1
0
-1

Ok, gracias por contestar, en el fichero tengo esto:

deb http://ppa.launchpad.net/gnome3-team/gnome3/ubuntu precise main
deb-src http://ppa.launchpad.net/gnome3-team/gnome3/ubuntu precise main
ain

Un saludo

+1
0
-1

~ Un viaje de mil leguas comienza con un paso. ~

Imagen de Jose Luis 1320
+1
0
-1

la que esta en la útlima línea, tu tienes esto:

deb http://ppa.launchpad.net/gnome3-team/gnome3/ubuntu precise main
deb-src http://ppa.launchpad.net/gnome3-team/gnome3/ubuntu precise main
ain

lo dejas así:

deb http://ppa.launchpad.net/gnome3-team/gnome3/ubuntu precise main
deb-src http://ppa.launchpad.net/gnome3-team/gnome3/ubuntu precise main

Guardas cambios, luego le das a:

 
sudo apt-get update
sudo ppa-purge ppa:ricotz/testing
sudo ppa-purge ppa:gnome3-team/gnome3

Saludos!.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de Alberto Aru
+1
0
-1

Muchísimas gracias, Jose Luis, acabas de arreglarme el ordenador. ¡Eres un genio!
¡¡Un saludo!!

+1
0
-1

~ Un viaje de mil leguas comienza con un paso. ~

Imagen de Alberto Aru
+1
0
-1

Gnome 3.4 parece que me tiene tirria, con lo bien que me llevaba con el 3.2...

+1
0
-1

~ Un viaje de mil leguas comienza con un paso. ~

Imagen de Jose Luis 1320
+1
0
-1

y te ayudo, ok?.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de Alberto Aru
+1
0
-1

Las extensiones del reloj, la temperatura de la batería, el selector de ventanas (la barra de abajo en plan gnome classic), el de la hibernacion, el media player, advanced settings, el indicador de lugares, el notificador de mensajes, el integrador de pidgin y habia uno con el icono de una ballena, lo he buscado pero no lo encuentro ahora mismo. De todos modos, muchas gracias por la ayuda. Si prefieres que te diga los nombres de las extensiones lo hago.

+1
0
-1

~ Un viaje de mil leguas comienza con un paso. ~

Imagen de Jose Luis 1320
+1
0
-1

Disculpa si no indiqué bien que es lo que quería, pero sí, quiero los nombres de las extensiones... yo tengo varias de esas extensiones en Ubuntu 12.04... Gnome-shell así como en Fedora 16 (usa gnome-shell 3.2).

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de Alberto Aru
+1
0
-1

Alternative Status Menu
User Themes
Advanced Settings in UserMenu
Media player indicator
SettingsCenter
CPU Temperature Indicator
Places Status Indicator
Battery remaining time and percentage
Frippery Move Clock
Message Notifier
Status Area Horizontal Spacing
Pidgin Conversation Integration
Window Rotate In
Pidgin Menu

La lista ha sido algo más ampliada de lo que preveía, lo siento (y eso que aún no he encontrado la que coloca la barra de abajo de selección de ventanas tipo gnome classic)
Muchas gracias por todo

+1
0
-1

~ Un viaje de mil leguas comienza con un paso. ~