No se pueden instalar todas las actualizaciones

Imagen de hectorsales
6 puntos

Hola buenas, tengo ubuntu 11.10 y hoy me ha salido el siguiente error en el Gestor de actualizaciones, no se pueden instalar todas las actualizaciones, he mirado en google y aquí mismo en el buscador del foro y no he dado con la solución, he intentado ir a Configuración del sistema---->Origenes del software--->actualizaciones, para ver como tengo configurado las actualizaciones y yo creo que las tengo bien...tengo marcadas las casillas de SEGURIDAD, RECOMENDADAS Y NO SOPORTADAS. Bien lo que he hecho tras salirme la dichosa ventana de "no se pueden instalar todas las actualizaciones" es cerrar la ventana, te daba la opción de cerrar o actualización parcial, la he cerrado y ya en el gestor de actualizaciones le he dado a actualizar y se han actualizado algunas actualizaciones NO TODAS, habían actualizaciones de seguridad, recomendadas y otras actualizaciones. Precisamente y hay vienen mis dudas por qué no se han actualizado TODAS las de seguridad y recomendadas si las tengo activadas en Origenes de software. Esto hasta ahora no me había ocurrido, he intentado ser lo más explicativo posible, llevo en Ubuntu cerca de 6 meses y hasta ahora todas las actualizaciones de seguridad y recomendadas se me habían instalado sin problemas...

Gracias de antemano...

Imagen de .doc
+1
0
-1

pueden ser muchas causas: servidor (repositorio) momentáneamente 'caido', falta de dependencias, etc.

Yo probaría en otro momento, empezando por 'recargar' (actualizar) los repositorios, por ejemplo con
sudo apt-get update
(y así puedes ver si hay algún problema con ellos)

(si tienes instalado aptitude, puedes hacer lo mismo con un 'sudo aptitude update' y luego, con un 'sudo aptitude safe-upgrade' puedes ver los problemas de dependencias, y las posibles soluciones que te propone aptitude)

+1
0
-1
Imagen de hectorsales
+1
0
-1

Gracias .doc, te agradecería si tienes infinita amabilidad, que me pudieras decir o extraer aquellos puntos más importantes de la "nota aclarativa"que me han dado, no tengo mucha idea de inglés.
Por cierto, antes de pedir ayuda lo he intentado con el google traductor, pero no es lo mio. También he intentado lo que me has dicho pero no lo he conseguido.
Me he dado de alta en http://ubuntuforums.org/index.php y he preguntado esta duda y me han dicho esto :http://ubuntuforums.org/showthread.php?t=1859240. Esta en inglés y no tengo mucha idea, alguien que sea tan,tan, tan amable y me pueda decir en poca palabras el contenido, no quiero que me lo traduzcáis, simplemente que resumáis aquello que vosotros habéis entendido, lo he intentado con el Google Traductor, pero no es lo mio.....

+1
0
-1

Ubuntu 14.04 LTS

Imagen de .doc
+1
0
-1

pues lo siento, mi amabilidad puede ser infinita, pero mi conocimiento de inglés, y del origen de tu problema, muy limitado. Quizás haya alguien con más conocimiento que te lo puede extractar. Pero te diría que el contenido (varios post) es largo, y debe dar mucha pereza leerlo detenidamente.

Y hombre, una cosita más, si se te da un consejo, di, por lo menos, que lo has probado, y el resultado que te ha ofrecido, cuestión que debe ser previa a 'huir hacia adelante' y preguntar que te aclaren otros consejos.

+1
0
-1
Imagen de hectorsales
+1
0
-1

Ok, Gracias, efectivamente he instalado aptitude, después he hecho un aptitude update y me han salido un montón de paquetes que no estaban actualizados, lo que no he hecho efectivamente es un upgrade (creo que con upgrade se instalan las actualizaciones). Quiero estar seguro antes de poner sudo aptitude upgrade no vaya a "cagarla" y no pueda volver hacia atrás. He buscado información en google y he llegado a la conclusión de que con apt-get se instalan solo los paquetes requeridos y con aptitude los requeridos e importantes. Creo que el Gestor de Actualizaciones usa apt-get y a lo mejor por eso no se me actualiza por que faltan paquetes importantes por instalar.
De todas formas esperaré unos días a ver si desde el Gestor de Actualizaciones se soluciona el problema, sino haré el "upgrade" y que sea lo que dios quiera..Espero que no te hayas molestado, pero al ser "nuevo" en Ubuntu, estoy intentando recopilar el mayor conocimiento posible. ¿Cómo? Googleando y preguntando en los foros a cada duda que me surge...Solo así se aprende, aunque "cagándola" me temo que también...

+1
0
-1

Ubuntu 14.04 LTS

Imagen de .doc
+1
0
-1

no estoy muy de acuerdo con lo que dices que diferencia a aptitude y de apt-get, pero no viene al caso. De todas formas, si prefieres hacer las cosas tomando precauciones, te recomiendo que antes de hacer algún cambio importante uses Clonezilla para crearte una imagen de tu partición root ( / ) 'antes del cambio', la cual puedes restaurar, si el cambio te disgusta, y así volver a la situación original de tu sistema. Es ideal, para esto, que tengas la /home montada en una partición distinta de la root (que, como se viene repitiendo, es muy recomendable)

En Google hay mucha información sobre Clonezilla, si te interesa puede venirte bien leer esto:
http://comoserdebianitaynomorirenelintento.blogspot.com.es/2012/03/clone...

+1
0
-1
Imagen de hectorsales
+1
0
-1

Gracias .doc por recomendarme Clonezilla.

En Google hay mucha información sobre Clonezilla, si te interesa puede venirte bien leer esto:
http://comoserdebianitaynomorirenelintento.blogspot.com.es/2012/03/clone...

+1
0
-1

Ubuntu 14.04 LTS