Paqutes rotos, por corte de suministro eléctrico, durante la instalación.

Imagen de aigo25
0 puntos

Hola a todos:
quiero contarles que, mientras se instalaban los paquetes, desde update manager, se cortó el suministro eléctrico. Cuando encendí la máquina, un símbolo de contramano ( un ícono rojo con una franja blanca) apareció en la barra del escritorio. El mismo dice lo siguiente:
El mensaje de error es:
"Error: BrokenCount>0".
Cuando voy a :
Mostrar actualizaciones, inicio la instalación de los paquetes.
Luego aparece lo siguiente:
The package system is broken
Y otro aviso que dice:
Crash report
The aplication Update Manager has closed unexpectedly.
En los detalles dice:
The following packages have unmet dependencies:
Y en los detalles dice:

libc6: Depends: libc-bin (= 2.15-0ubuntu10.2) but 2.15-0ubuntu10.2 is installed
libc6:i386: Depends: libc-bin (= 2.15-0ubuntu10) but 2.15-0ubuntu10.2 is installed
----------------------------------------------------------------------------------------------------------------------
Cuando inicio el Centro de software sucede lo siguiente:

Items cannot be installed or removed until the package catalog is repaired. Do you want to repair it now?
Once Update Manager has finished the repairs, you can close it and return to the store.
Le doy a reparar, pero me dice que:

Package operation failed.

Y en los detalles dice:

installArchives() failed: Error in function:
dpkg: error processing libc6 (--configure):
libc6:amd64 2.15-0ubuntu10.2 cannot be configured because libc6:i386 is in a different version (2.15-0ubuntu10)
dpkg: dependency problems prevent configuration of libc6-dev:
libc6-dev depends on libc6 (= 2.15-0ubuntu10.2); however:
Package libc6 is not configured yet.
dpkg: error processing libc6-dev (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libc-dev-bin:
libc-dev-bin depends on libc6 (>> 2.15); however:
Package libc6 is not configured yet.
libc-dev-bin depends on libc6 (<< 2.16); however:
Package libc6 is not configured yet.
dpkg: error processing libc-dev-bin (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libc6-i386:
libc6-i386 depends on libc6 (= 2.15-0ubuntu10.2); however:
Package libc6 is not configured yet.
dpkg: error processing libc6-i386 (--configure):
dependency problems - leaving unconfigured

Por favor si alguien me podría ayudar, no sé que debo hacer. No tengo experiencia en este tipo de asuntos. Gracias por su atención. Saludos .

Imagen de Gabriel_M
+1
0
-1

... abre una terminal y ejecuta:

apt-get update
apt-get dist-upgrade
apt-get install -f
dpkg --configure -a
apt-get clean

repite los comandos un par de veces

+1
0
-1
Imagen de aigo25
+1
0
-1

Hola Gabriel_M.
Muchas gracias por molestarte y atender a mi auxilio. Esto es lo que pasó:

sudo apt-get update
Ign http://dl.google.com stable InRelease
Obj http://dl.google.com stable Release.gpg
Ign http://archive.canonical.com precise InRelease
Ign http://extras.ubuntu.com precise InRelease
Ign http://security.ubuntu.com precise-security InRelease
Ign http://archive.ubuntu.com precise InRelease
Ign http://archive.ubuntu.com precise-updates InRelease
Obj http://dl.google.com stable Release
Obj http://archive.canonical.com precise Release.gpg
Des:1 http://security.ubuntu.com precise-security Release.gpg [198 B]
Obj http://extras.ubuntu.com precise Release.gpg
Obj http://archive.ubuntu.com precise Release.gpg
Obj http://dl.google.com stable/main amd64 Packages
Obj http://archive.canonical.com precise Release
Des:2 http://security.ubuntu.com precise-security Release [49,6 kB]
Obj http://extras.ubuntu.com precise Release
Des:3 http://archive.ubuntu.com precise-updates Release.gpg [198 B]
Obj http://dl.google.com stable/main i386 Packages
Ign http://dl.google.com stable/main TranslationIndex
Obj http://archive.ubuntu.com precise Release
Obj http://archive.canonical.com precise/partner amd64 Packages
Obj http://extras.ubuntu.com precise/main Sources
Des:4 http://archive.ubuntu.com precise-updates Release [49,6 kB]
Obj http://archive.canonical.com precise/partner i386 Packages
Ign http://archive.canonical.com precise/partner TranslationIndex
Obj http://extras.ubuntu.com precise/main amd64 Packages
Obj http://extras.ubuntu.com precise/main i386 Packages
Des:5 http://security.ubuntu.com precise-security/main amd64 Packages [172 kB]
Ign http://extras.ubuntu.com precise/main TranslationIndex
Obj http://archive.ubuntu.com precise/main amd64 Packages
Obj http://archive.ubuntu.com precise/restricted amd64 Packages
Obj http://archive.ubuntu.com precise/universe amd64 Packages
Obj http://archive.ubuntu.com precise/multiverse amd64 Packages
Obj http://archive.ubuntu.com precise/main i386 Packages
Obj http://archive.ubuntu.com precise/restricted i386 Packages
Obj http://archive.ubuntu.com precise/universe i386 Packages
Obj http://archive.ubuntu.com precise/multiverse i386 Packages
Obj http://archive.ubuntu.com precise/main TranslationIndex
Obj http://archive.ubuntu.com precise/multiverse TranslationIndex
Obj http://archive.ubuntu.com precise/restricted TranslationIndex
Obj http://archive.ubuntu.com precise/universe TranslationIndex
Des:6 http://archive.ubuntu.com precise-updates/main amd64 Packages [397 kB]
Des:7 http://security.ubuntu.com precise-security/restricted amd64 Packages [3.969 B]
Des:8 http://security.ubuntu.com precise-security/universe amd64 Packages [48,4 kB]
Des:9 http://security.ubuntu.com precise-security/multiverse amd64 Packages [2.180 B]
Des:10 http://security.ubuntu.com precise-security/main i386 Packages [178 kB]
Des:11 http://security.ubuntu.com precise-security/restricted i386 Packages [3.968 B]
Des:12 http://security.ubuntu.com precise-security/universe i386 Packages [48,6 kB]
Ign http://archive.canonical.com precise/partner Translation-es_ES
Des:13 http://security.ubuntu.com precise-security/multiverse i386 Packages [2.369 B]
Obj http://security.ubuntu.com precise-security/main TranslationIndex
Obj http://security.ubuntu.com precise-security/multiverse TranslationIndex
Obj http://security.ubuntu.com precise-security/restricted TranslationIndex
Obj http://security.ubuntu.com precise-security/universe TranslationIndex
Des:14 http://archive.ubuntu.com precise-updates/restricted amd64 Packages [6.755 B]
Des:15 http://archive.ubuntu.com precise-updates/universe amd64 Packages [143 kB]
Ign http://archive.canonical.com precise/partner Translation-es
Ign http://extras.ubuntu.com precise/main Translation-es_ES
Ign http://archive.canonical.com precise/partner Translation-en
Ign http://extras.ubuntu.com precise/main Translation-es
Obj http://security.ubuntu.com precise-security/main Translation-en
Obj http://security.ubuntu.com precise-security/multiverse Translation-en
Obj http://security.ubuntu.com precise-security/restricted Translation-en
Des:16 http://archive.ubuntu.com precise-updates/multiverse amd64 Packages [8.681 B]
Des:17 http://archive.ubuntu.com precise-updates/main i386 Packages [403 kB]
Ign http://extras.ubuntu.com precise/main Translation-en
Obj http://security.ubuntu.com precise-security/universe Translation-en
Des:18 http://archive.ubuntu.com precise-updates/restricted i386 Packages [6.732 B]
Des:19 http://archive.ubuntu.com precise-updates/universe i386 Packages [143 kB]
Des:20 http://archive.ubuntu.com precise-updates/multiverse i386 Packages [9.673 B]
Obj http://archive.ubuntu.com precise-updates/main TranslationIndex
Obj http://archive.ubuntu.com precise-updates/multiverse TranslationIndex
Obj http://archive.ubuntu.com precise-updates/restricted TranslationIndex
Obj http://archive.ubuntu.com precise-updates/universe TranslationIndex
Obj http://archive.ubuntu.com precise/main Translation-es
Obj http://archive.ubuntu.com precise/main Translation-en
Obj http://archive.ubuntu.com precise/multiverse Translation-es
Obj http://archive.ubuntu.com precise/multiverse Translation-en
Obj http://archive.ubuntu.com precise/restricted Translation-es
Obj http://archive.ubuntu.com precise/restricted Translation-en
Obj http://archive.ubuntu.com precise/universe Translation-es
Obj http://archive.ubuntu.com precise/universe Translation-en
Obj http://archive.ubuntu.com precise-updates/main Translation-es
Obj http://archive.ubuntu.com precise-updates/main Translation-en
Obj http://archive.ubuntu.com precise-updates/multiverse Translation-es
Obj http://archive.ubuntu.com precise-updates/multiverse Translation-en
Obj http://archive.ubuntu.com precise-updates/restricted Translation-es
Obj http://archive.ubuntu.com precise-updates/restricted Translation-en
Obj http://archive.ubuntu.com precise-updates/universe Translation-es
Obj http://archive.ubuntu.com precise-updates/universe Translation-en
Ign http://dl.google.com stable/main Translation-es_ES
Ign http://dl.google.com stable/main Translation-es
Ign http://dl.google.com stable/main Translation-en
Descargados 1.677 kB en 40seg. (41,5 kB/s)
Leyendo lista de paquetes... Hecho

sudo apt-get dist-upgrade
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Tal vez quiera ejecutar «apt-get -f install» para corregirlo.
Los siguientes paquetes tienen dependencias incumplidas:
libc6 : Rompe: libc6:i386 (!= 2.15-0ubuntu10.2) pero 2.15-0ubuntu10 está instalado
libc6:i386 : Depende: libc-bin:i386 (= 2.15-0ubuntu10)
Rompe: libc6 (!= 2.15-0ubuntu10) pero 2.15-0ubuntu10.2 está instalado
E: Dependencias incumplidas. Pruebe de nuevo usando -f.

sudo apt-get install -f
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Corrigiendo dependencias... Listo
Se instalarán los siguientes paquetes extras:
libc6:i386
Paquetes sugeridos:
glibc-doc:i386 locales:i386
Se actualizarán los siguientes paquetes:
libc6:i386
1 actualizados, 0 se instalarán, 0 para eliminar y 20 no actualizados.
5 no instalados del todo o eliminados.
Necesito descargar 3.935 kB de archivos.
Se utilizarán 20,5 kB de espacio de disco adicional después de esta operación.
¿Desea continuar [S/n]? s
Des:1 http://security.ubuntu.com/ubuntu/ precise-security/main libc6 i386 2.15-0ubuntu10.2 [3.935 kB]
Descargados 3.935 kB en 15seg. (258 kB/s)
E: Internal Error, No file name for libc6

sudo dpkg --configure -a
dpkg: error al procesar libc6 (--configure):
libc6:amd64 2.15-0ubuntu10.2 cannot be configured because libc6:i386 is in a different version (2.15-0ubuntu10)
dpkg: problemas de dependencias impiden la configuración de libc6-dev:
libc6-dev depende de libc6 (= 2.15-0ubuntu10.2); sin embargo:
El paquete `libc6' no está configurado todavía.
dpkg: error al procesar libc6-dev (--configure):
problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de libc-dev-bin:
libc-dev-bin depende de libc6 (>> 2.15); sin embargo:
El paquete `libc6' no está configurado todavía.
libc-dev-bin depende de libc6 (<< 2.16); sin embargo:
El paquete `libc6' no está configurado todavía.
dpkg: error al procesar libc-dev-bin (--configure):
problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de libc6-i386:
libc6-i386 depende de libc6 (= 2.15-0ubuntu10.2); sin embargo:
El paquete `libc6' no está configurado todavía.
dpkg: error al procesar libc6-i386 (--configure):
problemas de dependencias - se deja sin configurar
Se encontraron errores al procesar:
libc6
libc6-dev
libc-dev-bin
libc6-i386

sudo apt-get clean

Hasta aquí llega .

+1
0
-1
Imagen de kupley
+1
0
-1

Gabriel_M aunque ya no te servirá yo metí en la terminal estos dos comandos (no a la vez :)):
apt-get update
apt-get dist-upgrade

Una vez aquí la terminal te sugiere:

sudo apt-get dist-upgrade
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Tal vez quiera ejecutar «apt-get -f install» para corregirlo.
Los siguientes paquetes tienen dependencias incumplidas:
libc6 : Rompe: libc6:i386 (!= 2.15-0ubuntu10.2) pero 2.15-0ubuntu10 está instalado
libc6:i386 : Depende: libc-bin:i386 (= 2.15-0ubuntu10)
Rompe: libc6 (!= 2.15-0ubuntu10) pero 2.15-0ubuntu10.2 está instalado
E: Dependencias incumplidas. Pruebe de nuevo usando -f.

En tu caso, en vez de poner lo que te aconseja la terminal: sudo apt-get -f install
tú pones: sudo apt-get install -f

Al principio di la orden como tú y llegué donde tu llegaste, la segunda vez que lo probé puse lo que ponía en la terminal y me arreglo el paquete roto y pude actualizar desde el gestor de actualizaciones todo lo demás.

Saludos!

+1
0
-1

Novataaaa