Paquetes rotos

Imagen de numael
0 puntos

Hola a todos!

Tengo un problema, tenia instalada la version 11.10 de ubuntu y tenia varios problemas con la tarjeta gráfica del equipo, entonces actualicé a 12.04 los problemas de la tarjeta gráfica se solucionaron, ahora me quedo el problema que no puedo instalar wine ni teamviewer ni ia32-libs.

al intentar instalar ia32libs me pide ia32libs-multiarch, al intentar instalar este ultimo me dice que he retenido paquetes rotos, si entro en synaptyc y selecciono la opcion de roto o rotos no me muestra ninguna paquete, he intentado lo ste que he encontrado en varios post.

- quite todos los repositorios no oficiales de ubuntu.
- cambie el servidor de descarga de ubuntu (Cento de software/editar/origenes -> Descarga desde)
- sudo apt-get update
- sudo apt-get -f install
- sudo apt-get autoremove
- sudo apt-get upgrade

con los anteriores comandos me dice, nada por instalar o actualizar

- sudo deborphan --guess-all
con el anterior muestra una serie de paquetes (muchos)

no se que tengo mal.

al intentar instalar wine por synaptic me pide desinstalar 34 paquetes entre ellos ubuntu-desktop y unity, unity-2d y otros.

agradezco cualquier ayuda que me puedan prestar he leido varios foros pero ninguno me ha dado solución.

no quiero hacer una instalación limpia ya que tengo mucho programas instalados y configurados que necesito.

Imagen de gledof
+1
0
-1

$ sudo dpkg --configure -a

Luego
$ sudo apt-get update
$ sudo apt-get upgrade

+1
0
-1

Saludos.----

Imagen de numael
+1
0
-1

probe los comandos que me pasaste pero no me funcionaron, no entiendo por que el paquete ia32-libs entra en conflito con libmesa, unity, ubuntu-desktop y muchos otros.

+1
0
-1
Imagen de jccall80
+1
+1
-1

Has instalado repositorios de procedencia dudosa últimamente??

Un motivo puede ser este.

Prueba con

sudo aptitude full-upgrade

si no tienes instalado aptitude instalalo con

sudo apt-get install aptitude

se que mucho estaran en contra pero si fuera de ti reinstalaria el sistema de cero. Las actualizaciones de una versión a otra no me acaban de convencer.

+1
+1
-1
Imagen de Goyo
+1
0
-1

Pega la salida de
apt-cache policy wine

+1
0
-1
Imagen de numael
+1
0
-1

Probe los 2 ultimos comandos aca están los resultados

sudo aptitude full-upgrade
No se instalará, actualizará o eliminará ningún paquete.
0 paquetes actualizados, 0 nuevos instalados, 0 para eliminar y 0 sin actualizar.
Necesito descargar 0 B de archivos. Después de desempaquetar se usarán 0 B.

apt-cache policy wine
wine:
Instalados: (ninguno)
Candidato: 1.4-0ubuntu4.1
Tabla de versión:
1.4-0ubuntu4.1 0
500 http://archive.ubuntu.com/ubuntu/ precise-updates/universe amd64 Packages
1.4-0ubuntu4 0
500 http://archive.ubuntu.com/ubuntu/ precise/universe amd64 Packages

+1
0
-1
Imagen de Goyo
+1
0
-1

Intenta instalar wine con apt-get
sudo apt-get install wine
Si aparece algún error o propone desinstalar otros paquetes cancela y pega aquí la salida.

+1
0
-1
Imagen de numael
+1
0
-1

sudo apt-get install wine
[sudo] password for usuario:
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios no han sido creados o han
sido movidos fuera de Incoming.
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
wine : Depende: wine1.4 pero no va a instalarse
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.

+1
0
-1
Imagen de Goyo
+1
0
-1

Pues habría que hacer lo mismo con wine1.4
sudo apt-get install wine1.4

+1
0
-1