E: Internal Error, No file name for libapt-pkg4.12

Imagen de Alejandro Ruiz
0 puntos

al parecer algunos paquetes están rotos, el problema es que no los puedo reparar me sale un mensaje que dice así:

nstallArchives() failed: dpkg: error processing libapt-pkg4.12 (--configure):
libapt-pkg4.12:amd64 0.8.16~exp12ubuntu10.3 cannot be configured because libapt-pkg4.12:i386 is in a different version (0.8.16~exp12ubuntu10.2)

en synaptic, en el apartado de dependencias rotas me aparecen dos que son las siguientes:
libapt-pkg4.12 y libapt-pkg4.12:1386

buscando en internet probé con esta opción apt-get -f install y me aparece el siguiente error:

Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Corrigiendo dependencias... Listo
Los paquetes indicados a continuación se instalaron de forma automática y ya no son necesarios.
libunique-1.0-0 kde-l10n-es language-pack-kde-zh-hans-base
wine-gecko1.5:i386 kde-l10n-engb language-pack-zh-hans-base kde-l10n-zhcn
language-pack-zh-hans language-pack-kde-zh-hans
Utilice «apt-get autoremove» para eliminarlos.
Se instalarán los siguientes paquetes extras:
libapt-pkg4.12:i386
Se actualizarán los siguientes paquetes:
libapt-pkg4.12:i386
1 actualizados, 0 se instalarán, 0 para eliminar y 83 no actualizados.
1 no instalados del todo o eliminados.
Se necesita descargar 0 B/941 kB de archivos.
Se utilizarán 0 B de espacio de disco adicional después de esta operación.
¿Desea continuar [S/n]? s
E: Internal Error, No file name for libapt-pkg4.12

Igual trate desde synaptic en dependencias rotas que son como ya comenté libapt-pkg4.12 y libapt-pkg4.12:1386 y les puse marcar para reinstalar y me aparece el mismo error :
E: Internal Error, No file name for libapt-pkg4.12
también traté de descargar el paquete.deb desde ubuntu pero por obvias razones de que no puedo instalar me aparece: Falló la operación con el paquete

¿Que puedo hacer? ya busqué de muchas formas y no encuentro solución
agradezco cualquier ayuda

Imagen de Goyo
+1
0
-1

¿Cuál es la salda de esto?
apt-cache policy libapt-pkg4.12:i386

+1
0
-1
Imagen de nolin
+1
0
-1

EL problema te lo dice al principio:
0.8.16~exp12ubuntu10.3 <==> 0.8.16~exp12ubuntu10.2
El paquete que quieres instalar no coincide en versión con otras cosas necesarias ("dependencias") que ya tienes instaladas. Por ejemplo, dicho paquete es más antiguo y no quisieras machacar lo más nuevo, ¿verdad?
En tu caso parece que quieres algo para amd64 cuando lo que viene es para 386. Tendrías que bajar la versión que coincida con tu instalación de Ubuntu.

+1
0
-1
Imagen de Alejandro Ruiz
+1
0
-1

Ok, gracias por tomarte el tiempo en ayudarme nolin, pero verás. No tengo mucha experiencia en esto, el problema no es el paquete en si, el problema viene de que en realidad no quiero instalar un paquete en especifico, lo que quiero es instalar las actualizaciones pero me sale el típico error de el paquete de sistema está roto, ya desactivé los paquetes de terceros, utilicé apt-get install -f y todo lo que mencioné en el primer comentario. El problema es exactamente como dices pero como instalo la versión que necesito?

+1
0
-1