DC Samba4 + Ubuntu server 11.04, consulta puntual

Imagen de pixma
0 puntos

Hola a todos.

Hace unos meses que vengo probando samba4 y su integración con Active directory, hasta ahora está funcionando correctamente, con sus usuarios, permisos, gpo, etc etc, incluso está casi pronto para ponerse en producción, pero he aquí un tema que no lo había probado y me está complicando un poco y es lo siguiente,

Si desde un XP (por ejemplo) voy a mis sitios de red, veo todas las máquinas que he subido al dominio pero NO al dominio, obviamente si hago inicio->ejecutar y pongo la ip o el nombre logro ver todas las carpetas que éste tiene compartida, pero no tengo forma de hacerlo con el procedimiento descrito más arriba, esto me limita dado que aquellos usuarios que no tengan permisos para ejecutar, no podrán acceder a los recursos compartidos que tengo en mi servidor con samba4.

Alguien sabe en donde o que tengo que configurar para que pueda ver desde los windows el servidor??

Otra consulta relacionada.

Cada vez que accedo por ip o por nombre del servidor y éste me abre una carpeta con el nombre Samba 4.0.0beta7GIT-d....., el nombre del recurso compartido IPC$ es samba4.0.0beta.......... y eso lo quiero cambiar por algo que diga solo "samba", tienen idea de como tendría que hacer para cambiar ese nombre? no he encontrado aún la forma.

Saludos y gracias

Imagen de berdol
+1
0
-1

Hola pixma.
Con el xp, abriendo el explorador desde inicio, mipc y escribiendo donde pone MiPC sustituir por \\IPMAQUINA se puede acceder a dicha maquina en linux.
No he utilizado el samba4, pero si he configurado máquinas con ubuntu server para introducirlas en un domino de windows 2003 server, para que puedan compartir carpetas y sean servidor de bases de datos, ademas de que los usuarios se puedan conectar remotamente a estas máquinas con su usuario windows, al acceder a las carpetas situadas en las maquinas linux, me sale solamente samba, esto es debido a que en el archivo de configuración de samba el smb.conf situado en el /etc/samba/smb.conf en la parte de "server string =" tengo puesto:
"server string =samba", supongo que tu tendras puesto:
"server string =Samba4.0.0beta7GIT-d...", en el caso que samba4 utilice los mismos parametros que la versión de samba que tengo yo.
Sino recuerdo mal es la 2.xx o la 3.x, ya que de todo esto hace más de dos años.
Espero que te sirva.

+1
0
-1
Imagen de modestillo
+1
0
-1

Puedes probar a instalar likewise, es lo que yo uso, de esa manera puedes unir la máquina al active directory y asi los usuarios de acceso a samba son los mimos del active directory.

Luego instala el paquete acl para poner permisos.

Saludos

+1
0
-1