Instalar un programa con win pero sin paquete de instalación

Imagen de analiticas
0 puntos

Quisiera saber sí es posible,ejecutar un programa creado para Windows, pero que no tiene instalación,me explico:se copian los directorios en c:, se copia una dll a system 32 y se retoca el autoexec.bat y config.sys,luego se reinicia y ya esta instalado.
Se qué debe de ser una pregunta tonta para alguien que sepa, pero lo he intentado con Wine,Crossover y sin olvidar dosemu , pero no lo logro.muchas gracias a todos.y si podéis echarme un cable os lo agradeceria.

Imagen de Goyo
+1
0
-1

Sí es posible.

+1
0
-1
Imagen de analiticas
+1
0
-1

Te importaría, ser un poco más explícito.y muchas gracias.

+1
0
-1
Imagen de Goyo
+1
0
-1

¿Quieres decir que adivine cuál es el programa, que dlls hay que copiar y adónde y qué cambios hay que hacer en autoexec.bat y en config.sys? Me temo que eso está más allá de mi capacidad.

De todas formas sé poco de windows y apenas he usado wine. Lo que sí puedo asegurarte es que muchos programas que no tienen un archivo de instalación pueden ejecutarse en wine.

+1
0
-1
Imagen de analiticas
+1
0
-1

Perdón,la dll la tengo y controlada, los cambios en el autoexec y el config también los tengo, el programa es uno especial para clínicas, lo he instalado muchas veces en Windows xp, Per. Quiero cambiar a ubuntu, y no se cómo hacerlo,otra vez lo siento, pensé que me había explicado bien en la primera pregunta. Gracias

+1
0
-1
Imagen de gato2707
+1
0
-1

de wine (.wine) encontrarás carpetas que simulan ser las de W$, por ejemplo drive_c, y dentro de ellas los directorios que necesitas (\windows, \program files, etc.)

Puedes usar para instalar el ellas tus programas como si se tratara del propio W$

Para ejecutar tu programa deberás usar un comando desde la consola similar a:

$ wine ruta_a_tu_programa/nombre_de_tu_programa

En cuanto a la compatibilidad, solamente tú podrás contarnos después ya que no das más información

+1
0
-1

Saludos desde México
Mi Web: El Gato con Linux

Imagen de analiticas
+1
0
-1

Lo que no consigo es que ejecute el autoexec y el config, como lo haría en w$, y al faltar esos parámetros, me da un pantallazo y se va. Tu sabrías como ejecutarlos al inicio?
Muchas Gracias

+1
0
-1