Problema con 70-persistent-net.rules

Imagen de juanpthebest
0 puntos

Hola a todos, tengo un serio problema y por mas que busco no encuentro una solución factible. Explico:
He instalado un 2a tarjeta de red en mi servidor (la realidad era cambiar la actual integrada 10/100 mb por la nueva de 1000 mb y luego cambiar el nombre de la interface de eth1 a eth0 para no tener que re-configurar todo).

Entro en /etc/udev/rules.d/70-persistent-net.rules y la nueva tarjeta no aparece reflejada... reinicio de nuevo y nada.
Hago un:

ifconfig -a aparece perfectamente (eth0, eth1 y lo)
lspci también aparece

Navegando descubro que ubuntu genera automáticamente este archivo (70-persistent-net.rules) en cada arranque (es cierto -_-?) y leyendo en varios foros dicen que lo mas sencillo es borrarlo y este se me regenerara automáticamente con la nueva configuración... lo hago y pum ya no tengo archivo. (no se regenera) En mi frustrado intento de arreglarlo he mirado y mirado y parece ser que hay que tocar el archivo: /lib/udev/rules.d/75-persistent-net-generator.rules pero no me atrevo porque no se ni papa de programación. Me podeis echar una mano ???

Gracias anticipadas.

Imagen de donatelo26
+1
+1
-1

io tenia un problema similar pero era con una ip, no me la cambiaba, edite este archivo y wala /etc/network/interfaces, ademas te dejo con un link interesante
http://manpages.ubuntu.com/manpages/lucid/man5/interfaces.5.html

+1
+1
-1
Imagen de juanpthebest
+1
0
-1

Gracias por tu respuesta, pero mi problema no reside ahi, sino en el archivo que mencione antes. La configuracion de "interfaces" esta correcta aunque sirve de poco si no me reconoce los adaptadores de red. Me duele la cabeeza de googlear buscando soluciones xD

+1
0
-1
Imagen de juanpthebest
+1
0
-1

¡¡¡ Al final lo conseguí !!! la solución era sencilla si se pensaba un poco :) Cargue un cd de ubuntu 12.04 y lo cargue en live y use el archivo que genero y lo copie en la instalación de mi servidor. Todo funciona genial aunque me hubiese gustado que volviese a generarlo el solo :)

+1
0
-1
Imagen de cess cess
+1
0
-1

Bueno, yo tengo una tarjeta de red atheros ar8152 fast ethernet, que viene con mi laptop Toshiba c640 y intente instalar el driver un ubuntu me baje el driver de una pagina, mas o menos se llama así compat-wireless 6.2, instalo con unas sentencias que encontre googleando:
.
.
sudo make install
.
.
Pero cuando hago sudo modprobe atl1c

Me sale : Fatal error, no se encuentra el archivo

Entonces me dirigi a la carpeta /etc/udev/rules.d/70-persistant-net.rules

No me aparece el eth0

Pero no se como modificarla, dice que no se puede

+1
0
-1