Instalables .run (solucionado)

Imagen de drtxus
0 puntos

Hola a todos, mi problema es referido a la instalación o mas bien a la ejecución de un archivo con extensión .run. Por más que he probado, no hace nada de nada, este es el archivo mplabx-ide-v1_51-linux-installer.run . He activado la casilla de ejecutar como un programa.
He probado haciendo doble clic y no sale nada, también he probado estas opciones en terminal y tampoco:

./mplabx-ide-v1_51-linux-installer.run
sudo ./mplabx-ide-v1_51-linux-installer.run aqui me pide la contraseña, la introduzco y vuelve a su estado normal.

También puse esto:

sh mplabx-ide-v1_51-linux-installer.run
y este es el error que sale
mplabx-ide-v1_51-linux-installer.run: 1: mplabx-ide-v1_51-linux-installer.run: Syntax error: "(" unexpected

Dandole clic derecho al archivo me deja abrir con otra aplicación pero no encuentro la terminal de, todas maneras no creo que funcionase, y tampoco me aparece la opción de ejecutar en terminal.

Ya estoy un poco desesperado y se que es algo que está mal configurado pero creo que lo he rebuscado ya todo. Si ha alguien se le ocurre alguna cosa, lo que sea estaría muy agradecido.

Un saludo

Imagen de Alcruz
+1
0
-1

Prueba esto
Abre un terminal y pones
sudo bash
dejas un espacio
arrastra el archivo .run a ese terminal
puelsa Enter
de todas maneras tienes que leer los readme, no todos se instalan o ejecutan de la misma forma, , pero esta sería la forma mas generalizada

+1
0
-1
Imagen de drtxus
+1
0
-1

Hola compañero, ante todo muchas gracias por tu pronta respuesta, también lo he probado pero me lanza el siguiente error

/home/Descargas/mplabx-ide-v1_51-linux-installer.run: /home/Descargas/mplabx-ide-v1_51-linux-installer.run: no se puede ejecutar el fichero binario
El readme me lo lei, incluso algun video http://www.youtube.com/watch?v=T9rjfMjQqrQ , el problema es que a mi no me sale lo que dicen.

+1
0
-1
Imagen de Alcruz
+1
0
-1

Tal vez requira tener instado
build-essential

+1
0
-1
Imagen de drtxus
+1
0
-1

Gracias de nuevo Alcruz, hoy te voy a dar el dia jejejeje, mira lo he comprobado y esta instalado

http://ubuntuone.com/6wdim0Zp6v4q4oSaI6jP50

+1
0
-1
Imagen de drtxus
+1
0
-1

Ya esta ya lo he conseguido instalar, ufff que trabajito.

Lo volvi a descargar, cuando me dijistes que mirara si tenia instalado build-essential mire un poco más abajo y active para que se instalara sbuild.
Despues de esto se me ejecuto el instalable, no se si tiene algo que ver pero lo importante es que ya está instalado.

Muchas gracias compañero de ubuntu sin ti no lo hubiese conseguido.

Un saludo

+1
0
-1
Imagen de juanpabloconcha
+1
0
-1

Muchas gracias por la solución.

Saludos

+1
0
-1