(Solucionado) No entro al modo gráfico (atrapado en tty)

Imagen de ramvel
0 puntos

Buenas tardes, soy nuevo aquí.
Un saludo a todos por el año nuevo.

Mi problema es que al iniciar, se va directamente a tty.
Me pide usuario y contraseña. Pero para entrar al entorno gráfico antes le daba un 'startx', pero ahora no me funciona.

Me sale

...(resumo)...

Fatal server error:
no screens found

Please consult the The X.org Foundation support
          at http://wiki.x.org
for help
Please also check the log file at "/var/log/Xorg.0.log" for additional information.
 ddxSigGiveUp: Closing Log
giving up.
xinit: No such file or directory (errno 2): unable to connect to X server
xinit: No such process (errno 3): Server error.

Agradecería me ayuden a volver al modo normal "entorno gráfico".
Feliz Año, gracias anticipadas.

Imagen de quimr
+1
0
-1

Muchas gracias ramvel! A mi:

sudo mv ~/xorg.conf.new /etc/X11/xorg.conf

también me ha solucionado el problema!

+1
0
-1
Imagen de HenryCase
+1
0
-1

Buenas, a mi me ocurrió algo parecido, solo me dejaba entrar por consola y todo eso, pero descubrí que con el usuario invitado me dejaba entrar a modo gráfico, por lo que pensé que el problema estaría en el perfil de usuario, después de hacer varia pruebas y chaparme un montón de logs llegue a la conclusión de que no podía acceder a archivos por permisos, la solución, imaginemos que es patxi el nombre de usuario y que su carpeta de perfil esta en /home/patxi -->

cd /home
chown -R patxi patxi

Y taaachan, reinicias entras y todo ok. A ver si con esto consigo ahorrar un poco de tiempo a alguien.
Un saludo a toda la comunidad Linuxera.

;-)

+1
0
-1

Páginas