Fallo de instalacion de Ubuntu

Imagen de bildeo
0 puntos

Al intentar instalar Ubuntu 12.4.01 LTS desde un USB me fallo la instalacion y ahora no puedo arrancar w7 ,parece que se ha fastidiado el MBR.
He intentado repararlo con ms-sys pero me sale esto:

ubuntu@ubuntu:~$ sudo fdisk -l

Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders, total 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0xe1577d15

Device Boot Start End Blocks Id System
/dev/sda1 63 2047 992+ 42 SFS
Partition 1 does not start on physical sector boundary.
/dev/sda2 2048 409599 203776 42 SFS
/dev/sda3 * 409600 1000927231 500258816 42 SFS

Disk /dev/sdb: 8100 MB, 8100249600 bytes
256 heads, 51 sectors/track, 1211 cylinders, total 15820800 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xc3072e18

Device Boot Start End Blocks Id System
/dev/sdb1 * 12144 15820799 7904328 b W95 FAT32
ubuntu@ubuntu:~$ sudo ms-sys -7 /dev/sda3
/dev/sda3 seems to be a disk partition device,
use the switch -f to force writing of a master boot record
ubuntu@ubuntu:~$ sudo ms-sys -f /dev/sda3
/dev/sda3 has an x86 boot sector,
it is an unknown boot record

Podeis ayudarme a reparar esto ,no tengo cd de recuperacion y no puedo
ni instalar w7 ni por supuesto Ubuntu que era el objetivo
Gracias y un saludo.

Imagen de Gabriel_M
+1
0
-1

... esta en el disco no en la partición.

sudo su 
ms-sys -7 /dev/sda
+1
0
-1
Imagen de bildeo
+1
0
-1

Gracias. Lo he hecho y sigue igual ,aunque despues del comando me devolvió que habia sido grabado un nuevo mbr con exito. Pero en el arranque me pide el disco de instalacion .
Estoy realizando un test de memoria , es lo único que me permite windows.

+1
0
-1