Ubuntu 12.04 no reconoce dispositivo ethernet tarjeta de red (solucionado)

Imagen de MrDarkmian
0 puntos

Saludos tal vez me pueda ayudar alguien tengo una toshiba NB515 netbook einstalado ubuntu 12.04 pero no reconoce tarjeta de red el dispositivo ethernet, es decir tengo internet pero solo con wireless no con cable. la terjeta de red es una Atheros AR8162/8166/8168 PCI-E Fast Ethernet Controller (NDIS 6.20) asi es como sale en windows 7.

Agradeceria su ayuda

Imagen de Gabriel_M
+1
0
-1

sudo su
lspci
lsusb
ifconfig -a
ifconfig
iwconfig

Copia y pega las salidas en el post.

+1
0
-1
Imagen de MrDarkmian
+1
0
-1

damian@damian-PC:~$ sudo su
[sudo] password for damian:
root@damian-PC:/home/damian# lspci
00:00.0 Host bridge: Intel Corporation Atom Processor D2xxx/N2xxx DRAM Controller (rev 04)
00:02.0 VGA compatible controller: Intel Corporation Atom Processor D2xxx/N2xxx Integrated Graphics Controller (rev 0b)
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 2 (rev 02)
00:1d.0 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #1 (rev 02)
00:1d.1 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 02)
00:1d.2 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 02)
00:1d.3 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 02)
00:1d.7 USB controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation NM10 Family LPC Controller (rev 02)
00:1f.2 SATA controller: Intel Corporation N10/ICH7 Family SATA Controller [AHCI mode] (rev 02)
00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 02)
01:00.0 Ethernet controller: Atheros Communications Inc. AR8162 Fast Ethernet (rev 10)
02:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
root@damian-PC:/home/damian# lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 003: ID 10f1:1a34 Importek
Bus 004 Device 002: ID 0cf3:3005 Atheros Communications, Inc. AR3011 Bluetooth
root@damian-PC:/home/damian# ifconfig -a
lo Link encap:Bucle local
Direc. inet:127.0.0.1 Másc:255.0.0.0
Dirección inet6: ::1/128 Alcance:Anfitrión
ACTIVO BUCLE FUNCIONANDO MTU:16436 Métrica:1
Paquetes RX:375 errores:0 perdidos:0 overruns:0 frame:0
Paquetes TX:375 errores:0 perdidos:0 overruns:0 carrier:0
colisiones:0 long.colaTX:0
Bytes RX:61163 (61.1 KB) TX bytes:61163 (61.1 KB)

wlan0 Link encap:Ethernet direcciónHW 24:ec:99:93:7c:e4
Direc. inet:192.168.2.102 Difus.:192.168.2.255 Másc:255.255.255.0
Dirección inet6: fe80::26ec:99ff:fe93:7ce4/64 Alcance:Enlace
ACTIVO DIFUSIÓN FUNCIONANDO MULTICAST MTU:1500 Métrica:1
Paquetes RX:4779 errores:0 perdidos:0 overruns:0 frame:0
Paquetes TX:4629 errores:0 perdidos:0 overruns:0 carrier:0
colisiones:0 long.colaTX:1000
Bytes RX:5807772 (5.8 MB) TX bytes:651048 (651.0 KB)

root@damian-PC:/home/damian# iwconfig
lo no wireless extensions.

wlan0 IEEE 802.11bgn ESSID:"DACR.NET"
Mode:Managed Frequency:2.437 GHz Access Point: F8:D1:11:75:CA:5C
Bit Rate=48 Mb/s Tx-Power=16 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:on
Link Quality=70/70 Signal level=-40 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:19 Invalid misc:200 Missed beacon:0

root@damian-PC:/home/damian#

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

... la información obtenida tienes dos tarjetas de red:

02:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter 

Reconocida y funcionante con wlan0

01:00.0 Ethernet controller: Atheros Communications Inc. AR8162 Fast Ethernet (rev 10)

Listada, pero completamente ignorada, ni siquiera ifconfig la visualiza.
Es necesario:
Descargar el driver de aqui:
http://www.orbit-lab.org/kernel/compat-wireless-3-stable/v3.5/compat-wir...
Descomprimir el archivo

tar -xf compat-wireless-3.5.1-1-snpc.tar.bz2

Instalar las dependencias necesarias, cambiar al directorio, seleccionar el script, compilar e instalar

sudo su
apt-get update
apt-get install build-essential  linux-headers-`uname -r`
cd compat-wireless-3.5.1-1-snpc
./scripts/driver-select alx
make
make install
modprobe alx
nano /etc/modules
(añadir al final la línea)
alx

Guardar el archivo (Control + O)
Cerrar nano (Control + X)

Ten presente que no puedes conectarte a internet con las dos tarjetas a la vez o una u otra y si te conectas a internet y a una red lan, la conexión a la lan no lleva gateway.

+1
0
-1
Imagen de MrDarkmian
+1
0
-1

Muchas gracias amigo, espero algun día tener esa experiencia en GNU-Linux

Saludos desde Ecuador

+1
0
-1
Imagen de FERCHO-278
+1
0
-1

**/Moderado/**

Las preguntas en su propio hilo por favor. Gracias.

+1
0
-1

FERCHO-278

Imagen de Gabriel_M
+1
0
-1

... tiene una Realtek RTL8100C - 10/100 Controller incorporada, dado que no aparece en el sistema infiero que ha dejado de funcionar.
Deberás agregarle una tarjeta de red pci nueva.

+1
0
-1
Imagen de TetTaYuu
+1
-1
-1

**/Moderado/**

No secuestres un hilo que no es tuyo. Gracias.

+1
-1
-1
Imagen de Jose Luis 1320
+1
0
-1

Abre un nuevo hilo indicando;

Versión de Ubuntu que tienes.

El comando lsusb es totalmente inútil en tu caso, puesto que no revela absolutamente algún dispositivo de red, hay que comprender lo que se lee primero. ¿Usas algun módem por USB? si no es así no tiene caso que pongas la salida de lsusb.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de TetTaYuu
+1
0
-1

Realmente posteo aqui porque tengo la misma version de ubuntu y por supuesto la misma tarjeta de red, ademas lo de lsusb no lo sabia solo llevo 1 dia de usar ubuntu.

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

No vas a secuestrarlo ni invadirlo. Abre un nuevo hilo especificando:

- Versión de Ubuntu.
- Lo que has hecho para solucionar el problema y como lo has hecho.
- Las salidas de los comandos lspci e ifconfig.

De otra manera no será posible que te ayuden, llevas usando Ubuntu 1 día, ¿me compete a mí?.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro