no detecta webcam sony vaio vgn-fe41e: solucionado!

Imagen de jose75
0 puntos

Hola! Soy novato en Ubuntu y todo ha ido bien hasta ahora...ya que no detecta la webcam integrada de mi portátil. He probado con aMSN y cuando le doy a configurar cámara me dice que no se detecta ninguna. Alguien me podría explicar paso a paso (recordad: novato 100%) cómo puedo hacer para solucionar el problema? Gracias!!!

Imagen de ketk
+1
0
-1

Sólo tienes que seguir los pasos que se describen en la web del desarrollador del driver: http://www.palmix.org/r5u870-en.html
Descarga el driver para el kernel kernel 2.6.30 (supongo que tienes karmic y este driver funciona en karmic), descomprímelo y deja el directorio resultante en tu directorio personal.
Abre un terminal e introduce los siguientes comandos uno a uno:

cd r5u870-0.10.1
sudo make
sudo make install
modprobe r5u870 

Después de esto ya debería funcionar la webcam.


TuVela.com información, tutoriales, curiosidades y más sobre Ubuntu, GNU/Linux y otros temas de mi interés. 6b 65 74 6b

+1
0
-1

TuVela.com información, tutoriales, curiosidades y más sobre Ubuntu, GNU/Linux y otros temas de mi interés. 6b 65 74 6b


Imagen de jose75
+1
0
-1

Siento ser tan "tonto" para esto...pero sigo teniendo problemas. Me he bajado el driver (creo) de la web: http://www.palmix.org/r5u870-en.html. Ahí me da varias opciones:

1) driver for kernel 2.6.30: amd64 (64bit) and i386 (32bit)
2) driver for kernel 2.6.27: amd64/i386

¿Cuál es el que debo bajar? Yo no sé qué versión de Kernel tengo (ni sé dónde mirarlo).

Luego metí los comandos que tú me dijistes y me devuelve el siguiente mensaje:

bash: cd: r5u870-0.10.1: No existe el fichero ó directorio

¿Qué hago mal? ¿Qué debo hacer?

Gracias...y repito...siento ser tan torpe!

+1
0
-1
Imagen de ketk
+1
0
-1

Depende qué versión tengas si tienes karmic (9.10) como te dije antes tienes que descargar el del kernel 2.6.30 y si es 32 o 64bit depende de cuál instalases.
Abre el terminal e introduce:

uname -a

Fíjate en lo que te sale, si al final pone "x86_64 GNU/Linux" tienes que descargar 64bit en otro caso descarga la de 32bit.
Después de eso haz clic derecho en lo que descargaste y luego en Extraer aquí. Mueve el directorio resultante a tu directorio personal y sigue los pasos que te describí.


TuVela.com información, tutoriales, curiosidades y más sobre Ubuntu, GNU/Linux y otros temas de mi interés. 6b 65 74 6b

+1
0
-1

TuVela.com información, tutoriales, curiosidades y más sobre Ubuntu, GNU/Linux y otros temas de mi interés. 6b 65 74 6b


Imagen de jose75
+1
0
-1

Hola! Una vez que introduje en el terminal lo de "uname -a" me sale esto:

Linux jose 2.6.31-14-generic #48-Ubuntu SMP Fri Oct 16 14:04:26 UTC 2009 i686 GNU/Linux

+1
0
-1
Imagen de ketk
+1
0
-1

Como dije antes:

Fíjate en lo que te sale, si al final pone "x86_64 GNU/Linux" tienes que descargar 64bit en otro caso descarga la de 32bit.

A tí según me has dicho te pone:

i686 GNU/Linux

Por tanto debes descargar el de 32bit.

Si lo quieres rápido y fácil introduce esta secuencia de comandos en el terminal y todo debería ir bien:

wget http://www.palmix.org/download/r5u870_k2.6.30_i386.tar.bz2
tar xvfz r5u870-0.10.1.tar.gz
cd r5u870-0.10.1
sudo make
sudo make install
modprobe r5u870 

TuVela.com información, tutoriales, curiosidades y más sobre Ubuntu, GNU/Linux y otros temas de mi interés. 6b 65 74 6b

+1
0
-1

TuVela.com información, tutoriales, curiosidades y más sobre Ubuntu, GNU/Linux y otros temas de mi interés. 6b 65 74 6b


Imagen de jose75
+1
0
-1

De verdad que ya me da vergüenza...parece que soy un inútil, pero me sigue dando error. Te voy a pegar aquí lo que me va diciendo.

Hice lo que tú me dijiste, el método rápido, meto la primera secuencia:

wget http://www.palmix.org/download/r5u870_k2.6.30_i386.tar.bz2

...y parece que todo bien.

Luego meto la segunda:

tar xvfz r5u870-0.10.1.tar.gz

...y me sale esta info:

tar: r5u870-0.10.1.tar.gz: No se puede open: No existe el fichero ó directorio
tar: El error no es recuperable: salida ahora
tar: Child returned status 2
tar: Saliendo con fallos debido a errores anteriores

...a continuación (a pesar del supuesto fallo sigo metiendo el siguiente comando):

cd r5u870-0.10.1

...y me responde esto:

bash: cd: r5u870-0.10.1: No existe el fichero ó directorio

Así es que no sé...algo falla, seguramente algo hago mal, pero no sé el que. Ya estoy por tirar la toalla. Y por cierto, muchas gracias por la paciencia y la ayuda!

+1
0
-1
Imagen de ketk
+1
0
-1

Perdona, copié las instrucciones de la web pero parece que tienen algún fallo en el nombre de los directorios. Vamos a ver si así te va:

wget http://www.palmix.org/download/r5u870_k2.6.30_i386.tar.bz2
tar -jxvf r5u870_k2.6.30_i386.tar.bz2
cd r5u870
sudo make
sudo make install
sudo modprobe r5u870

¿Ha funcionado?


TuVela.com información, tutoriales, curiosidades y más sobre Ubuntu, GNU/Linux y otros temas de mi interés. 6b 65 74 6b

+1
0
-1

TuVela.com información, tutoriales, curiosidades y más sobre Ubuntu, GNU/Linux y otros temas de mi interés. 6b 65 74 6b


Imagen de jose75
+1
0
-1

Por fin, lo coseguimos! Un millón de gracias por tu ayuda...muy amable! La cam va perfecta!!! Un saludo!

+1
0
-1
Imagen de josial
+1
0
-1

Bienvenido a la comunidad Ubuntu amigo jose75. Te recuerdo que luego de solucionado el problema se debe editar el título agregando (solucionado) para que otros con el mismo problema sepan que en tu hilo se resolvió. Es una a legría que amigos como Ketk nos ayuden a los novatos. Un saludo

+1
0
-1
Imagen de GRACIELA BAIELI
+1
0
-1

Soy nuevo total en UBUNTU(12.04), y he instalado SKYPE (4.1). al intentar una video llamada, no detecta la camara que posee mi notebook. Tengo instalado CHEESE, y al clickear, tampoco reconoce la videocamara.
He intentado con wget http://www.palmix.org/download/r5u870_k2.6.30_i386.tar.bz2, como recomienda KETK, pero aparece un anuncio de Error not found. Como debo proceder?

+1
0
-1

GRACE BAIELI