Desaparecio memoria de intercambio, afecta??

Imagen de Héctor Garcia
0 puntos

Bueno, primero buenas noches todos :3, bien, hoy he estado instalando varios juegos desde el centro de software, Nexuiz, TeeWorld entre otros (para profundizar), bueno estuve curioso de ver que tanto consumia nexuiz y bueno, al ver en Monitor del Sistema vi el procesador y la RAM pero la opcion intercambio me aparece * no disponible * pero antes me aparecian 2 o 3 gb no recuerdo muy bien, pero alli habian algunos GBytes de esa memoria de intercambio (creo que la conocida SWAP), bueno mi pregunta, afecta al sistema? como puedo reparar esto? Gracias

Imagen de LyingB
+1
0
-1

La memoria de intercambio sirve para aligerar la cantidad de datos que son vertidos a la RAM: El sistema usa primordialmente la RAM, pero también usa la SWAP.

Una vez dicho esto, si tienes la suficiente RAM para trabajar tu sistema puede prescindir de la SWAP, pero si la RAM se agota los procesos no trabajarán hasta que exista RAM disponible.

También está el hecho de que sin SWAP no puedes hibernar tu equipo.

Si quieres recuperar la SWAP ¿Cómo instalaste el sistema? ¿Particionamiento manual o dejaste que el instalador hiciera el trabajo sucio?

De cualquier manera, abre una terminal y teclea lo siguiente:

sudo su -
swapoff --all
swapon --all
cat /etc/fstab
free -m
fdisk -l
exit

El primer comando te pedirá tu contraseña la cual no se muestra; copia y pega lo que te devuelva la terminal.

+1
0
-1


Agrega al final del título del post (solucionado) si has arreglado tu problema.

Imagen de Héctor Garcia
+1
0
-1

Bien que tal, intente hacer los pasos que me diste pero en el tercer comando me aparece este error ** swapon: /dev/mapper/cryptswap1: stat falló: No existe el archivo o el directorio *** (sin los ***), la segunda opcion si funciono pero aqui me trabe, por cierto para instalarlo formatee todo mi HD eliminando Win7 y dejando solo Ubuntu, gracias por tu ayuda :)

+1
0
-1

Héctor Garcia

Imagen de LyingB
+1
0
-1

Al parecer has instalado el sistema cifrando todo. Te pido que pegues la salida de todos los comandos que te mencioné y adicionalmente del siguiente:

blkid
cat /etc/crypttab
vgdisplay
lvdisplay

Desde la terminal de root.

+1
0
-1


Agrega al final del título del post (solucionado) si has arreglado tu problema.

Imagen de Héctor Garcia
+1
0
-1

Hola que tal otra vez, mira no te comprendi muy bien lo de adicionalmente del siguiente, hice los pasos nuevos que me diste y en vgdisplay me sale esto: No volume groups found. Que sera :(, gracias por tu ayuda.

+1
0
-1

Héctor Garcia

Imagen de LyingB
+1
0
-1

Te di algunos comandos inicialmente (swapoff --all, swapon -all...) Quiero que los vuelvas a poner y conforme te den resultados pongas dichos resultados aquí para ver donde esta el error. Adicionalmente a esos primeros comandos en mi segundo mensaje te di otra serie de comandos; igual los pones y pegas acá todo lo que te digan.

+1
0
-1


Agrega al final del título del post (solucionado) si has arreglado tu problema.

Imagen de Héctor Garcia
+1
0
-1

swapoff --all (aqui no hizo nada, abrio otro renglón)
swapon --all ( swapon: /dev/mapper/cryptswap1: stat falló: No existe el archivo o el directorio
)
cat /etc/fstab ( # /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
#
# / was on /dev/sda1 during installation
UUID=ce55b704-08f2-4832-bbb1-93218419136d / ext4 errors=remount-ro 0 1
# swap was on /dev/sda5 during installation
#UUID=757f9516-51c6-4aca-ad43-dd387fb9241c none swap sw 0 0
/dev/mapper/cryptswap1 none swap sw 0 0

free -m ( total usado libre compart. búffers almac.
Mem: 3808 2149 1658 0 96 1136
-/+ buffers/cache: 916 2891
Intercambio: 0 0 0

fdisk -l ( Disco /dev/sda: 320.1 GB, 320072933376 bytes
255 cabezas, 63 sectores/pista, 38913 cilindros, 625142448 sectores en total
Unidades = sectores de 1 * 512 = 512 bytes
Tamaño de sector (lógico / físico): 512 bytes / 4096 bytes
Tamaño E/S (mínimo/óptimo): 4096 bytes / 4096 bytes
Identificador del disco: 0x0005e1bc

Dispositivo Inicio Comienzo Fin Bloques Id Sistema
/dev/sda1 * 2048 617056255 308527104 83 Linux
/dev/sda2 617058302 625141759 4041729 5 Extendida
La partición 2 no se inició en el limite físico del sector
/dev/sda5 617058304 625141759 4041728 82 Linux swap / Solaris
Nota: el tamaño del sector es 1024 (no 512)

Disco /dev/sdb: 4149 MB, 4149698560 bytes
256 cabezas, 63 sectores/pista, 251 cilindros, 4052440 sectores en total
Unidades = sectores de 1 * 1024 = 1024 bytes
Tamaño de sector (lógico / físico): 1024 bytes / 1024 bytes
Tamaño E/S (mínimo/óptimo): 1024 bytes / 1024 bytes
Identificador del disco: 0x00000000

Esto no parece una tabla de particiones
Probablemente ha seleccionado el dispositivo que no era.

Dispositivo Inicio Comienzo Fin Bloques Id Sistema
/dev/sdb1 ? 4294967295 8589934589 4294967295 ff BBT
/dev/sdb2 ? 4294967295 8589934589 4294967295 ff BBT
/dev/sdb3 ? 4294967295 8589934589 4294967295 ff BBT
/dev/sdb4 ? 4294967295 8589934589 4294967295 ff BBT

blkid ( /dev/sda1: UUID="ce55b704-08f2-4832-bbb1-93218419136d" TYPE="ext4"
/dev/sdb: UUID="0000-006F" TYPE="vfat" )

cat /etc/crypttab ( cryptswap1 /dev/sda5 /dev/urandom swap,cipher=aes-cbc-essiv:sha256 )

vgdisplay ( No volume groups found )

lvdisplay ( No volume groups found )

Ignora los paréntesis del inicio son solo para separar :)

+1
0
-1

Héctor Garcia

Imagen de LyingB
+1
0
-1

Son bastante raros en cuanto a particiones se refiere: fdisk me informa que tienes una partición Swap, pero blkid no la muestra. Intenta esto:

sudo gedit /etc/fstab

La siguiente línea:
#UUID=757f9516-51c6-4aca-ad43-dd387fb9241c none swap sw 0 0

Déjala así:

#UUID=757f9516-51c6-4aca-ad43-dd387fb9241c none swap sw 0 0

Borra la línea que dice:
/dev/mapper/cryptswap1 none swap sw 0 0

Guarda y cierra el archivo, luego vuelve a ejecutar "sudo swapon --all" (sin comillas).

Si no funciona (te vuelve a tirar error) significa que si bien el disco está particionado no está formateada como swap dicha partición, por lo que puedes tomar dos caminos distintos:

El primero es borrar las entradas en /etc/fstab:
#UUID=757f9516-51c6-4aca-ad43-dd387fb9241c none swap sw 0 0
/dev/mapper/cryptswap1 none swap sw 0 0

y en /etc/crypttab:
/dev/urandom swap,cipher=aes-cbc-essiv:sha256 )

Con casi 4Gb de RAM no creo que necesites memoria de intercambio. Luego podrías volver a particionar tu disco para aprovechar el espacio perdido.

La segunda opción es formatear la partición:

sudo mkswap /dev/sda5
sudo blkid |grep sda5

Te devolverá algo como esto:

/dev/sda5: UUID="ffc9d593-1848-478d-bd94-cfea3049085e" TYPE="Swap" 

De ahí copias UUID="ffc9d593-1848-478d-bd94-cfea3049085e" (el que te salga en tu caso, luego editas el archivo /etc/fstab:

sudo gedit /etc/fstab

Borras estas líneas:
#UUID=757f9516-51c6-4aca-ad43-dd387fb9241c none swap sw 0 0
/dev/mapper/cryptswap1 none swap sw 0 0

Y pones la tuya:

UUID="ffc9d593-1848-478d-bd94-cfea3049085e"     none    swap    sw    0 0

Guardas y cierras el archivo y vuelves a ejecutar sudo swapon --all

Eso es todo.

+1
0
-1


Agrega al final del título del post (solucionado) si has arreglado tu problema.