Problemas al abrir enlaces .doc

Imagen de ANINGA
0 puntos

Hola a todos. Tengo un problema raro desde que actualicé a 12.04 LTS, y no se como resolverlo.
Resulta que si en una página hago click a un enlace, y este es un documento .doc, me sale una página en negro.
Me explico.
Si yo quiero acceder, por ejemplo, a este enlace:
http://web.educastur.princast.es/proyectos/fisquiweb/Apuntes/Apuntes1Bac...
lo normal es que se abra, desde el navegador, el documento.
Los .pdf si se abren, pero los .doc no.
He probado con Chromium, y tampoco. Por lo que deduzco que el problema es de Ubuntu, ya que en otro ordenador que tengo con Windows abre perfectamente.
¿Cómo lo soluciono?
Uso el ordenador para dar clases y me deja bloqueado.
Gracias de antemano.

Imagen de Jose Luis 1320
+1
0
-1

Por favor evita poner expresiones de urgencia, no te van a ayudar mucho.

Saludos!.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de ANINGA
+1
0
-1

Lo siento

+1
0
-1
Imagen de Goyo
+1
0
-1

Si yo quiero acceder, por ejemplo, a este enlace:
http://web.educastur.princast.es/proyectos/fisquiweb/Apuntes/Apuntes1Bac...
lo normal es que se abra, desde el navegador, el documento.

Según lo que llames "normal". Solo puede ocurrir eso si el navegador incluye esa funcionalidad (no sé que ninguno la incluya, pero en principio podría ser) o si tienes instalado otro software que se integre con el navegador para proporcionarla.

+1
0
-1
Imagen de ANINGA
+1
0
-1

Digo normal porque antes lo hacía. Y también lo hace windows. Por eso lo considero normal. ¿No se abre en tu ordenador este enlace?

+1
0
-1
Imagen de Goyo
+1
0
-1

A ver, creo que te he entendido mal. ¿Lo que quieres es que se abra con LibreOffice?
En mi caso con Firefox, el documento no se abre automáticamente pero me da la opción de abrirlo con LibreOffice y de establecer ese comportamiento como predeterminado.

+1
0
-1
Imagen de ANINGA
+1
0
-1

Es que si yo pico en el enlace que he puesto arriba se me abre una pestaña nueva, pero en negro, sin nada dentro. Y no me da la opción de abrir con LibreOffice, ni de ninguna otra forma.
Eso es lo raro.

+1
0
-1
Imagen de Goyo
+1
0
-1

Sí que es raro. Las pestañas nuevas sin nada dentro suelen estar en blanco.
En todo caso en firefox ve a Editar > Preferencias, pestaña Aplicaciones y cambia la acción asociada a los documentos de word.

+1
0
-1
Imagen de ubu777
+1
0
-1

Lo que te sucede es normal, se llama "Problemas de configuracion post-actualizacion", y en tu caso, lo mas seguro es que vengas arrastrando una configuracion de openoffice que conflictua con la de libreoffice (si has venido actualizando desde una version 11 de Ubuntu).
Solucion:

1.- Abre el archivo de configuracion:

sudo gedit /usr/share/applications/defaults.list

Reemplaza todas las palabras openoffice.org por libreoffice
o mejor,
Inicia desde el live-cd de Ubuntu 12.04 y copia el defaults.list a tu Ubuntu instalado, reemplazandolo.

2.- Verifica que tu archivo de configuracion personal este libre del openoffice:

gedit ~/.local/share/applications/mimeapps.list

3.- Si despues de lo anterior, no funciona, me temo que tendras que sincronizar tus datos de firefox y reinstalar purgando los archivos de configuracion:

sudo apt-get purge firefox
sudo apt-get install firefox

Por ultimo sincroniza de nuevo para restablecer tus datos de firefox.

Si aun sigue sin funcionar, me temo que tendras que hacer lo que yo (y el creador de LM) recomiendamos siempre:
Instalacion nueva = - problemas
Aunque yo tengo un aliciente mas para hacer esto con cada nueva version de Ubuntu:
DISFRUTO el configurar una nueva instalacion de Ubuntu y ponerla a punto.

+1
0
-1

--------------------------------------------------------------------
*I'm sorry, I've played very sensitive fibers. This forum is not ready for my help. You can contact me in the master forums.
Ubuntu Forums Org.

Imagen de ANINGA
+1
0
-1

Gracias.
He hecho todo lo que me dices y nada.
Si instalo de nuevo ¿es como si formatease, y perdería todo lo que tengo?
Soy relativamente nuevo en Ubuntu y hay cosas que se me escapan.

+1
0
-1
Imagen de ANINGA
+1
0
-1

¿Como se copia el defaults.list del live-cd y se reemplaza, como me comentas? El resto lo he hecho y no funciona. Me queda eso y reinstalar.
Gracias por adelantado.

+1
0
-1
Imagen de nacho tineo
+1
0
-1

Ami con chrome me descarga el archivo .doc.
Con firefox me pregunta que quiero hacer.
Pero ahora mismo me sale un error que no se encuentra la pagina.
Si quieres te puedo pasar el archivo de apuntes enlace químico para que salgas del paso hasta que revises la configuración de tu equipo.
Un saludo

+1
0
-1

La libertad es aquella facultad que aumenta la utilidad de todas las demás facultades.
(Immanuel Kant)

Imagen de ANINGA
+1
0
-1

Gracias.
El problema no es el archivo, pues hay más en internet.
Es que si quiero abrir otro tampoco me va a dejar.
Esto es raro, raro.

+1
0
-1
Imagen de ubu777
+1
0
-1

¿Como se copia el defaults.list del live-cd y se reemplaza, como me comentas?

Inicia del live-cd y abre el explorador de archivos.
has click en cada unidad/particion que te aparezca a la izquierda para montarlas.
metete a cada una y fijate cual tiene una particion /home/tuusuario
Cuando la tengas identificada, abre una ventana del navegador como root -> alt+f2 y escribe -> gksudo nautilus.
En esa ventana navega a donde dice sistema de archivos -> /usr/share/applications/defaults.list
copialo y pegalo en el directorio /usr/share/applications/ de la particion que identificaste.

+1
0
-1

--------------------------------------------------------------------
*I'm sorry, I've played very sensitive fibers. This forum is not ready for my help. You can contact me in the master forums.
Ubuntu Forums Org.