Particion ext4 antigua inaccesible (ahora en disco secundario)

Imagen de Paco Carpena
0 puntos

Muy buenas,

Este es mi tercer año de linux pero sigo considerándome novato. Es mi primera intervención en este foro que consulto a menudo.

Acabo de instalar ubuntu 12.10 en un nuevo disco porque no podía arrancar mi anterior ubuntu 12.04, que instale desde sinaptic de ubuntu 10.04.

Ahora puedo leer las particiones FAT y NFTS del disco seagate en el que tenia ubuntu, pero no puedo acceder a la vieja partición de arranque ext4, de 60GB ("/dev/sda7"). El resto de particiones de ese disco las puedo montar y utilizar sin problemas, pero cada vez que intento montar la ext4 de 60GB me da el error siguiente:

Error mounting /dev/sda7 at /media/francisco/3c759c20-eefe-4fb9-8589-5b8dd0355779: Command-line `mount -t "ext4" -o "uhelper=udisks2,nodev,nosuid" "/dev/sda7" "/media/francisco/3c759c20-eefe-4fb9-8589-5b8dd0355779"' exited with non-zero exit status 32: mount: wrong fs type, bad option, bad superblock on /dev/sda7,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

Esta captura muestra el estado de ese disco secundario:
https://www.dropbox.com/s/bwgyewa6hky2slk/cda7ext4

Y este es el contenido de ejecutar el comando dmesg:
https://www.dropbox.com/s/za10dja5yrgcq3d/dmesg

Cuando he intentado editar el montaje automático para que al inicio la cargue, ubuntu no arranca y tengo que reiniciar y entrar con GRUB (ahora no sale pues tengo el disco nuevo sin particionar y utilizado exclusivamente por el nuevo ubuntu 12.10). He seguido esta guia y después he tenido que deshacer lo editado:
http://www.ubuntu-guia.com/2011/08/montar-particion-inicio-ubuntu-1104.html

Mi sistema es de 32bits, tengo un Intel® Core™2 Quad CPU Q6700 @ 2.66GHz × 4

Creo que no olvido nada importante. Mientras espero alguna respuesta voy a ver si consigo algo con gparted.

Muchas gracias de antemano.

Paco Carpena.

Imagen de Gabriel_M
+1
0
-1

determina como se denomina la partición en ese momento

sudo su
fdisk -l

Pasa varias veces el reparador del sistema de archivos

sudo su
fsck /dev/sd?? -a

Cambia ?? por lo que corresponde a la partición dañada

+1
0
-1
Imagen de Paco Carpena
+1
0
-1

Hola Gabriel, muchas gracias.

No habia leido lo de la sesion live y lo hice desde el ubuntu de mi HD, me daba un error y me pedia ejecutarlo sin -a o -p.

Luego si que lo he hecho desde el live usb, y esto es lo que obtengo

ubuntu@ubuntu:~$ sudo su
root@ubuntu:/home/ubuntu# fsck /dev/sda7 -a
fsck from util-linux 2.20.1
/dev/sda7: recovering journal
Error reading block 6852901 (Attempt to read block from filesystem resulted in short read).

/dev/sda7: UNEXPECTED INCONSISTENCY; RUN fsck MANUALLY.
(i.e., without -a or -p options)
root@ubuntu:/home/ubuntu# fsck /dev/sda7 -a
fsck from util-linux 2.20.1
fsck.ext2: Attempt to read block from filesystem resulted in short read while trying to open /dev/sda7
Could this be a zero-length partition?

DESPUES SIN -a

root@ubuntu:/home/ubuntu# fsck /dev/sda7
fsck from util-linux 2.20.1
e2fsck 1.42.5 (29-Jul-2012)
fsck.ext2: Attempt to read block from filesystem resulted in short read while trying to open /dev/sda7
Could this be a zero-length partition?
root@ubuntu:/home/ubuntu#

No se... probare otra vez desde gparted o tal vez con photorec. Cuando he tratado de recuperar con gparted, me ha dado error desmontando todo el hd con sus 5 particiones a las que si que tenia acceso. Creo que alguna de las veces me ha cerrado la sesion de ubuntu.

Saludos.

+1
0
-1
Imagen de christian_play
+1
0
-1

Hola, ¿Has probado a utilizar rescatux? es una live que entre otras tiene la opcion de forzar la reparación del sistema de archivos. A mi me a funcionado siempre que me ha fallado el gparted para reparar particiones.

+1
0
-1
Imagen de Paco Carpena
+1
0
-1

Pues aunque ya es tarde, tomo buena nota christian_play. Y muchas gracias por el apunte, no conocía esa posibilidad.

Todo lo que he probado ha dado errores, llegando a bloquear el sistema, reiniciarlo, desmontar las unidades... salvo photorec, que me ha rescatado todo, pero... es prácticamente inservible. Al menos los datos esenciales los tenía a salvo, pero he perdido cosas, claro, pues photorec me ha mezclado y renombrado los cientos de miles de archivos que tenia, repartiéndolos en 650 directorios de 500 archivos cada uno. Sólo ha conservado la extensión.

Creo que aunque no esté propiamente resuelto, debería editar el título del hilo ¿me lo puede confirmar algún forero?

Gracias por todo.

+1
0
-1