no reconose toda la memoria ram

Imagen de samm04
0 puntos

hola a todos tengo un pequeño
problema e instalado unbunto 12.10 64bit
tengo 8gb de memoria y solo reconoce
3.6 gb de memoria
mi procesador es un AMD Athlon ii X2 p340
de video ati mobility radeon hd 4250

les agradeseria inmensamente
su ayuda

Imagen de nolin
+1
0
-1

Posibilidades:
1) Tu (¿vieja?) placa base no reconoce más de 4 GB.

2) Tu modelo de tarjeta gráfica no tiene memoria propia, sino que la coge de la principal.
y entonces:
2.1) En la Bios está marcado que la HD4250 se reserve para sí 4 GB.
2.2) Algún software está reservandose 4 GB para la HD4250.

Reservarse 4 GB para la gráfica es una barbaridad (1 GB ya sería muchísmo), y no creo que ninguna de las posibilidades "2.x)" sea la correcta. Me inclino más por la posibilidad 1)
Todo esto suponiendo que no te hayas equivocado y no sea Ubuntu de 64 bits, porque ningún OS de 32 bits entiende más de 4 GB.

+1
0
-1
Imagen de samm04
+1
0
-1

pero entro en el bios y me reconoce los 8gb de memoria asi que no creo que sea la numero uno

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

Tal vez no hayas instalado Ubuntu de 64 bits... Abre Terminal, escribe "uname -a" sin comillas, enter.

Copia y pega aca en el foro lo que salga.

Y no esta de más hacer un memtest, igual y tiene problemas en la RAM.

Prendes la computadora, Tecla mayús de inmediato, y seleccionas Memtest desde el menú.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de samm04
+1
0
-1

Linux mrsollutions-Aspire-5552 3.5.0-22-generic #34-Ubuntu SMP Tue Jan 8 21:47:00 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

+1
0
-1
Imagen de bean
+1
0
-1

porque ningún OS de 32 bits entiende más de 4 GB.

Estimado compañero, no siempre es así:
por ahora estoy en un Ubuntu 12.10 de 32-bit, con núcleo Linux 3.5.0-22-lowlatency
GNOME 3.6.0, que me reconcoe una memoria de 7,8 GB con un Procesador Intel® Core™2 Duo CPU E7400 @ 2.80GHx2, según el monitor del sistema.
Y, lo anterior re confirmado con
$ dmesg | grep -i memory
y con
$ free
que me dice en mem física lo siguiente:
total usado libre compart. búffers almac.
Mem: 8208524 998180 7210344 0 72056 592652
-/+ buffers/cache: 333472 7875052
Intercambio: 2077688 0 2077688
Como verás, con los 7.8 se confirma lo de los 8 físicos en 4 slots de 2 Gbs c/u.
Tu apreciación en 32 bit me parece aplica a otro sistema operativo distinto de alguno Linux.
Saludos

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

Eso es por que el kernel tiene la extensión PAE, si el kernel low-latency te reconoce los 8 GB de ram es por que ya esta parchado con la extensión PAE, sin la extensión PAE el kernel de 32 bits no puede reconocer mas de 4 GB.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de bean
+1
0
-1

es y viene así por defecto sin que haya tenido que parcharlo, lo que demuestra que la afirmación de nolin no puede ser absoluta como se lee, sino es como escribí:

no siempre es así.

Fe ratas: donde dice:

reconcoe

debe decir:

reconoce
+1
0
-1
Imagen de bean
+1
0
-1

a ver si samm 04 se anima, me parece que tendría como opciones, o parchar su kernel a PAE o bien instalar el real time de Ubuntu Studio en Quetzal - magnífico para mi gusto, aunque de pronto echo de menos a Unity, si de verdad tiene un procesador 32 bits (Una opción) .

Bien ¿ y que es PAE ?:
PAE significa Extensión de Dirección Física (Physical Address Extension) y es una característica de los procesadores de 32 bits ( que debe añadirse o parcharse) por la que acceden a más de 4GB de memoria. He leído que al soportar PAE el procesador también puede soportar el bit NX ( el bit 63 en arq de 64, ej. Athlon en AMD 64, que evita ataques maliciosos o desbordamientos de buffer - vg., por gusanos Sasser, Blaster) ).
Y, como se desprende de lo conversado, los procesadores de 64 bits acceden a más de 4GB por diseño o arquitectura que no por software como es el caso de estos kernels para 32 bits, en que como ej. menciono el de Ubuntu Studio.
Por lo anterior, es posible que el error se encuentre en que (2a. opción) tiene un procesador de arq. de 64 bits toda vez que menciona el Athlon AMD, y no ha instalado de verdad el Ubuntu para 64 sino sólo el de 32, y allí José Luis ha dado en el clavo.
Saludos.

+1
0
-1
Imagen de samm04
+1
0
-1

me pararece muy interesante tu salida aver que pasa

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

Tienes menos... abre tu computadora y checa que tienes realmente en los slots de memoria RAM.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de hectorrr
+1
0
-1

Hola Gente. Tengo el siguiente problema, tengo dos memorias de 4gb cada una instalas correctamente, tengo ubuntu LTS 10.04 64 bits. Y recién me doy cuenta que sólo me reconoce 4 GB de RAM.
usando lshw -short sale :
ruta H/W Dispositivo Clase Descripción
====================================================
system Computer
/0 bus Motherboard
/0/0 memory 3683MiB Memoria de sistema
/0/1 processor AMD FX(tm)-6100 Six-Core Processor
/0/100 bridge RS780 Host Bridge
/0/100/1 bridge AMD RS780/RS880 PCI to PCI bridge (int g
/0/100/1/5 display RS780L [Radeon 3000]
/0/100/4 bridge RS780/RS880 PCI to PCI bridge (PCIE port
/0/100/4/0 eth0 network AR8161 Gigabit Ethernet
/0/100/11 storage SB7x0/SB8x0/SB9x0 SATA Controller [IDE m
/0/100/12 bus SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
/0/100/12.1 bus SB7x0 USB OHCI1 Controller
/0/100/12.2 bus SB7x0/SB8x0/SB9x0 USB EHCI Controller
/0/100/13 bus SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
/0/100/13.1 bus SB7x0 USB OHCI1 Controller
/0/100/13.2 bus SB7x0/SB8x0/SB9x0 USB EHCI Controller
/0/100/14 bus SBx00 SMBus Controller
/0/100/14.1 storage SB7x0/SB8x0/SB9x0 IDE Controller
/0/100/14.2 multimedia SBx00 Azalia (Intel HDA)
/0/100/14.3 bridge SB7x0/SB8x0/SB9x0 LPC host controller
/0/100/14.4 bridge SBx00 PCI to PCI Bridge
/0/100/14.4/5 wlan0 network AR2417 Wireless Network Adapter [AR5007G
/0/100/14.5 bus SB7x0/SB8x0/SB9x0 USB OHCI2 Controller
/0/101 bridge Family 15h Processor Function 0
/0/102 bridge Family 15h Processor Function 1
/0/103 bridge Family 15h Processor Function 2
/0/104 bridge Family 15h Processor Function 3
/0/105 bridge Family 15h Processor Function 4
/0/106 bridge Family 15h Processor Function 5
/1 scsi6 storage

+1
0
-1
Imagen de hectorrr
+1
0
-1

Gente, increíblemnte fui a lo básico. Saqué cada una de las meorias, las probé por separados en cada slot y antes las limpié por las dudas. Vi cada una funcionaba bien, además de actualizar la BIOS. Probé nuevamente con ambas, y funcionó!. Es evidente que había un mal contacto....muchas gracias y quizás le sirva para algún otro.

+1
0
-1