kernel 3.7.5 da problemas con virtualbox

+1
0
-1

Los Kernel son muy importantes para mantener nuestros equipos actualizados y en estas ultimas versiones e notado que dan problemas con Virtualbox, no se por que pero las verciones 3.6.8;3.7.0;3.7.0;3.7.5, dan errores con virtualbox lo e intentado recopilando, instalando directamente desde terminal y siempre me da el mismo error la vercion que me funciona mejor es la 3.6.5 y de esta para arriba nunguna funciona bien.

Comentarios

Imagen de .doc

claro, las distribuciones (y su paqueteria, con sus dependencias) supongo que van adaptándose a los nuevos kernel, y tu estás hablando de unas versiones de kernel que, por ejemplo, en Debian, por decirlo así 'la madre' de los Buntus, aún no han entrado ni en su rama Experimental.

Imagen de Juan Francisco Marin Salas

claro por eso es bueno comentar los problemas que dan, para que se desarrolle de forma adecuada sino para que probarlos, somos una comunidad de sofware libre por eso no tenemos los males de otros sofware cerrado como windows

Imagen de Jose Luis 1320

Desde ya Linus Torvalds esta en el problema y cuando lo resuelva te va a mandar una tostadora como compensación, me lo acaba de decir por cuernófono celular.

Como comenta el colega .doc; Ninguna distribución se adapta al kernel, es al revés, cada kernel que llega la distribución lo toma, lo adapta, reporta bugs, selecciona módulos, es decir lo adapta para que funcione en las herramientas y configuraciones de la distribución.

Un kernel nuevo lo que trae son nuevas tecnologías para la gestión de un dispositivo, trae características nuevas y soporte para nuevas tecnologías informáticas. Es decir que si tu no tienes una tecnología nueva en tu PC física que el nuevo kernel soporta, es como si tuvieras la versión antigua.

Y en cuanto a contribuir... bueno no indicas detalles ni tienes pruebas (logs, trazas inversas, etc..) para indicar que problema tienes con virtualbox, solo palabras al aire, y esas no sirven para contribuir sobre todo al desarrollo de algo tan importante como el kernel Linux.

Y la respuesta por antonomasia; Este sitio NO se relaciona con el kernel Linux, ni siquiera con el desarrollo y mantenimiento de Ubuntu (eso lo hace Canonical Ltd.) es sólo una comunidad de usuarios de Ubuntu (una distribución, una vez más, de miles) entre miles que hay en la red. Toma en cuenta que Ubuntu y Linux son dos cosas diferentes, no son lo mismo.

Para contribuir al kernel linux, debes tener ciertos requisitos: primero el Inglés, puesto que se comunican en Inglés, dos registrarte a la lista de correo: https://lkml.org/ tres leer los requisitos y formarte de conocimiento para comprender como se desarrolla el kernel, entre más requisitos.

Nadie te manda a compilar kernel inestables, por ejemplo la rama 3.7.

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de Gabriel_M

Estoy usando Siduction y en Virtualbox pruebo Raring, en estos momentos tengo el kernel 3.7.4 y Virtualbox corre perfectamente.
Lo que ocurre es que el usar kernels de última versión, requiere paquetes de aplicaciones de última versión, se debe utilizar Virtualbox descargado desde Oracle.
Además el planteo es erroneo no es:
"... estas ultimas versiones e notado que dan problemas con Virtualbox..."
Sino que debe ser:
"... mi versión de Virtualbox da problemas con las últimas versiones del kernel..."
Este planteo correcto, se dá tambien con otros desarrollos privativos (Nvidia, Ati, etc.)

Imagen de Alcruz

las veces que he compilado un kernel, siempre tuve problemas en instalar el controlador Nvidia, la solución fue la de mantener la carpeta de fuentes del kernel en /usr/src . por lo que saco como conclución de que el linux-headers creado, no era suficiente

Imagen de snorkellingcactus

No das detalles sobre tu problema, pero si no te funciona NINGUNA de las versiones posteriores a la 3.6.5 seguro sea porque te olvidaste de recompilar vbox-modules. Si no me equivoco, ubuntu hace eso al instalar virtualbox, en tu caso, tendrìas que reinstalar virtualbox.