mythbuntu 12.04.2 salida S-Video pc a tv

Imagen de girelaine
20 puntos

Hola, acabo instalar mythbuntu 12.04.2 aunque antes también probé con ubuntu 12.04.2 tuve el mismo problema. Reconozco que soy novato en linux aunque llevo tiempo usándolo.

El caso es que para ver pelis y navegar quiero conectar un antiguo pc a una vieja televisión a través de una conexión S-Video, las opciones de la bios y el arranque de inicio del ordenador lo veo bien en la tv, pero cuando inicia ubuntu o mythbuntu todo se queda en negro y no aparece nada.

Googleando parece que tengo que configurar el S.O. para que éste considere que la salida de video la estoy haciendo por s-video y supongo que cambiar la resolución de pantalla para el monitor de la tv, he visto que algunos lo solucionan editando un archivo situado en /etc/X11/xorg.conf pero este archivo no existe ni en mi mythbuntu ni en ubuntu 12.04.2

Otros parece que encuentra solución en la configuración del controlador privativo de las gráficas Nvidia, pero parece que para mi tarjeta gráfica ATI Radeon R200 QM [Radeon 9100] no existen controladores privativos.

Los demás datos de mi antiguo pc:
Procesador: Intel Pentium IV (2.00 Ghz)
Placa Base (MotherBoard): GIGABYTE GA-8SR533P Rev 3 .0 http://goo.gl/5qFXI
Tarjeta Gráfica: ATI Radeon 9100

¿Qué debo hacer entonces? una ayuda por favor, cualquier dato que pueda aportar lo daré con gusto. Gracias.

Imagen de girelaine
+1
0
-1

por favor, se os ocurre algo? no me gustaría recurrir a Windows XP :_(

+1
0
-1
Imagen de Gabriel_M
+1
+1
-1

Crear los scripts que activen y desactiven el S-Video

s-von.sh

#!/bin/bash
# Activa S-Video a 800x600
xrandr --addmode S-video 800x600 && xrandr --output S-video --mode 800x600 --pos 200x200 && xvattr -a XV_CRTC -v 1

s-voff.sh

#!/bin/bash
# Desactiva S-Video
xvattr -a XV_CRTC -v 0 && xrandr --output S-video --off

Copia los archivos al directorio /usr/bin
y dale permisos de ejecución

sudo su
chmod +x /usr/bin/s-von.sh
chmod +x /usr/bin/s-voff.sh
+1
+1
-1
Imagen de girelaine
+1
0
-1

Gracias Gabriel_M, he hecho lo que dices. Luego he conectado el pc a la tv por svideo y a la vez por vga al monitor de pc para ver lo que hacía, entonces he pinchado dos veces en s-von.sh y botón derecho del ratón sobre el mismo en la opción "ejecutar", pero como antes no aparece nada en la tv (salvo la bios y el arranque del pc)
¿Se me escapa algo? gracias.

+1
0
-1
Imagen de girelaine
+1
0
-1

si abro terminal y arrastro el archivo s-von.sh (/usr/bin/s-von.sh) hasta la tarminal para ejecutarlo me dice:
xrandr: cannot find output "S-video"

+1
0
-1