Problemas con la conexion.

Imagen de NightVision
0 puntos

Buenos días gente, publico este post porque si bien he encontrado muchas soluciones googleando mi problema no he logrado solucionarlo, mas que nada porque cuando trato de seguir las instrucciones de lo tutoriales me saltan otros problemas que me llevan a nuevos tutoriales y así ad infinitum.
Y como son mis primeros pasos con un S.O. que no sea de Windows me sentiria mas comodo si alguien me asesora un poco.
Bien, me compre un Notebook Lenovo G480 con W7, despues de leer mucho y varios intentos fallidos pude instalar Ubuntu 12.10, todo funcionaba 10 puntos.
Ningun problema con la conexion wi-fi, y si abria el menu de las conexiones haciendo click sobre el boton de conexiones en la barra superior se me mostraban todas la redes wi-fi disponibles (la de casa y varias mas de vecinos).
Instale los programas que uso para trabajar y todo marchaba excelente (Por la dudas los programas son Eclipse, Appserv y el MySQL Workbench), hasta que un dia al prender la notebook me aparecio el cartelito "wi-fi desconectado".
Al clickear sobre el icono de Conexiones ya no me aparecian las distintas redes wi-fi.
Usando iwconfig visualizaba lo y eth1 ambas con la leyenda no wireless extensions
Despues de tratar con muchos tutoriales pude tener conexion al wi-fi deshabilitando en origenes de software>controladores adicionales la opcion usando Broadcom 802.11 Linux STA wireless driver source desde bcmwl-kernel-soucer, dejando marcada la opcion no usar dispositivo, ejecutando la siguientes lineas en la terminal y reiniciando el equipo.

sudo ifconfig wlan0 up
iwlist wlan0 scanning

Luego de esto, ya con conexion wi-fi, he intentado instalar los drivers de la placa puesto que si bien tengo conexion al ingresar iwconfig solo aparecen lo (no wireless extension) y wlan0.
eth1 ha desaparecido y al conectar el cable al puerto de ethernet ya ni se encience el led .
Instale ndiswrapper y trate de cargar el controlador pero al poner el .inf e instalar me tira el error FATAL: Module ndiswrapper not found pero el driver me queda como instalado.
Ademas cuando vuelvo a habilitar la opcion usando Broadcom 802.11 Linux STA wireless driver source desde bcmwl-kernel-soucer, me deja sin conexion wi-fi, solo quedando lo al ejecutar iwconfig.
La verdad si alguien me pudiera dar una mano me vendria barbaro puesto que como dije antes, al tratar de seguir un tutorial para solucionar el problema nunca puedo terminarlo porque me topo con otro, y siendo nuevo en esto se hace muy dificil.
Saludos y gracias de antemano.

Imagen de Gabriel_M
+1
0
-1

.... abrir una terminal y ejecutar en ella:

sudo su
lspci | grep -i ethernet
lspci | grep -i network
lsusb | grep -i ethernet
lsusb | grep -i network
lsmod | grep iwl
ifconfig -a
ifconfig
iwconfig

Copia las salidas y pegalas en el post.

+1
0
-1
Imagen de NightVision
+1
0
-1

Hola Gabriel, antes que nada gracias por responder.
Luego esto es lo que me ha devuelto la terminal

root@facundo-20080:/home/facundo# lspci | grep -i ethernet
01:00.0 Ethernet controller: Atheros Communications Inc. AR8162 Fast Ethernet (rev 08)

root@facundo-20080:/home/facundo# lspci | grep -i network
02:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev 01)

root@facundo-20080:/home/facundo# lsusb | grep -i ethernet

root@facundo-20080:/home/facundo# lsusb | grep -i network

root@facundo-20080:/home/facundo# lsmod | grep iwl

root@facundo-20080:/home/facundo# ifconfig -a
lo Link encap:Bucle local
Direc. inet:127.0.0.1 Másc:255.0.0.0
Dirección inet6: ::1/128 Alcance:Anfitrión
ACTIVO BUCLE FUNCIONANDO MTU:16436 Métrica:1
Paquetes RX:175 errores:0 perdidos:0 overruns:0 frame:0
Paquetes TX:175 errores:0 perdidos:0 overruns:0 carrier:0
colisiones:0 long.colaTX:0
Bytes RX:14642 (14.6 KB) TX bytes:14642 (14.6 KB)
wlan0 Link encap:Ethernet direcciónHW 08:ed:b9:a0:1b:09
Direc. inet:192.168.1.37 Difus.:192.168.1.255 Másc:255.255.255.0
Dirección inet6: fe80::aed:b9ff:fea0:1b09/64 Alcance:Enlace
ACTIVO DIFUSIÓN FUNCIONANDO MULTICAST MTU:1500 Métrica:1
Paquetes RX:323 errores:0 perdidos:0 overruns:0 frame:0
Paquetes TX:619 errores:0 perdidos:0 overruns:0 carrier:0
colisiones:0 long.colaTX:1000
Bytes RX:149574 (149.5 KB) TX bytes:87547 (87.5 KB)

root@facundo-20080:/home/facundo# ifconfig
lo Link encap:Bucle local
Direc. inet:127.0.0.1 Másc:255.0.0.0
Dirección inet6: ::1/128 Alcance:Anfitrión
ACTIVO BUCLE FUNCIONANDO MTU:16436 Métrica:1
Paquetes RX:179 errores:0 perdidos:0 overruns:0 frame:0
Paquetes TX:179 errores:0 perdidos:0 overruns:0 carrier:0
colisiones:0 long.colaTX:0
Bytes RX:15364 (15.3 KB) TX bytes:15364 (15.3 KB)
wlan0 Link encap:Ethernet direcciónHW 08:ed:b9:a0:1b:09
Direc. inet:192.168.1.37 Difus.:192.168.1.255 Másc:255.255.255.0
Dirección inet6: fe80::aed:b9ff:fea0:1b09/64 Alcance:Enlace
ACTIVO DIFUSIÓN FUNCIONANDO MULTICAST MTU:1500 Métrica:1
Paquetes RX:335 errores:0 perdidos:0 overruns:0 frame:0
Paquetes TX:633 errores:0 perdidos:0 overruns:0 carrier:0
colisiones:0 long.colaTX:1000
Bytes RX:155330 (155.3 KB) TX bytes:89491 (89.4 KB)

root@facundo-20080:/home/facundo# iwconfig
lo no wireless extensions.
wlan0 IEEE 802.11bgn ESSID:"Speedy_"
Mode:Managed Frequency:2.462 GHz Access Point: 00:E0:4D:8F:97:88
Bit Rate=18 Mb/s Tx-Power=19 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=46/70 Signal level=-64 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:4 Invalid misc:25 Missed beacon:0

+1
0
-1
Imagen de Gabriel_M
+1
0
-1

Abrir una terminal
Para activar tu tarjeta Atheros 8162
Abrir una terminal
Ejecutar en ella

sudo su
apt-get install linux-headers-generic build-essential
wget http://www.orbit-lab.org/kernel/compat-wireless-3-stable/v3.5/compat-wireless-3.5.1-1-snpc.tar.bz2
tar -xf compat-wireless-3.5.1-1-snpc.tar.bz2
cd compat-wireless-3.5.1-1-snpc
./scripts/driver-select alx
make
make install
modprobe alx
reboot

Una vez funcionando la tarjeta ethernet, para la inalambrica sería necesario
Abrir una terminal
Ejecutar en ella:

sudo su
apt-get update
apt-get install firmware-b43-installer
apt-get remove bcmwl-kernel-source
reboot
+1
0
-1
Imagen de NightVision
+1
0
-1

He ejecutado en la terminal las instrucciones que me has dejado y ahora al conectar el cable ya se enciende nuevamente el led, pero no si la placa esta funcionando correctamente puesto que no parece haber transmision de datos.
Si desactivo la opcion "Activar Inalambrico" en el menu de conexiones me quedo sin internet aun teniendo el cable conectado.
Si ingreso iwconfig obtengo
lo no wireless extensions.
wlan0 IEEE 802.11bgn ESSID:"Speedy_"
Mode:Managed Frequency:2.462 GHz Access Point: 00:E0:4D:8F:97:88
Bit Rate=24 Mb/s Tx-Power=19 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Power Management:off
Link Quality=56/70 Signal level=-54 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:2 Invalid misc:171 Missed beacon:0

Y con ifconfig me da como resultado
lo Link encap:Bucle local
Direc. inet:127.0.0.1 Másc:255.0.0.0
Dirección inet6: ::1/128 Alcance:Anfitrión
ACTIVO BUCLE FUNCIONANDO MTU:16436 Métrica:1
Paquetes RX:108 errores:0 perdidos:0 overruns:0 frame:0
Paquetes TX:108 errores:0 perdidos:0 overruns:0 carrier:0
colisiones:0 long.colaTX:0
Bytes RX:10351 (10.3 KB) TX bytes:10351 (10.3 KB)
wlan0 Link encap:Ethernet direcciónHW 08:ed:b9:a0:1b:09
Direc. inet:192.168.1.37 Difus.:192.168.1.255 Másc:255.255.255.0
Dirección inet6: fe80::aed:b9ff:fea0:1b09/64 Alcance:Enlace
ACTIVO DIFUSIÓN FUNCIONANDO MULTICAST MTU:1500 Métrica:1
Paquetes RX:1114 errores:0 perdidos:0 overruns:0 frame:0
Paquetes TX:1269 errores:0 perdidos:0 overruns:0 carrier:0
colisiones:0 long.colaTX:1000
Bytes RX:768321 (768.3 KB) TX bytes:188553 (188.5 KB)

Saludos.

+1
0
-1
Imagen de Eleseen
+1
0
-1

hola a la toda comunidad, no queria crear otro tema en el foro por lo que veo tienes la misma laptop que la mia y tengo un problema parecido despues de sufrir con el instalar el ubuntu 12.10 ahora intente instalar el Ethernet como la otra vez, despues de varios intentos me sale error y sigo sin ethernet y sin wifi

corri estos comando:
lspci
lsusb
ifconfig -a
ifconfig
iwconfig

y esto me arrogo:
root@alejandro-UBUNTU:/home/alejandro-ubuntu# lspci
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4)
00:1c.3 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 4 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM76 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
01:00.0 3D controller: NVIDIA Corporation Device 1140 (rev a1)
03:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev 01)
04:00.0 Ethernet controller: Atheros Communications Inc. AR8162 Fast Ethernet (rev 10)
root@alejandro-UBUNTU:/home/alejandro-ubuntu# lsusb
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 003 Device 002: ID 0458:003a KYE Systems Corp. (Mouse Systems) NetScroll+ Mini Traveler / Genius NetScroll 120
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 0489:e032 Foxconn / Hon Hai
Bus 001 Device 004: ID 5986:0294 Acer, Inc
Bus 002 Device 003: ID 058f:6366 Alcor Micro Corp. Multi Flash Reader
root@alejandro-UBUNTU:/home/alejandro-ubuntu# ifconfig -a
lo Link encap:Bucle local
Direc. inet:127.0.0.1 Másc:255.0.0.0
Dirección inet6: ::1/128 Alcance:Anfitrión
ACTIVO BUCLE FUNCIONANDO MTU:16436 Métrica:1
Paquetes RX:2192 errores:0 perdidos:0 overruns:0 frame:0
Paquetes TX:2192 errores:0 perdidos:0 overruns:0 carrier:0
colisiones:0 long.colaTX:0
Bytes RX:172960 (172.9 KB) TX bytes:172960 (172.9 KB)

root@alejandro-UBUNTU:/home/alejandro-ubuntu# ifconfig
lo Link encap:Bucle local
Direc. inet:127.0.0.1 Másc:255.0.0.0
Dirección inet6: ::1/128 Alcance:Anfitrión
ACTIVO BUCLE FUNCIONANDO MTU:16436 Métrica:1
Paquetes RX:2192 errores:0 perdidos:0 overruns:0 frame:0
Paquetes TX:2192 errores:0 perdidos:0 overruns:0 carrier:0
colisiones:0 long.colaTX:0
Bytes RX:172960 (172.9 KB) TX bytes:172960 (172.9 KB)

root@alejandro-UBUNTU:/home/alejandro-ubuntu# iwconfig
lo no wireless extensions.

pd1: este fue el post cuando se resolvio mi problema pero ahora ya no me funciona,
http://www.ubuntu-es.org/node/175494#.UTPJOjDG9qU
pd2: en ese tiempo usaba ubuntu 12.04, y ahora instale ubuntu 12.10
pd3: el comando : apt-get install build-essential linux-header-`uname -r` , a la hora de jecutarlo no me funciona por mas que agrego el dvd del ubuntu 12.10
gracias a todos los que leen y espero me puedan ayudar :D
saludos a la comunidad

+1
0
-1

asd

Imagen de Gabriel_M
+1
0
-1

sudo su
apt-cdrom add 
apt-cdrom ident 
apt-cdrom -d donde-se-monto-el-dvd -r
apt-get update
apt-get  install build-essential linux-header-`uname -r`
+1
0
-1
Imagen de Eleseen
+1
0
-1

aun sigo sin internet :(
***************************************************************************************************
ejecute estos comandos :
sudo su
lspci | grep -i ethernet
lspci | grep -i network
lsusb | grep -i ethernet
lsusb | grep -i network
lsmod | grep iwl
ifconfig -a
ifconfig
iwconfig

root@alejandro-UBUNTU:/home/alejandro-ubuntu# lspci | grep -i ethernet
04:00.0 Ethernet controller: Atheros Communications Inc. AR8162 Fast Ethernet (rev 10)
root@alejandro-UBUNTU:/home/alejandro-ubuntu# lspci | grep -i network
03:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev 01)
root@alejandro-UBUNTU:/home/alejandro-ubuntu# lsusb | grep -i ethernet
root@alejandro-UBUNTU:/home/alejandro-ubuntu# lsusb | grep -i network
root@alejandro-UBUNTU:/home/alejandro-ubuntu# lsmod | grep iwl
root@alejandro-UBUNTU:/home/alejandro-ubuntu# ifconfig -a
lo Link encap:Bucle local
Direc. inet:127.0.0.1 Másc:255.0.0.0
Dirección inet6: ::1/128 Alcance:Anfitrión
ACTIVO BUCLE FUNCIONANDO MTU:16436 Métrica:1
Paquetes RX:2544 errores:0 perdidos:0 overruns:0 frame:0
Paquetes TX:2544 errores:0 perdidos:0 overruns:0 carrier:0
colisiones:0 long.colaTX:0
Bytes RX:197952 (197.9 KB) TX bytes:197952 (197.9 KB)

root@alejandro-UBUNTU:/home/alejandro-ubuntu# ifconfig
lo Link encap:Bucle local
Direc. inet:127.0.0.1 Másc:255.0.0.0
Dirección inet6: ::1/128 Alcance:Anfitrión
ACTIVO BUCLE FUNCIONANDO MTU:16436 Métrica:1
Paquetes RX:2544 errores:0 perdidos:0 overruns:0 frame:0
Paquetes TX:2544 errores:0 perdidos:0 overruns:0 carrier:0
colisiones:0 long.colaTX:0
Bytes RX:197952 (197.9 KB) TX bytes:197952 (197.9 KB)

root@alejandro-UBUNTU:/home/alejandro-ubuntu# iwconfig
lo no wireless extensions.

**********************************************************************************
tambien ejecute estos comandos:

sudo su
apt-cdrom add
apt-cdrom ident
apt-cdrom -d donde-se-monto-el-dvd -r
apt-get update
apt-get install build-essential linux-header-`uname -r`

root@alejandro-UBUNTU:/home/alejandro-ubuntu# apt-cdrom add
Usando el punto de montaje del CD-ROM /media/alejandro-ubuntu/Ubuntu 12.10 amd64/
Identificando.. [8c73d922f78503b9871028a2b1cb04b3-2]
Buscando en el disco archivos de índices...
Se encontraron 4 índices de paquetes, 0 índices de fuentes, 0 índices de traducción y 1 firmas
Este disco se llama:
«Ubuntu 12.10 _Quantal Quetzal_ - Release amd64 (20121017.5)»
Copiando las listas de paquetes...gpgv: Firmado el mié 17 oct 2012 13:36:03 PET usando clave DSA ID FBB75451
gpgv: Firma correcta de «Ubuntu CD Image Automatic Signing Key »
Reading Package Indexes... Hecho
Escribiendo nueva lista de origen
Las entradas de la lista de orígenes para este disco son:
deb cdrom:[Ubuntu 12.10 _Quantal Quetzal_ - Release amd64 (20121017.5)]/ quantal main restricted
Repita este proceso para el resto de los CD del conjunto.

root@alejandro-UBUNTU:/home/alejandro-ubuntu# apt-cdrom ident
Usando el punto de montaje del CD-ROM /media/cdrom/
Montando el CD-ROM
E: No se puede obtener información del punto de montaje /media/cdrom/ - stat (2: No existe el archivo o el directorio)
E: Failed to mount the cdrom.

root@alejandro-UBUNTU:/home/alejandro-ubuntu# apt-cdrom -d /media/alejandro-ubuntu/ -r
apt 0.9.7.5ubuntu5 para amd64 compilado en Oct 16 2012 10:57:22
Usage: apt-cdrom [options] command

apt-cdrom is a tool to add CDROM's to APT's source list. The
CDROM mount point and device information is taken from apt.conf
and /etc/fstab.

Commands:
add - Add a CDROM
ident - Report the identity of a CDROM

Options:
-h This help text
-d CD-ROM mount point
-r Rename a recognized CD-ROM
-m No mounting
-f Fast mode, don't check package files
-a Thorough scan mode
--auto-detect Auto detect drive and mount point
-c=? Read this configuration file
-o=? Set an arbitrary configuration option, eg -o dir::cache=/tmp
See fstab(5)

root@alejandro-UBUNTU:/home/alejandro-ubuntu# apt-get update
Ign cdrom://Ubuntu 12.10 _Quantal Quetzal_ - Release amd64 (20121017.5) quantal InRelease
Ign cdrom://Ubuntu 12.10 _Quantal Quetzal_ - Release amd64 (20121017.5) quantal/main Translation-es_PE
Ign cdrom://Ubuntu 12.10 _Quantal Quetzal_ - Release amd64 (20121017.5) quantal/main Translation-es
Ign cdrom://Ubuntu 12.10 _Quantal Quetzal_ - Release amd64 (20121017.5) quantal/main Translation-en
Ign cdrom://Ubuntu 12.10 _Quantal Quetzal_ - Release amd64 (20121017.5) quantal/restricted Translation-es_PE
Ign cdrom://Ubuntu 12.10 _Quantal Quetzal_ - Release amd64 (20121017.5) quantal/restricted Translation-es
Ign cdrom://Ubuntu 12.10 _Quantal Quetzal_ - Release amd64 (20121017.5) quantal/restricted Translation-en
Leyendo lista de paquetes... Hecho

root@alejandro-UBUNTU:/home/alejandro-ubuntu# apt-get install build-essential linux-header-`uname -r`
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
El paquete build-essential no está disponible, pero algún otro paquete hace referencia
a él. Esto puede significar que el paquete falta, está obsoleto o solo se
encuentra disponible desde alguna otro origen

E: El paquete «build-essential» no tiene un candidato para la instalación
E: No se ha podido localizar el paquete linux-header-3.5.0-17-generic
E: No se pudo encontrar ningún paquete con la expresión regular «linux-header-3.5.0-17-generic»

alguna sugerencia mas ??

+1
0
-1

asd