[Como] Instalar Ubuntu junto a Windows 8

Imagen de Gabriel_M
11,543 puntos

1- Crear una partición desde Windows, reduciendo sus particiones y dejando espacio libre, por ejemplo siguiendo esta guía:
http://www.conecta-pc.es/windows/crear-particiones-windows-8.html

2- Descargar la imagen iso de X/K/L/Ubuntu 13.10 versión de 64 bits

2- Grabar la imagen .iso, en un Dvd a baja velocidad ( Imageburn, http://www.imgburn.com/index.php?act=download) o en pendrive Usb (Universal USB Installer, http://www.pendrivelinux.com/universal-usb-installer-easy-as-1-2-3/)

3- Desde Windows 8, ir al menú de apagado y pulsar en el botón de Reiniciar, manteniendo presionado la tecla Mayúsculas.

4- En la ventana emergente de Windows seleccionar: Resolver problemas

5- En la siguiente ventana emergente seleccionar: Configuración del firmware UEFI

6- Reiniciado el ordenador, ingresar a la Bios
Desactivar:
Secure Boot
La opción del boot que esta debajo de Secure Boot
Cambiar:
La secuencia de inicio al dispositivo que aloja X/K/L/Ubuntu 13.10 64 bits
Guardar la configuración
Insertar el dispositivo e iniciar desde él.

7- X/K/L/Ubuntu deberá iniciar en modo EFI, con un menú diferente al usual.

8- Tanto si se inicia la instalación directamente como si se prueba el sistema y luego se inicia la instalación, al llegar a particionamiento se elige avanzado, y se crea en el espacio liberado desde Windows, las siguientes particiones:

Una de unos 250 Mb en Sistema de arranque EFI
Editado: ---------------------
Partición EFI formateada como FAT (tipo EF00 ), para alojar los archivos del cargador de arranque.
Fin edición:------------------
Una de 30 Gb sistema de archivos ext4, punto de montaje /
Una de 2 Gb uso común, triple de la ram para hibernar y/o suspender sistema de intercambio, montaje por defecto
Una del espacio sobrante, sistema de archivos ext4, punto de montaje /home

El Grub en la partición asignada a /

9 -Al reiniciar, luego de terminada la instalación entrara automáticamente a Ubuntu y no habrá acceso para Windows, es necesario instalar Boot-Repair
Se abre una terminal y se ejecuta en ella:

sudo su
add-apt-repository ppa:yannubuntu/boot-repair
apt-get update
apt-get install -y boot-repair
boot-repair

10 - Boot repair, mostrara una ventana donde informa un sistema EFI, que requiere corrección del Grub,
Se aplica y listo.
Al reiniciar tanto Ubuntu como Windows 8 podrán ser iniciados.

Imagen de aalleexx81
+1
0
-1

Editado:
Las preguntas en el foro respectivo.
No en tutoriales

+1
0
-1

Alex Welcome - Computer Scientist and Engineer

Imagen de nolin
+1
+3
-1

Con esto del nuevo UEFI (UEFI sustituye a BIOS) y discos GPT (antes eran al estilo msdos, con MBR) siempre hay malos entendidos.

La partición EFI es una que contiene los archivos para arrancar un sistema operativo.
Como son pequeños, la EFI puede ser pequeña, de unos 200 MB. y tiene obligatoriamente que estar formateada en FAT16 o mejor en FAT32.

Puede haber una o varias particiones EFI, pero sólo se usará para arrancar la marcada como "bootable".
Si tienes interés, arranca con LiveCD (o USB), con el gparted quitas la flag de "boot" y así podrás ver su contenido con Nautilus. Pero si no la vuelves a marcar "boot", ya me dirás cómo haces para arrancar.

El grub "tradicional" no funciona con sistemas UEFI. El boot-repair soluciona ésto.
Arranca con LiveCD, instálalo y ejecútalo como dijo Grabriel_M y sigue las instrucciones que te diga. Si es necesario, abre una segunda terminal para hacer lo que boot-repair te pide.

No se debe olvidar que ambos sistemas MSW y Ubuntu tienen que instalarse con la misma opción "secure boot" de la UEFI. Si está activada, lo está para los dos; y si no está activada, no lo estará para ninguno.

Por último, en la UEFI el orden de arranque debe ser Ubuntu antes que MSW. De lo contrario no se mostrará el menú de Grub y arrancará directamente en W8.

+1
+3
-1
Imagen de aalleexx81
+1
0
-1

Un millón de gracias en primer lugar a Gabriel por su excelente tutorial.

Y en segundo lugar mis agradecimientos a nolin por su aclaración.

Finalmente arranqué Ubuntu en modo liveusb, instalé Boot Repair tal como me indicaba Gabriel en su tutorial y seguí las indicaciones que me iba dando una a una y he conseguido reparar el GRUB y que funcionara lo que pretendía, tener la opción de arrancar Windows 8 o Ubuntu 12.10.

De nuevo un millón de gracias a los dos.

Un cordial saludo.

+1
0
-1

Alex Welcome - Computer Scientist and Engineer

Imagen de eduardomunyoz
+1
0
-1

llevo por lo menos 12 veces instalando ubuntu junto a windows 8
siempre me arranca windows 8, pasa del grub y del ubuntu
he dehabilitado el secure boot, he deshabilitado el arranque uefi, he bajado la ultima version 13.04
nada de nada
ya no se que hacer.

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

Y que te devuelvan el dinero, esa laptop no te permite arrancar/usar el sistema operativo de tu elección, mándala por un tubo.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de leonoc25
+1
0
-1

no me funciono como yo queria gracias una cosa menos que tengo que hacer jajaj

bueno te cuento mi problema para los mas genios ya que soy nuevo
pero me a encantado un monton gnu/linux me encanta jugar con el terminal jajaj
bueno os cuento mi problema con un toshiba i7
e compartido el disco entre win 8 que benia instalado por defecto pero como la verdad desde que prove ubuntu en la de sobremesa solo uso ubuntu que feo a win 8 jajajajajaj
y la otra mitad e puesto ubuntu 13.04

tengo desactivado secure boot

pero mi sorpresa es que cuando inicio el pc no me sale el grub de ubuntu si no que directamente se va a win 8
e hecho este tutorial haber si me solucionaba algo del grub pero solo los cambios los veo cuando oprimo la tecla f12
me sale boot menu
hdd/ssd toshiba
select a divece to boot
sistema vamos a iniciar el de win8 o el de ubuntu
y asi es la unica forma que puedo desde el portatil iniciar en ubuntu 13.04 no e podido encontrar otra forma haber quien da con el santo grial

+1
0
-1
Imagen de nagios
+1
0
-1

Has hecho todo bien, a mi me pasaba lo mismo, lo único que tienes que hacer es en el boot de la bios decirle que arranque con el disco que tiene el grub, verás que todo sale bien, el dico que ponga linux.

+1
0
-1
Imagen de jtripleeme
+1
0
-1

Muchas gracias.. Seguí los pasos y tengo el arranque dual funcionando de lujo.
Tengo Windows 8 y Ubuntu 13.10 en una Notebook ACER Aspire V5-571

+1
0
-1
Imagen de andoru
+1
0
-1

hola pa yo es q tengo curiosidad por saber como hiciste para intalar en tu laptop yo tengo una igual y lastimosamente no he podido y honestamente no quiero intentar de nuevo sin tener la info bien clara y consisa

+1
0
-1
Imagen de Omar T
+1
0
-1

Es necesario crear todas estas particiones manualmente, Obligatoriamente o es posible instalarlo automaticamente??. En mi caso tengo un espacio libre sin asignar contiguo a la partición de Windows 8.1

+1
0
-1
Imagen de cuentos
+1
0
-1

...... instalación que hice con partición GPT pero win7. Es mejor dejar que el instalador haga el particionado, para que este tome la primera partición de GPT, y hay ponga la /boot
como sea si decides para mayor seguridad crear tu mismo las particiones, y tienes problemas para la /boot, despues puedes instalar boot-repair.

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de Omar T
+1
-3
-1

Saludos.
Hace algún tiempo (al principio de la era Linux) era posible tener arranque usando un gestor de arranque copiado en un floppy. Cuando se iniciaba el PC con el disco adentro, se iniciaba el gestor de arranque de linux, y si no, seguia a windows.

Es posible instalar el grub en un pendrive? de tal forma que no se afecte las particion EFI original y no haya que reparar nada despues.

De tal forma si queremos usar ubuntu, le colocamos la pendrive y listo!

Saben si esto es posible??

+1
-3
-1
Imagen de teamcpc
+1
0
-1

Me parece que lo que estás buscando se llama supergrubdisk.

+1
0
-1
Imagen de nagios
+1
0
-1

No me deja el arranque EFI, sino que sigue con el de UEFI, sólo arranca con windows 8. Aunque he instalado el Ubuntu 13.10, con la partición /boot de 250Mb. He desactivado el Secure boot antes. En la instalación me ha dicho el Grub que no podía instalar y que era un fallo o error fatal y me sacado de mala manera de la instalación Tanto que me ha desactivado el DVD, y no me funciona ni el windows 8.1

+1
0
-1
Imagen de nagios
+1
0
-1

Hola a todos, como digo ya está todo solucionado, pero me ha costado lo mío: Hice todo lo que me dijisteis, pero en la bios tuve que ir poniendo y quitando porque también se metió algo llamado Legalicy, al final, todo se arregló y cogió el ubuntu con el EFI y también podía arrancar con el UEFI de windows 8.1.
Me estuve viendo vídeos en youtube a cual más malo, todo eran para portátiles, ninguno para un ordenador clónico. Después el ubuntu me dio problemas de arranque, me dejó el escritorio limpio, tuve que formatear y me quitó el grub y el arranque y volví a recuperar lo con el boot-repair desde ubuntu 13.10 del disco y me lo arregló todo y ahora ya lo tengo todo, Un saludo y gracias a todos. (Os escribo desde él).

+1
0
-1
Imagen de mgr2642
+1
0
-1

Qué pena no haber visto este artículo antes. Por cierto, creo haber incumplido las normas del foro abriendo un nuevo tema en el foro en lugar de tomar este hilo.
Gracias y un saludo

+1
0
-1
Imagen de neciloreivaj
+1
0
-1

Hola,

estoy siguiendo los passos de Gabriel, en un portàtil acer aspire V5, pero al reiniciar y instal·lar ubuntu se corta la instalacion con el siguiente mensaje:
stopping CPU interrups balancing daimon

agradecería ayuda

+1
0
-1
Imagen de danul835
+1
-1
-1

Buenas,
no me ha quedado muy claro que hay que hacer con lo de la partición de arranque EFI que indicas en el paso 8. ¿Hay que crearla? ¿Eso es para solucionar lo de que no aparezca ningún menú para seleccionar el SO al arrancar y que por tanto inicie directamente Windows 8?

Tengo deshabilitado el CSM y el secureboot, e instalé Ubuntu 13.10, pero no me hay manera de iniciarlo. Supongo que tendrá que ver con el mensaje ese de al terminar de particionar de que no haya una partición BIOS creada y que por tanto es posible que no inicie Ubuntu. Lo reinstalé, creando una partición de unos 300 MB, pero sigue sin arrancar.
Un saludo y gracias.

+1
-1
-1
Imagen de Gabriel_M
+1
+1
-1

.... y se crean en el espacio liberado desde Windows, las siguientes particiones:
Una de unos 250 Mb en Sistema de arranque EFI
Una de 30 Gb sistema de archivos ext4, punto de montaje /
Una de 2 Gb uso común, triple de la ram para hibernar y/o suspender sistema de intercambio, montaje por defecto
Una del espacio sobrante, sistema de archivos ext4, punto de montaje /home
El Grub en la partición asignada a /

+1
+1
-1
Imagen de danul835
+1
0
-1

Claro, ¿pero lo de sistema de arranque EFI a qué se refiere? ¿Es una opción de esas que se elije como cuando creas la del swap, que pone "área de archivos de intercambio"?, porque no me aparece esa opción, solo una de BIOS, que es la que he probado, pero sigue sin funcionar. Saludos.

+1
0
-1
Imagen de Gabriel_M
+1
+2
-1

Si se va a usar Efi para el inicio es necesario tener un sistema de particiones Efi formateado con FAT (tipo EF00 ), para que contenga los archivos del cargador de arranque.

+1
+2
-1
Imagen de mgr2642
+1
-1
-1

Hola:
En la visión Gparted de un equipo con Win8 aparecen las siguientes particiones: (he intentado meter la imagen pero no lo he logrado, debería haber hecho

/dev/sda1 ntfs Recovery 400MB 258MB 248MB hidden, diag
/dev/sda2 fat32 ESP 300MB 51MB 248MB boot
/dev/sda3 ! unknow 128MB ----- ----- msftres
/dev/sda4 ntfs Acer 442GB 83GB 358GB msftdata
/dev/sda5 ntfs Push/Button/Reset 23GB 13GB 10GB hidden, diag

Entiendo que desde Win8 hay que cambiar /dev/sda4 y crear espacio para insertar desde el instalador de Ubuntu el directorio raíz (/), el área de intercambio y /home, con sus respectivos sistemas de archivos (ext4 y swap) (supongo que estas dos últimas pueden dejarse de lado).
Tengo dudas sobre si el sistema de arranque EFI es /dev/sda2. Tampoco tengo claro -si lo anterior es cierto- si la creación de ese espacio de 250MB (en este caso faltaría) se hace desde el mismo Win8 o en la instalación de Ubuntu. O estoy confundido y se crea también en el espacio anterior junto con los demás.
Por último, sobre dónde instalar Grub parece que no va al MBR de sda sino a la partición raíz de ubuntu (la que sea). En fin, perdonad todas estas dudas pero ya hice en su momento una instalación rupturista sobre un equipo Win8 y no quisiera hacer lo mismo al equipo de una colega, a quien he prometido una instalación compatible.
Gracias anticipadas y perdonad la longitud del texto.

+1
-1
-1
Imagen de nolin
+1
0
-1

mgr2642, por lo que muestras:

La partición dev/sda2 es pequeña (300 MB), formateada al tipo fat32 y marcada como de arranque (boot), Sí, ésta es la partición EFI. Pero recuerda que es posible que necesites otra segunda partición EFI para instalar el grub.

La partición dev/sda4 es la utilizada actualmente para win8. Es esta la que hay que trocear, pues las otras son para poder restaurar el equipo a como venía de fábrica.

Puedes trocearla desde Windows o utilizando GParted. Lo que NO puedes desde Windows es formatear los nuevos trozos al tipo ext4 (el de Linux). O sea, hazlo desde GParted, mejor antes de instalar, arrancando con el LiveCD, en modo "probar antes de instalar". (No formatees el trozo que dejes para win8, o perderás lo que haya en él).

Al Grub dile que use la partición que hayas asignado y formateado para "/". Si no va, prueba con la EFI. Se instalará, pero (lee los primeros mensajes en este hilo) necesitaras el boot-repair.

+1
0
-1
Imagen de mgr2642
+1
0
-1

Creo que ahora me voy aclarando, tenía dudas sobre dónde crear la partición EFI. No sabía que podría haber varias, aunque supongo que sólo será efectiva la que esté marcada como de arranque. Como no he tenido la ocasión todavía de enfrentarme a una instalación real (bueno sí, pero me la cargué y estoy encantado con ubuntu 14.04 64), me gusta la idea de no tocar la configuración de fábrica y poder restituir el equipo en caso de fracaso. Con esta prevención, probar será mucho más sencillo y espero tener éxito en mi próxima experimentación.

+1
0
-1
Imagen de andoru
+1
0
-1

hola gente despues de mucho mucho batallar pude instalar kubuntu q me parece genial pero cuando me aparece la terminal de grub rescue no me deja usar los comando del terminal para instalar el boo-repair como puedo hacer y es q la cuestion es q es algo urgente xq necesito hacer una tarea en linux para esta semana gracias de antemano por su ayuda ojala me puedan ayudar xq en verdad me urge

+1
0
-1
Imagen de t.mcclure
+1
0
-1

Buenos días
Siguiendo los pasos del tutorial tengo instalado los dos sistemas operativos, pero siempre me arranca con windows 8. Para poder arrancar con Ubuntu tengo que pulsar la tecla que en mi ordenador le permite entrar a la bios y desde ahí elegir Ubuntu. Una vez hecho esto si que sale el grub.
Creo que el problema viene ocasionado porque el windows 8 al instalarse me genera 3 particiones(no sé si es mi disco de instalación o unos drivers de HP que según se instalan en los mensajes pone algo de UEFI que he sido incapaz de descifrar):
1- Partición de recuperación (sda 2)
2- Partición Efi (sda 3)
3- Partición para Windows (sda4)

Mi disco actualmente tiene además de las anteriores
4 -Partición al inicio del disco marcada como boot y formateada con fat32 de tipo EFI (sda1)
5- Partición de swap (sda 5)
6- Partición montada en / (sda 6)
7- Partición /home (sda 7)
Al utilizar el boot-repair como indican nunca me da la opción de utilizar la sda 1, siempre me da la opción de la sda3 que ha generado la instalación de Windows. Y cuando termina el proceso me da un mensaje de advertencia diciendo que donde se ha realizado la reparación puede estar muy lejos y no ser detectado por mi bios. Me recomienda crear una partición de 400 MB al inicio del disco y montarla como /boot.

Consultando con el gparted veo que las dos particiones EFI son boot, pero la que ha generado al instalar windows está montada en /boot/efi sin embargo la otra está sin montar. ¿Pueden venir por ahí los problemas?
Estoy tentado de cargarme la que ha generado la instalación de windows y utilizar la primera montándola como /boot/EFI pero como eso no lo he visto en ningún tutorial, foro, etc y no quiero tener que volver a realizar todo me da un poco de “miedo”.
¿Alguna idea?. Gracias

+1
0
-1
Imagen de nthny
+1
0
-1

Después de hacer eso, me sale:

http://i60.tinypic.com/1445q4p.jpg

algo hice mal?

+1
0
-1
Imagen de cesar1086
+1
0
-1

Disculpen pero en mi W8 no sale la opción "Configuración del firmware UEFI"

Además de que cuando logro que por fin algún livecd arranque, este no detecta ningún Disco Duro.

Saludos.

+1
0
-1