moto4lin - no hay caso (Solucionado)

Imagen de elaleyelrojo
0 puntos

Probe en el buscador de aca, en google en general, lo instale de todas las manera posibles, y siempre llego a lo mismo.

Sigo todos los pasos pero cuando pongo “upload list” en la pantalla principal no me carga los datos del V3
me aparece este error

[info] Switching device /dev/ttyACM0 to P2K mode…
[info] AT E0 answer: AT E0 OK
[info] Phone answer: OK
[info] Phone pluged as AT
Getting file list
[error] Unable to get drive list
Complete

aca dejo el link de la pantalla
http://img162.imageshack.us/img162/5410/pantallazoud0.png

tengo ubuntu 7.04 cualquier ayuda sera bienvenida

 

Imagen de sergiosan00709
+1
0
-1

Para manejar los archivos del V3 te aconsejo que instales el WAMMU, que es una herramienta muy buena para los telefonos Motorola , yo lo e probado con un Motorola V235 y con el V3.

 

****************************************************

Siempre hay opciones de poder hacer lo que uno desee hacer. Siempre y cuando uno desee hacerlo.

Si Microshit quiere pelea, la comunidad GNU/Linux le dara Pelea y

+1
0
-1


Viewsonic 22", 8Gb de Ram Kingston, AMD Phenom X4, 2 multiquemadoras LG, 2 Nvidia Gforce 9600GT en SLI, 2 HDD de 250GB c/u,Mainboard Gigabyte GA-M57SLI-S4, Case COSMOS de Cooler Master.

Imagen de elaleyelrojo
+1
0
-1

ahi me baje el wammu, ahora lo pruebo y te cuento como me fue

gracias 

+1
0
-1
Imagen de elaleyelrojo
+1
0
-1

la verdad que funciona, me reconoce el telefono, contactos, etc, pero no puedo gestionar fotos y mp3, no tiene esa opcion? o por lo menos no la encuentro. Hay que activarla de alguna manera?

+1
0
-1
Imagen de sergiosan00709
+1
0
-1

Trata de buscar en la carpeta Media (donde estan las Unidades), alguna que diga "Disk" o "Phone", para que la montes manualmente.

El Wammu aun no tiene (por lo que he podido probar) la manipulacion de multimedia del telefono, pero quiza buscando bien puedas encontrar alguna funcion, ya que yo solo lo use para pasar mis contactos y mensajes que es para lo que yo lo necesitaba y no lo use a fondo .

Dentro de los repositorios hay como 4 programas mas para el manejo de los telefonos, te aconsejo de que busques y pruebes, yo solo he probado : el Wammu (que me funciono de maravilla para lo que quise) y el administrador de telefonos (el cual no e funciono).

Yo ya vendi el fono, por falta de plata, por lo que no te puedo dar mas referencia por el momento, sino encantado.

****************************************************

Siempre hay opciones de poder hacer lo que uno desee hacer. Siempre y cuando uno desee hacerlo.

Si Microshit quiere pelea, la comunidad GNU/Linux le dara Pelea y

+1
0
-1


Viewsonic 22", 8Gb de Ram Kingston, AMD Phenom X4, 2 multiquemadoras LG, 2 Nvidia Gforce 9600GT en SLI, 2 HDD de 250GB c/u,Mainboard Gigabyte GA-M57SLI-S4, Case COSMOS de Cooler Master.

Imagen de elaleyelrojo
+1
0
-1

listo gracias probare de esa manera o buscare algun otro programa

Igualmente espero ver si alguien que tenga v3 o algun otro motorola si pudo hacer funcionar el moto4lin 

 

+1
0
-1
Imagen de sergiosan00709
+1
0
-1

 Te doy mis bendiciones... Cualquier cosa pasas la voz.

 

****************************************************

Siempre hay opciones de poder hacer lo que uno desee hacer. Siempre y cuando uno desee hacerlo.

Si Microshit quiere pelea, la comunidad GNU/Linux le dara Pelea y

+1
0
-1


Viewsonic 22", 8Gb de Ram Kingston, AMD Phenom X4, 2 multiquemadoras LG, 2 Nvidia Gforce 9600GT en SLI, 2 HDD de 250GB c/u,Mainboard Gigabyte GA-M57SLI-S4, Case COSMOS de Cooler Master.

Imagen de elaleyelrojo
+1
0
-1

probe el kmobile pero es simil al wammu solo contactos, sms, etc, nada de multimedia

en MEDIA no aparece el "phone" o similar.......

parece que el unico que sirve es el moto4lin,,,,,, pero no me anda, esperare entonces que alguien que lo use me de una mano

 

saludos 

+1
0
-1
Imagen de wartlog
+1
0
-1

Mira con mi V3 (de la primera generacion) funciona de perlas el moto4lin te recomiendo que visites la pagina principal del proyecto ya que ahy te enseñan como conectar varios tipos de telefono,

en mi caso nada mas tuve que conectar el telefono e ir al kinfocenter y buscar dentro del listado de hardware que se conecta por USB, en gnome no me acuerdo como se llama la utilidad pero es donde te muestra todo el hardware conectado, bueno de ahy vas a sacar tanto el ID del vendedor como el ID del aparato  

 

posteriormente entra al moto4lin con permisos de super usuario mediante la consola haciendo

sudo moto4lin

posteriormente entre en el menu preferencias y puse los datos obtenidos comenzando con:

 ACM device:  /dev/ttyACM0

AT vendor ID:  22b8

AT product ID:  4902

P2K vendor ID:  22b8

P2K product ID: 4901

 

NOTA: Estos datos los tienes que actualizar conforme te los reconozca tu telefono quitando el ACM device 

 De ahy en la parte de abajo le das en update list y seleccionas tu telefono y le das click donde dice set as P2k device

 Finalmente para que se conecte abres un terminal en la consola y escribes 

sudo echo AT+MODE=8 > /dev/ttyACM0

 Listo ya con eso deberia de funcionar tu V3, por cierto si reinicias tu aparato desde el programa tendras que volver a escribir este comando en la terminal para que se reconozca tu telefono y ademas siempre tendras que entrar al moto4lin en modo superusuario ya que en modo normal a mi no me funciono y nunca se conecto saludos y espero haberte sido de ayuda

 de cualquier forma te dejo la pagina donde encontre la informacion, saludos

http://moto4lin.sourceforge.net/wiki/Category:Models

________________

"Each secret is a spine in the heart that only a few can take it out"

Linux User #447391

Ubuntu User #14889

+1
0
-1

________________

"Each secret is a spine in the heart that only a few can take it out"

Linux User #447391

Ubuntu User #14889

Imagen de elaleyelrojo
+1
0
-1

Finalmente para que se conecte abres un terminal en la consola y escribes

sudo echo AT+MODE=8 > /dev/ttyACM0

 

Para hacer esto te refieres abrir una solapa mas de "terminal"? bueno asi lo hice yo y me tira este error....

alejandro@alejandro-desktop:~$ sudo echo AT+MODE=8 > /dev/ttyACM0
bash: /dev/ttyACM0: Permiso denegado

 

agrego todo lo que me aparece en la terminal

X Error: BadDevice, invalid or uninitialized input device 169
  Major opcode:  147
  Minor opcode:  3
  Resource id:  0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 169
  Major opcode:  147
  Minor opcode:  3
  Resource id:  0x0
Failed to open device
Form1
PhoneMan
New mode: 2
New mode: 1
P2kProc::doConnect()
QSettings::sync: filename is null/empty
QSettings::sync: filename is null/empty
New mode: 0
QSettings::sync: filename is null/empty
New mode: 1
P2kProc::doConnect()
QSettings::sync: filename is null/empty

+1
0
-1
Imagen de franchus3
+1
0
-1

Si no ejecutas el moto4lin en modo root no funciona... esa es la solucion... por lo que vi tienes bien configurado el programa... yo tambien pase por lo mismo....

+1
0
-1
Imagen de elaleyelrojo
+1
0
-1

como se ejecuta en modo root?

 

listo ya lo busque en el "buscador" gracias

ahora pruebo si anda 

+1
0
-1
Imagen de elaleyelrojo
+1
0
-1

Gracias franchus3 !!!!!!!!!

Ahora si me funciona, por fin

 

+1
0
-1
Imagen de sergiosan00709
+1
0
-1

Felicidades por tu logro.

Ya viste, en GNU/Linux todo tienen solucion 

 

****************************************************

Siempre hay opciones de poder hacer lo que uno desee hacer. Siempre y cuando uno desee hacerlo.

Si Microshit quiere pelea, la comunidad GNU/Linux le dara Pelea y

+1
0
-1


Viewsonic 22", 8Gb de Ram Kingston, AMD Phenom X4, 2 multiquemadoras LG, 2 Nvidia Gforce 9600GT en SLI, 2 HDD de 250GB c/u,Mainboard Gigabyte GA-M57SLI-S4, Case COSMOS de Cooler Master.

Imagen de franchus3
+1
0
-1

Eso es lo lindo que tiene esto... algunos se matan  configurando cosas y demas y despues lo comparten con los demas.... gracias a los foros aprendi muchisimo.... amo a mi consola! jajaja (para los amantes de las consolas.... instalen yakuake.... (sudo apt-get install yakuake)), es la consola al alcance del F12

Saludos 

+1
0
-1
Imagen de keyboardphd
+1
0
-1

He estado intentando conectar mi Motorla L6 tanto con moto4lin como con el kmobile y de ninguna manera me funciona, el moto4lin dice q encuentra un device, pero no hace nada con él, el USB View no arroja ninguna información, no da lista alguna en el file manager... es como que no lo encontrara.. será que no funciona con mi telefono?

 

+1
0
-1

-software should be free-

Imagen de bonyo
+1
0
-1

Tengo un V235, e hice todo lo detallado arriba, y me ocurre que no me puede conectar el teléfono el moto4lin.

Y cuando hago un "sudo p2ktest" me sale esto:

 P2k Test
Device list:
22b8:4902: [Motorola Inc.] [Motorola Phone (V235)]
0000:0000: [Linux 2.6.22-14-generic uhci_hcd] [UHCI Host Controller]
0000:0000: [Linux 2.6.22-14-generic uhci_hcd] [UHCI Host Controller]
0000:0000: [Linux 2.6.22-14-generic uhci_hcd] [UHCI Host Controller]
0000:0000: [Linux 2.6.22-14-generic uhci_hcd] [UHCI Host Controller]
0000:0000: [Linux 2.6.22-14-generic ehci_hcd] [EHCI Host Controller]
Switching to P2K...
P2k Phone found

(E_p2k_openPhone.-1: no p2k phone)
(E_p2k_sendControl.-6: no connection)
(E_p2k_getPhoneName.-14: E001)
Can not get phone model
(E_p2k_sendControl.-6: no connection)
(E_p2k_getDriveName.-14: E001)
Can not get drive name
(E_p2k_sendControl.-6: no connection)
(E_p2k_freeSpace.-14: E001)
Can not get free space(E_p2k_sendControl.-6: no connection)
(E_p2k_fileCount.-14: E001)
Can not get file count(E_p2k_sendControl.-6: no connection)
(E_p2k_fileCount.-14: E001)
(E_p2k_fileList.-14: E000)

+1
0
-1

 

bonyo: Ubuntu User number is # 20856

Imagen de bonyo
+1
0
-1

Me tira estas líneas cuando abro moto4lin (habiendo hecho todo el proceso anterior, y ejecutando como root.) con el celular conectado :

 

$foligna@foli:~$ sudo moto4lin
$Form1
$PhoneMan
$New mode: 1
$New mode: 2
$P2kProc::doConnect()
$(E_openPhone: Unable to set configuration)

 

+1
0
-1

 

bonyo: Ubuntu User number is # 20856

Imagen de Tsukishiro
+1
0
-1

siiii.. muchas gracias, yo tenia el mismito problema pero iniciandolo con sudo moto4lin , quedo resuelto el problema, esta solucion nisiquiera la vi en la ayuda de debian ni ningun otro foro, asi que muchas gracias

+1
0
-1

si has de tener una rosa, tienes que mirar la espina
si no sabes del dolor, no sabras de la alegria