No me funciona el botón izquierdo del ratón (solucionado)

Imagen de luis_rgi
0 puntos

Hola

Soy usuario de ubuntu. No sé linux no comandos ni entrar a la consola. Me lo instalé hace tiempo y me va de cine.

Solo una cosa necesité de alguien que sabía de informática: configurar la impresora.

Ahora el botón izquierdo del ratón ha dejado de funcionar. Estoy currando con el touchpad.

Hay preguntas similares a la mía sin respuesta. Parece por tanto que ocurre de vez en cuando a otros usuarios.

¿Alguien sabe como solventar esta cosa tan rara?

Gracias

Imagen de rioport
+1
0
-1

Eso quiere decir que funcionó ¿Por qué le hechas la culpa a Ubuntu, has probado en otro S.O. si aún funciona?. Sabiendo que es el botón izquierdo es más probable que tu ratón ya haya expirado, pues es el botón que más se usa.

+1
0
-1

-- GC --

Imagen de edro1992
+1
0
-1

¿Tienes Windows instalado aunque sea en una maquina virtual y has probado si ahí si funciona? Otra solución es que actualices el sistema, puede que tengas confictos entre librerias o paquetes que sean antiguos ¿que versión de Ubuntu estás utilizando?

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

aparte de comprar otro mouse....

Pero /var/log/syslog debe de decir algo cuando tratas de usar el mouse.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de luis_rgi
+1
0
-1

Gracias por las respuestas.
No me funciona efectivamente el ratón en los dos pc en los que tengo la 12.04 de ubuntu (botón izquierdo) ni los botones equivalentes del raton el el touch pad. Solo el físico derecho del ratón.

Lo de var/log/syslog no sé lo que es. Si pudieras darme alguna pista.

Me estoy dando cuenta de que si no sabes informática...la cosa se pone chunga....

No pasa nada. De todos modos para el qeu me reprocha que relacione a ubuntu con el problema pon en google "ubuntu 12.04 left mouse button not working".

Otros problemas similares:

http://www.taringa.net/posts/linux/6881725/Instalastes-UBUNTU-y-el-Touch...

http://comoinstalarlinux.com/foros/index.php?topic=8.0

http://www.ubuntu-es.org/node/2601

http://foro.ubuntu-guia.com/Ubuntu-12-04-no-me-reconoce-el-raton-USB-td4...

http://es.answers.yahoo.com/question/index?qid=20120821102115AA1v5WB

http://www.ubuntu-es.org/node/171583

http://askubuntu.com/questions/128265/mouse-pointer-touchpad-getting-stu...

http://superuser.com/questions/437601/mouse-touchpad-stuck-in-ubuntu-12-...

http://askubuntu.com/questions/163548/left-mouse-button-stops-working-ub...

http://askubuntu.com/questions/184222/left-mouse-button-not-working-in-x...

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

Investígalo por tu cuenta.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de rioport
+1
0
-1

* El primero sólo aplica para touchpads, no para ratones USB, No es similar.

* En el segundo los clicks con el touchpad funcionan, además dio información que tú no das; la salida del comando xinput -list.

* El tercero, por monesvol el hilo es del 2005, el problema es con el servidor de las X, si ese problema aún existiera los reportes de fallos serían a montones por la cantidad de tiempo que llevaría, así que tampoco aplica.

* 4to Aquí ni siquiera reconoce el usb, pero da poquisimos detalles; no aplica.

* 5to -- No hay bola de cristal -- descartado.

* 6to El ratón de la lap no funciona, el externo sí; no aplica a tu problema.

* 7: Aplica sólo a Gnome-shell.

* 8: Le pasa sólo cuando reanuda la PC desde la suspensión.

* 9: Este sí se parece, pero sólo le pasa con ratones USB. ¿Al descargar y cargar el módulo usbhid funciona nuevamente tu ratón externo?, cuando no te funciona el botón izquierdo ¿puedes desplazarte en Firefox con el mencionado botón?.

* 10 Sólo le pasa en Xubuntu ¿Te pasa lo mismo a ti? ¿Has probado la solución que aceptó el usuario que pregunta, te funcionó?.

¿Has probado el ratón USB con otro SO?, en las mismas maquinas lo podrías probar con otras versiones de Ubuntu desde el modo live ¿las dos maquinas son laptops ¿Que marca, modelo, ...?. En ambas funciona bien al principio y al poco rato deja de funcionar, O funcionó hace un tiempo, ahora ya no funciona ni en una ni en la otra.

Sin más información tú hilo se irá para el archivo muerto ya que aquí no hay servicio de bola de cristal, y tú quizá termines comprándote otro ratón.

+1
0
-1

-- GC --

Imagen de Gabriel_M
+1
0
-1

... las indicaciones de tus búsquedas:
Abre una terminal.
Ejecuta en ella:

sudo su
apt-get update
apt-get install xinput
xinput list

Este último comando te dará una salida parecida a esta:

⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ ImPS/2 Generic Wheel Mouse              	id=9	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Power Button                            	id=6	[slave  keyboard (3)]
    ↳ Power Button                            	id=7	[slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard            	id=8	[slave  keyboard (3)]
    ↳ ACPI Virtual Keyboard Device            	id=10	[slave  keyboard (3)]

En este caso el mouse es: ImPS/2 Generic Wheel Mouse id=9
Identificado su id, 9 en este caso, ejecutas en la misma terminal:

 xinput get-button-map 9

Debe dar una salida similar a esta

1 2 3 4 5 6 7 

Si el primer número es "0", el botón 1 está desactivado, para reestablecerlo es necesario ejecutar

xinput set-button-map  9  1

Si al reiniciar vuelve el problema, verifica la existencia en tu /home/usuario o en el sistema, la existencia de un archivo ".xinputrc" o un directorio (carpeta) .xinput.d/ con archivos, donde podría haber comandos xinput.

+1
0
-1
Imagen de luis_rgi
+1
0
-1

Gracias Gabriel,

A partir de tus indicaciones un colega me ha echado una mano y la cosa se ha solventado.

Un cordial saludo

+1
0
-1
Imagen de rioport
+1
0
-1

... en éste hilo solucionado la solución se la llevará a la tumba el usuario que preguntó.

+1
0
-1

-- GC --