Pantalla Negra y no recupero parte grafica

Imagen de tatukapata
0 puntos

Hola:
Antes que nada, ya he leido varias opciones con respecto al problema de la pantalla negra pero antes de solucionar lo he arruinado.-

Algunas caracteristicas:
SO: Ubuntu 11.04 (Natty)
Placa Base: GA-G31M-ESL
Procesador: Intel 2,0Gb
Tarjeta Grafica: actualmente la de la placa madre

Sucedio como a la mayoria, realice algunas actualizaciones -que por recomendacion solicitaba el SO- y al reiniciar no llega a arrancar mas bien parece hibernar.-

Intente recuperar por el modo de recuperacion no funciono (detuve la parte grafica X e intentar editar xorg.conf.d pero no encontre) pero en un desliz desinstale completamente Xorg a traves de la consola.-

Hoy en dia, solo puedo ingresar por consola pero no se como instalar nuevamente Xorg.-
A la pc con que tengo inconveniente, no tengo acceso a internet, solo puedo utilizar el liveCd.-

Pense instalar desde livecd Xorg pero no tengo el conocimiento suficiente para lograrlo. No me gustaria borrar e instalar de nuevo sino mas bien aprender como solucionar el inconveniente.-

Desde ya, le agradezco .-

Imagen de Jose Luis 1320
+1
0
-1

¿y nosotros como vamos a saber que tarjeta gráfica tiene tu tarjeta madre? No tenemos tu tarjeta madre a la mano, tu sí.

al reiniciar no llega a arrancar mas bien parece hibernar.-

Bien, explícate esto, yo no te entiendo.

Intente recuperar por el modo de recuperacion no funciono (detuve la parte grafica X e intentar editar xorg.conf.d pero no encontre) pero en un desliz desinstale completamente Xorg a traves de la consola.-

¿Exactamente que hiciste?, en el modo de recuperación no hay modo gráfico a menos que tu lo especifiques; /etc/X11/xorg.conf.d es un directorio, no un archivo de configuración y ¿como fue tu "desliz" en el que terminaste por desinstalar xorg? El editar un archivo de configuración no desinstala paquetes. Favor de describir como llegaste al problema al intentar solucionarlo.

Hoy en dia, solo puedo ingresar por consola pero no se como instalar nuevamente Xorg.-
A la pc con que tengo inconveniente, no tengo acceso a internet, solo puedo utilizar el liveCd.-

Pense instalar desde livecd Xorg pero no tengo el conocimiento suficiente para lograrlo. No me gustaria borrar e instalar de nuevo sino mas bien aprender como solucionar el inconveniente.-

Desde el live cd en teoría se puede instalar Xorg, tienes que agregar el cd a la lista de fuentes y hacer lo habitual para instalar paquetes, supongo que ya sabes.

Ahi tienes un aprendizaje, si te digo como hacer cada paso, no aprenderías.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de tatukapata
+1
0
-1

Buenas Jose Luis 1320
Estos son los detalles:
Tarjeta de video: VGA - Intel Corporation 82633/G31 Express Integranted Graphics Controller

Con respecto a hibernar, cuando selecciono ingresar a Ubuntu no aparece el logo sino directamente la pantalla da un mensaje de "Estado Hibernado" y se apaga el monitor.-

Ingrese a con el LiveCD y presionando Control + Alf + F1 (segun tutorial http://www.ubuntuforums.org/showthread.php?t=1746908) realice los pasos pero no funciono.-

¿Como lo borre?
Fue ingresando en la terminal
$ apt-get remove xserver-xorg

Intente instalar, desde tu recomendacion, LiveCD, agregando en etc/apt/.sources.list al cdrom; el X (xserver-xorg) pero no lo logre. Ejecutando en la terminal "X" indica que no esta instalada y ejecute "apt-get install xserver-xorg" pero no lo logre instalar.-

De todo modo, recuerdo haber copiado del liveCD, la carpeta completa /etc/X11 y luego /home/ubuntu/.gconf; ./home/ubuntu/.gconfd; .bashrx; .profile y etc/gdm/custom.conf

Bien complicado mi situacion

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

Intente instalar, desde tu recomendacion, LiveCD, agregando en etc/apt/.sources.list al cdrom; el X (xserver-xorg) pero no lo logre. Ejecutando en la terminal "X" indica que no esta instalada y ejecute "apt-get install xserver-xorg" pero no lo logre instalar.-

Asumo que agregaste el CD al archivo sources.list, pero que pasó? ¿Como trataste de instalar xorg? instalas xorg como el mensaje te indica: sudo apt-get install xserver-xorg... ¿No se pudo instalar? ¿que pasó?

¿Terminal X? no hay ninguna terminal X, explícate bien por que no entiendo de que estas hablando y todavía redactas a manera de resumen, no lo hagas.

De todo modo, recuerdo haber copiado del liveCD, la carpeta completa /etc/X11 y luego /home/ubuntu/.gconf; ./home/ubuntu/.gconfd; .bashrx; .profile y etc/gdm/custom.conf

}

Esto no lo hagas, no va a funcionar, a menos que hagas propietario cada uno de los archivos a los usuarios que pertenecen a una instalación por defecto.

Y aún no entiendo lo de la hibernación... ¿arrancas Ubuntu desde tu disco duro o del liveCD? ¿Hibernaste Algo antes de iniciar Ubuntu?

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de tatukapata
+1
0
-1

Jose Luis 1320

Antes que nada, inicio desde el disco duro. No hiberno nada. Intentare explicar paso a paso:

1. Inicio la pc desde el disco duro
2. Selecciono Ubuntu desde la grub de Ubuntu (tengo wi$ y ubuntu en el mismo disco duro)
3. Al seleccionar, despues de un breve lazo, en la pantalla me indica "Sin Señal" y el monitor pasa al estado hibernado o ahorro de energia.-
4. Despues de suceder eso presiono Ctrl + Alt + F1
5. Me logueo como root ingresando el siguiente comando

/$ sudo -i

6. Una vez logueado, ingreso el siguiente comando para que ejecute "X" -supongo para ejecutar el modo grafico-

\# X
"El programa 'X' no se encuentra instalado. Puede instalar escribiendo: apt-get install xserver-xorg"

Escribo en la terminal

/# apt-get install xserver-org

Recibo el siguiente mensaje
El paquete 'xserver-xorg' no está disponible, pero es referido por otro paquete. Esto puede significar
que el paquete falta, está obsoleto estado, o sólo
está disponible desde la fuente.

Sin embargo, los siguientes paquetes lo reemplazan:
xserver-org-video-tseng xserver-org-video-siliconmotion xserver-org-video-i740 xserver-org-video-geode xserver-org-video-input-mouse xserver-org-video-chips xserver-org-video-trident xserver-org-video-s3 xserver-org-video-i128 xserver-org-video-neomagic xserver-org-video-cirrus xserver-org-video-ark xserver-org-video-tdfx xserver-org-video-sisusb xserver-org-video-rendition xserver-org-video-vesa xserver-org-input-evdev xserver-org-video-apm xserver-org-video-sis xserver-org-input-vmmouse

E: El paquete 'xserver-org' no tiene candidato para su instalación

Si ejecuto en la terminal 'startx'

/# startx
exec: 3: /usr/bin/X: not found
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinint: server error
/#

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

si escribes X, no vas a ejecutar X...

el nombre del paquete no es xserver-org, es xserver-xorg, creo que copiaste a mano el texto, aquí hay algunas incoherencias:

 
/# apt-get install xserver-org
Recibo el siguiente mensaje
El paquete 'xserver-xorg' no está disponible, pero es referido por otro paquete. Esto puede significar
que el paquete falta, está obsoleto estado, o sólo
está disponible desde la fuente.

¿Tratas de instalar xserver-org o xserver-xorg?

deslogueate de root, y trata de iniciar X de la siguiente manera:

 
startx --:0

si no funciona trata con startx --:1

bueno, esto siempre y cuando tengas instalado X, que al parecer por las salidas de startx que has puesto, si lo tienes instalado, en este caso, no tiene caso instalar X de nuevo, tal vez es un asunto del driver...

y en todo caso hay que ver que nos dice el archivo /var/log/Xorg.0.log, necesitas permisos de root para ver ese archivo.

Busca por las lineas que comienzan con (EE) y (WW)

Edito: olvide tu salida /usr/bin/X not found te falta el ejecutable de X, disculpa.

Y sospecho que en el cdrom no podrás instalar el paquete xserver-xorg, deberás descargarlo de manera manual, lo guardas en un USB. montas el USB en tu computadora y lo instalas, así

sudo su
mount /dev/sdaX /mnt
cd /mnt
dpkg -i xserver-xorg-core_1.1.********.deb

sdX lo reemplazas según tu USB, esto lo ves ejecutando con permisos de root.

los asteriscos los reemplazas por el nombre completo del paquete.

https://launchpad.net/ubuntu/natty/+package/xserver-xorg-core

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de tatukapata
+1
0
-1

Gracias
Jose Luis 1320, llegue a realizar todos los puntos mencionados pero no se soluciono.-

De todo modo, tuve que reinstalar el SO por necesidad del equipo.-

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

Por eso no funcionó...

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de Harkonen
+1
0
-1

Instalando una nueva versión con live cd y eligiendo la opción de instalar actualizando el sistema anterior , dice algo similar, de esta forma me respetó programas datos,..., no eché nada en falta, a lo mejor no siempre es posible, pero...
Saludos.

+1
0
-1