ati hd7750+catalyst+ubuntu12.10+fglrx+xorg+unity+wine = pesadilla

Imagen de danielln
0 puntos

hola a todos,

Esto es una pesadilla. He dado con el talón de Aquiles de Ubuntu, es decir, configurar una gráfica moderna y molona..... y esperar que todo funcione.

Les cuento, me he comprado una super-chula ATI Radeon HD7750 de 2Gb. En mi pc, con dual boot (ubuntu y win7) usaba antes la vga que viene integrada en placa.... que la verdad, ni idea de cual es..... pero bueno, siempre fue bien aunque no fuera una gran cosa.

Instalo la nueva gráfica, arranco con windows7, instalo los ultimos drivers desde la web de AMD.... todo perfecto, los juegos van de maravilla y la resolución de 1280x1024 va de lujo. CERO problemas.

Arranco con ubuntu..... en principio bien, el sistema se pone solito a 1280x1024..... así que me voy a la web de AMD y me bajo los ultimos drivers para linux..... los descomprimo y los instalo..... aparentemente todo bien. Reinicio y arranco de nuevo con ubuntu...... de repente me aparece una marca de agua en la esquina inferior derecha de la pantalla que dice "AMD testing mode"..... pongo mi contraseña y entro con unity..... unity ha desaparecido por completo, solo tengo el fondo de escritorio y la marca de agua....

Cierro sesión e inicio en modo gnome básico.... consigo ver las barras de menú pero sigue la marca de agua. Abro una terminal y hago apt-get update/upgrade...... empieza a bajarse el fglrx con un monton de cosas anexas...... esto no pinta bien.

Reinicio de nuevo..... ha desparecido la marca de agua. Entro en modo unity. No hay nada.... ni iconos, ni paneles.... nada.... solo el fondo del escritorio. Abro una terminal e intento re-instalar los drivers de AMD.... me dice que nones, que hay una versión del fglrx de no se qué rollo y que la tengo que desinstalar antes.... la desinstalo con apt-get remove/purge...... reinicio..... de repente, unity ha vuelto, vuelvo a intentar instalar los drivers de AMD.... me deja hacerlo.... reinicio.... unity sigue ahí..... pero voy a arrancar un juego instalado con playonlinux, el world of tanks, va fatal.... pero fatal de narices.... 3 o 4 fps..... esto es una pesadilla. Entre tanto he visitado 20000000 millones de foros, consultas, dudas, trucos..... que si hay que hacer un script, que si hay que reinstalar el unity, que si reconstruir el xorg, que si para arriba, que si para abajo..... vamos una tesis del MIT..... YO SOLO QUIERO INSTALAR LOS DRIVERS DE LA MALDITA TARJETA Y QUE FUNCIONE.

Bueno, llegados a este punto, dejo el tema así, me limitaré a jugar desde windows7. Al menos parece que los drivers de AMD están instalados en ubuntu.... aunque no sé para qué....

Todo esto ha sido un tira y afloja de más de una semana.....

Hoy al arrancar el ubuntu.... me aparece la actualización de software.... la acepto y pa'lante.... al terminar me dice que tiene que reiniciar. Reinicio y...... ha vuelto la marca de agua.... ha desparecido el unity.....

Francamente, creo que ubuntu debe mejorar mucho..... muchísimo en este aspecto..... años atrás con otras versiones de ubuntu siempre pasaba lo mismo con las gráficas de ese momento..... a estas alturas, este tema debería estar más que resuelto.

Algún consejo, ayuda o consuelo?

Gracias

Imagen de Goyo
+1
0
-1

Esos controladores que te dan problemas son software privativo de AMD y nadie más que ellos puede arreglarlos. No hay mucho se pueda hacer para que ubuntu mejore en este aspecto mientras AMD no haga su parte.

+1
0
-1
Imagen de jhcs
+1
0
-1

Si mi estimado igual sufro lo mismo con esta cagada de drivers propietarios, pero ten animos ya probe los controladores libres, y ve se prometedores, como sabras amd libera las especificaciones de sus tarjetas, y estos drivers nuevos ya supera alos privativos en calidad y estabilidad, no te ha pasado que repente se cae el servidor xorg?, tengo una ati 7750.

+1
0
-1
Imagen de danielln
+1
-1
-1

Todos van mal..... lo que funciona con uno..... se estropea con el otro..... pero hace algo que el primero no hace.... y así hasta el infinito. Los drivers de AMD son la última versión que creo que son de marzo de este año. He estado leyendo que esto parece un problema muy común con el ubuntu 12.10..... que con el 12.04 no pasa porque en el 12.10 el fglrx es una beta de no se qué rollo y te la endiñan sí o sí..... a estas alturas me vengo a enterar.....

Siempre he tenido muy malas experiencias con ubuntu y tarjetas aceleradoras desde tiempos inmemoriales.... y hablo de lo que me costó configurar una Voodoo Banshee de 16Mb y AGP allá por los años 90......

Por lo que he vivido en este aspecto, sólo he visto estabilidad cuando la gráfica que vas a usar es 2 o 3 años más antigua que la versión de ubuntu a instalar..... o bien..... es una gráfica "plana" sin pretensiones de las que suelen estar integradas en la placa base y para un uso de oficina..... sin mucho más.

Esto es como cuando ubuntu se hacía la picha un lío cuando tu portatil venía con una wifi broadcom tal o cual.... que había que hacer un estudio super-profundo y terminar poniendo una tirita microscópica de cinta aislante en el pin xx de la tarjeta wifi para que el misterioso sistema de energía la mantuviera siempre encendida....

Y vaya..... qué casualidad..... siempre que voy a instalarle el ubuntu a un amigo en su portatil o en su torre.... siempre tienen el modelo tal o el hardware cual que ya se sabe que dan problemas con esto y con lo otro....

Creo que ubuntu ha comenzado una especie de carrera desenfrenada para competir con windows, con mac y con la demás distribuciones de linux y está comenzando a dejar sin tapar muchos agujeros que afectan a la compatibilidad y a la estabilidad. Yo creo que deberían olvidarse de estar obsesionados con sacar nuevas y lustrosas versiones cada seis u ocho meses y centrarse en la tarea de obtener estabilidad y compatibilidad.

Siempre he partido de la filosofía más temprana del linux: si crees que tu pc está obsoleto, pon linux. Si estás harto de los virus, pon linux. Si quieres un sistema estable y seguro, pon linux. Creo que estas premisas han quedado en desuso para los desarrolladores de ubuntu y están obsesionados por competir.

En fin, siento el rollo. Sin embargo, sigo igual con la ATI..... en un círculo sin fin de drivers y con única esperanza que en unos meses se solucione por sí solo con una nueva versión de driver.

Saludos

+1
-1
-1
Imagen de Jose Luis 1320
+1
-1
-1

y hablo de lo que me costó configurar una Voodoo Banshee de 16Mb y AGP allá por los años 90......

La primera versión de Ubuntu fue lanzada en octubre del 2004.

Esto es como cuando ubuntu se hacía la picha un lío cuando tu portatil venía con una wifi broadcom tal o cual.... que había que hacer un estudio super-profundo y terminar poniendo una tirita microscópica de cinta aislante en el pin xx de la tarjeta wifi para que el misterioso sistema de energía la mantuviera siempre encendida....

Eso por que broadcom nunca ha dicho que su pin funciona de esa manera y nunca ha provisto del API para que ese pin se controle via software. Quejate con broadcom si tienes tanto problema.

Creo que ubuntu ha comenzado una especie de carrera desenfrenada para competir con windows, con mac y con la demás distribuciones de linux y está comenzando a dejar sin tapar muchos agujeros que afectan a la compatibilidad y a la estabilidad. Yo creo que deberían olvidarse de estar obsesionados con sacar nuevas y lustrosas versiones cada seis u ocho meses y centrarse en la tarea de obtener estabilidad y compatibilidad.

Falso, Ubuntu como producto comercial tiene otro segmento en el mercado, lugar en donde windows no tiene posibilidades, los celulares, las tablets y la TV.

¿Como crees que Ubuntu le pueda hacer para que gane tu pobre percepción de estabilidad y compatibilidad, si AMD no dice como funciona su hardware? ¿Acaso tu le vas a dar fondos para que usen la ingenieria inversa?, que por cierto es muy caro.

+1
-1
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de cuentos
+1
0
-1

Por lo que e visto en internet, tienes que borrar tu configuracion de /xorg.conf file, y generar uno nuevo, mira estos sitios y comentas:
Este es algo viejo pero mira para que veas como va:
http://www.ubuntu-guia.com/2009/08/instalar-driver-propietario-para-ati-...
ahora mira este que esta en ingles:
http://wiki.cchtml.com/index.php/Ubuntu_Quantal_Installation_Guide
Espero y sean de ayuda.

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de danielln
+1
-1
-1

Gracias. He hecho todo eso y vuelvo al círculo vicioso. Parece ser que hay un bug no resuelto aún de los drivers privativos en el momento de la instalación en ubuntu 12.10..... así que si necesitas estabilidad tendrás que tirar con los drivers "públicos" pero olvídate de los juegos con wine..... hasta que no se resuelva no hay nada que hacer. Otro gran problema es que entre tanto purge/remove/uninstall, por el camino te acabas cargando el opengl. Si por casualidades del destino consigo instalar algo..... una de dos: O bien desaparece Unity..... o bien te quedas con el ubuntu y una molesta marca de agua en la esquina inferior derecha.

De este modo, con las aceleradoras ATI y el ubuntu 12.10 solo tienes 3 opciones:
1. Drivers "públicos" de ubuntu 12.10, tienes Unity pero no hay rendimiento 3d
2. Drivers "específicos" para ATI fglrx+catalyst. Pierdes Unity, aparece una marca de agua y el rendimiento 3d es pésimo y el fglrx es una beta.
3. Drivers "privativos" de AMD.... práticamente imposibles de instalar en ubuntu 12.10, en caso de lograrlo te quedas sin unity, no hay marca de agua y el rendimiento 3d mejora sólo un poquito, pero en cuanto haya actualización de software todo se irá a freir espárragos.

Si busco mi problema en foros, parece que esto es lo que hay.... le está pasando a todo el mundo, y la gente está desesperada.... por no decir hasta las narices...... y como los fabricantes son malos malísimos pues nada, a esperar. AMD ya tiene una beta para bajarse pero..... no sé si hacerlo.... me da un miedo tremendo.

Me encanta ubuntu pero..... estas lagunas me desesperan: Mi portatil, un HP del año 2007 iba de maravilla con el ubuntu 11...... hasta que instalé el 12.04..... la batería ahora dura unos 20 minutos (antes era casi 2 horas)..... por no decir que se sobrecalienta y se pone en modo grill hasta que se apaga bruscamente..... la culpa? de los fabricantes? he tenido que hacer virguerías para instalar un millón de cosas que los de ubuntu habían desabilitado porque les salió del núcleo..... este proceso.... como siempre en un tira y afloja, quita y pon, sube y baja de más de 3 meses hasta dar con la combinación adecuada. Ahora la batería aguanta como 50 minutos pero el tema del sobrecalentamiento sigue ahí. De repente el ventilador suena como si fuera a despegar y 5 segundos más tarde..... PLUM! se apaga por completo.... tengo que esperar 2 o 3 minutos para que se enfríe un poco y volver a encenderlo.

En fin..... lo dicho.... a sufrir y esperar.

Gracias a todos y en cuanto consiga descubrir cómo resolver esto, lo pondré aquí ipso facto.

+1
-1
-1