Operating system not found - kubuntu y Xp (solucionado)

Imagen de x_whity_x
0 puntos

Hola antes que nada disculpen si inicio un tema ya existente o en el lugar inadecuado,

En mi notebook siempre use linux (solo linux) por necesidad tuve que instalar windows,
entonces decidí partir el disco quedando:

sda1 7GB linux primaria
sda2 23GB windows primaria
sda3 210GB linux extendida (aca esta montado /home)
sda4 2GB swap

una ves echo esto instale kubuntu 12.04 (solo el linux) y andaba todo de maravillas,
hago dd if=/dev/sda1 of=linuxboot bs=512 count=1
luego instale win XP copio el archivo linuxboot en el directorio C: y edito el boot.ini para que me de la opción de arrancar el linux. quedando:

[boot loader]
timeout=30
default=C:\linuxboot
[operating systems]
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect
C:\linuxboot="Kubuntu"

y ahora cuando quiero arranca con mi querido kubuntu me dice operating system not found y no tengo forma de arrancar en linux.

Desde ya muchas gracias por su tiempo.

Imagen de elnetotaca
+1
0
-1

Compañero, podrías hacer las instalaciones como la gente normal???
instala primero win2 en sda1 con 23Gb
luego instala linux en sda2 con 7gb
sda3 210GB linux extendida (/home)
sda4 2GB swap

linux instalará el grub para que puedas accesar a tus dos sistemas operativos.

Saludos.

+1
0
-1

unzip; strip; touch; finger; mount; fsck; more; yes; unmount; sleep
Es lo que hago a diario....... En Linux mal pensados!

Imagen de x_whity_x
+1
0
-1

De haber tenido la copia de win al momento de formatear lo hubiera echo de esa manera como ya lo había echo en la pc de escritorio

+1
0
-1
Imagen de aullido10
+1
0
-1

**/Moderado/**

Las preguntas en su propio hilo por favor. Gracias.

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

Lo que tu hiciste fue 1) Instalar Ubuntu en /dev/sda1 2) luego formateaste la partición en donde instalaste Ubuntu con dd.

Deja a dd para tareas más avanzadas y de bajo nivel. El uso de dd implica que sepas lo que haces, Este no fue el caso.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de x_whity_x
+1
0
-1

Al dd lo use desde el LiveCD primero haciendo un mount y después dd if=/mnt como no anduvo lo hice derecho con sda1 pero si arrancó con el live cd la sda1 la veo y tiene todo adentro.
No hay opción de que sea otra cosa?
Muchas gracias

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

Así de simple. con dd no haces otra cosa.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de Gabriel_M
+1
0
-1

... instalar Lilo ó Grub legacy en /dev/sda1 para que dd if=/dev/sda1 of=linuxboot bs=512 count=1, genere un archivo con un gestor de arranque que inicie Gnu/Linux.
Desde una sesión live haz chroot de la partición Gnu/Linux e instala Lilo ó Grub legacy en /dev/sda1, luego genera nuevamente el archivo y reemplazalo en Windows.

+1
0
-1
Imagen de x_whity_x
+1
0
-1

Muchas gracias por la info, en cuanto vuelva a mi casa lo pruebo y te comento los resultados

+1
0
-1
Imagen de x_whity_x
+1
+1
-1

Muchas gracias a todos ya lo pude solucionar con lo que me indicó Gabriel_M

+1
+1
-1