No puedo instalar java

Imagen de Uri44
0 puntos

Hola a tod@s,

Hoy he vuelto a liarme con Ubuntu, concretamente con Xubuntu 12.10. Necesito instalar el paquete openjdk-7-jre y me estoy rallando un montón. En teoría debería ser tan fácil como abrir la terminal y escribir "sudo apt-get install openjdk-7-jre" pero me suelta el siguiente error:

Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios no han sido creados o han
sido movidos fuera de Incoming.
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
openjdk-7-jre : Depende: openjdk-7-jre-headless (= 7u15-2.3.7-0ubuntu1~12.04.1)
Recomienda: libgconf2-4 pero no va a instalarse
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.

He intentado desde Synaptic y el error que me devuelve es este:

openjdk-7-jre:
Depende: openjdk-7-jre-headless (= 7u15-2.3.7-0ubuntu1~12.04.1)
Recomienda: libgconf2-4 pero no va a ser instalado

Y el centro de software me lanza este otro:

openjdk-7-jre: Depends: openjdk-7-jre-headless (= 7u15-2.3.7-0ubuntu1~12.04.1) pero 7u15-2.3.7-0ubuntu1~12.04.1 no está instalado
Depends: libjpeg8 (>= 8c) pero 8c-2ubuntu7 no está instalado
Depends: libpulse0 (>= 1:0.99.1) pero 1:2.1-0ubuntu4 no está instalado

¿Cómo puedo solucionar esto? He probado a instalar los paquetes que me "recomienda" pero siempre me acaba diciendo que hay paquetes rotos o algo por el estilo... Llevo cerca de 3 horas peleándome con esto y he probado todo lo que se me ha ocurrido o leído y no encuentro solución alguna.

Si intento instalar openjdk-6 los errores son iguales o parecidos...

Gracias de antemano

Imagen de Goyo
+1
0
-1

openjdk-7-jre: Depends: openjdk-7-jre-headless (= 7u15-2.3.7-0ubuntu1~12.04.1)

Por ahí tienes activado algún repositorio que no es para tu versión de Ubuntu, seguramente es la causa de los problemas.

+1
0
-1
Imagen de Uri44
+1
0
-1

Ok, gracias. A saber cuál es ahora...Añadí varios repositorios y ahora ves y búscalo...De todos modos me he bajado Ubuntu 12.10 y le he puesto el escritorio clásico de gnome y me gusta más...Iré con cuidado al añadir repos raros...
Interpreto entonces que, siempre que me dé algún error similar, es por la incompatibilidad de repositorios ¿no?
Muchas gracias

+1
0
-1

Todos hemos sido novatos alguna vez...

Imagen de Goyo
+1
0
-1

apt-cache policy paquete
Te dice qué versiones de un paquete están disponibles y en qué repositorios.

siempre que me dé algún error similar, es por la incompatibilidad de repositorios ¿no?

No siempre. En este caso creo que sí por el "12.04" en el nombre del paquete.

+1
0
-1
Imagen de Uri44
+1
0
-1

Tomo nota, gracias.
:)

+1
0
-1

Todos hemos sido novatos alguna vez...