No puedo abrir k3b por problemas en /var/tmp/kdecahe-kim

Imagen de kimm
0 puntos

Hola,
He actualizado a la versión 13.04. Todo bien algún pequeño ajuste...
Pero mi problema es con k3b y smplayer.
Con smplayer correcto pero al hora de cerrar se me queda colgado y he de forzar el cierre.
Pero mi mayor problema es con k3b, no me abre la gráfica sólo con la consola puedo abrirlo y es inoperante.
He ido con synaptic no me da ningún paquete para reparar,he desinstalado con synaptic también junto con todos los paquetes
He borrado la lista, he creado una nueva .limpiado todo con ubuntu tweak.Nada.
¿ puede ser un problema de permisos? he intentado entrar con kdesu.en lugar de sudo,pero me da un error de comando...Os paso un log de la consola del k3b en smplayer viene a decirme parecido pero me funciona solo es al cerrar
He leído algo con el comando "chown" per al desconocer no he probado nada
log al abril k3b:

kim@kim-System-Product-Name:~$ sudo k3b
[sudo] password for kim:
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
KGlobal::locale(): Warning your global KLocale is being recreated with a valid main component instead of a fake component, this usually means you tried to call i18n related functions before your main component was created. You should not do that since it most likely will not work
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
Error: "/var/tmp/kdecache-kim" is owned by uid 1000 instead of uid 0.
Error: "/tmp/kde-kim" is owned by uid 1000 instead of uid 0.
k3b(22037)/kdeui (kdelibs): Attempt to use QAction "view_projects" with KXMLGUIFactory!
k3b(22037)/kdeui (kdelibs): Attempt to use QAction "view_dir_tree" with KXMLGUIFactory!
k3b(22037)/kdeui (kdelibs): Attempt to use QAction "view_contents" with KXMLGUIFactory!
k3b(22037)/kdeui (kdelibs): Attempt to use QAction "location_bar" with KXMLGUIFactory!
Error: "/tmp/ksocket-kim" is owned by uid 1000 instead of uid 0.

Gracias

kim

Imagen de cuentos
+1
0
-1

correr el programa como root, con sudo creo que no te ayuda nada, incluso creo que es peor.
Trata desde la terminal a correrlo pero sin sudo solamente:
k3b
y mira si te da un error en la terminal

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de kimm
+1
0
-1

Gracias Cuentos,
Mira esto es lo que me da poniendo solo "k3b" a secas Obviamente no se ejecuta el gráfico, pero en el monitor de sistema veo que el proceso si esta ejecutándose.
La consola me da esto:
kim@kim-System-Product-Name:~$ k3b
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
KGlobal::locale(): Warning your global KLocale is being recreated with a valid main component instead of a fake component, this usually means you tried to call i18n related functions before your main component was created. You should not do that since it most likely will not work
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.

(k3b:9321): Gtk-CRITICAL **: IA__gtk_settings_set_long_property: assertion `GTK_SETTINGS (settings)' failed

(k3b:9321): Gtk-CRITICAL **: IA__gtk_settings_set_long_property: assertion `GTK_SETTINGS (settings)' failed

(k3b:9321): Gtk-CRITICAL **: IA__gtk_settings_set_long_property: assertion `GTK_SETTINGS (settings)' failed

(k3b:9321): Gtk-CRITICAL **: IA__gtk_settings_set_long_property: assertion `GTK_SETTINGS (settings)' failed

(k3b:9321): Gtk-CRITICAL **: IA__gtk_settings_set_string_property: assertion `GTK_SETTINGS (settings)' failed

(k3b:9321): Gtk-CRITICAL **: IA__gtk_icon_theme_get_for_screen: assertion `GDK_IS_SCREEN (screen)' failed

(k3b:9321): Gtk-CRITICAL **: IA__gtk_icon_theme_get_for_screen: assertion `GDK_IS_SCREEN (screen)' failed

(k3b:9321): Gtk-CRITICAL **: IA__gtk_icon_theme_prepend_search_path: assertion `GTK_IS_ICON_THEME (icon_theme)' failed

(k3b:9321): Gtk-CRITICAL **: IA__gtk_icon_theme_get_for_screen: assertion `GDK_IS_SCREEN (screen)' failed

(k3b:9321): Gtk-CRITICAL **: IA__gtk_icon_theme_prepend_search_path: assertion `GTK_IS_ICON_THEME (icon_theme)' failed

(k3b:9321): Gtk-CRITICAL **: IA__gtk_icon_theme_get_for_screen: assertion `GDK_IS_SCREEN (screen)' failed

(k3b:9321): Gtk-CRITICAL **: IA__gtk_icon_theme_prepend_search_path: assertion `GTK_IS_ICON_THEME (icon_theme)' failed

(k3b:9321): Gtk-CRITICAL **: IA__gtk_settings_set_string_property: assertion `GTK_SETTINGS (settings)' failed

(k3b:9321): Gtk-CRITICAL **: IA__gtk_settings_set_string_property: assertion `GTK_SETTINGS (settings)' failed

(k3b:9321): Gtk-CRITICAL **: IA__gtk_settings_set_string_property: assertion `GTK_SETTINGS (settings)' failed
k3b(9321)/KSharedDataCache KSharedDataCache::Private::mapSharedMemory: Failed to establish shared memory mapping, will fallback to private memory -- memory usage will increase

Un saludo,

kim

+1
0
-1
Imagen de kimm
+1
0
-1

Por cierto me olvide de comentar- que pienso que puede ser importante- que tengo kubuntu pero con cinnamon.

+1
0
-1
Imagen de rioport
+1
0
-1

Los errores críticos están relacionados con el tema que usas, al iniciar la aplicación como root se cargan las configuraciones de este (root) y como el tema que usa no es el mismo que el de tu cuenta no se presentan los errores que se dan con tu usuario.

Prueba a cambiar el tema que estés usando actualmente o cambia de entorno de escritorio.

+1
0
-1

-- GC --

Imagen de kimm
+1
0
-1

Hola Rioport,
Sí, he probado de instalar otro tema/entorno- el linux mint, que tenia antes- y me sigue igual.
Hasta en el editor del compiz he activado la opción del KDE.
Sumo y sigo...
gracias

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

He editado el título a algo más detallado. "Problemas con X cosa" no describe nada, debes describir tu problema en el título.

En fin, jamás corras aplicaciones gráficas usando sudo, lo que hace sudo es adueñarse del archivo .Xauthority, entre otros, lo que puede dar problema en el futuro para abrir tu sesión de escritorio siquiera.

Y en cuanto a tu problema, no se relaciona con tu cache, ese es problema de correrlo con sudo, /var/tmp/kdecache-kim pertenece a al usuario 1000, es decir a ti, y las aplicaciones kde detectan eso, menos mal.

Lo que yo veo de los errores de gtk, no es ningún problema que impida a la aplicación correr, a lo mucho te correría con el tema de GTK mal renderizado o con los iconos de Oxygen, recuerda tu estas corriendo una aplicacion Qt y esas se camuflajean, es decir parecen que son aplicaciones Gnome, cuando las corres dentro de un shell gnome,

Lo de QDbusConnection, segun los desarrolladores de kde es algo normal que tengas esos mensajes,

Lo de KGlobal::locale tiene más que ver con las traducciones, es probable que tu aplicación no salga completamente traducida.

Lo que si me pone en duda es el último mensaje; no se decirte si esa es la causa de que k3b no se abra de forma "gráfica" pero esto es un memory leak o goteo de memoria, con el tiempo el uso de RAM de k3b se incremetará, dado a que por razones no pudo acceder a la memoria compartida:

k3b(9321)/KSharedDataCache KSharedDataCache::Private::mapSharedMemory: Failed to establish shared memory mapping, will fallback to private memory -- memory usage will increase

¿A lo mejor por que estarás corriendo k3b en cinnamon?

El problema también podría ser esto:

(k3b:9321): Gtk-CRITICAL **: IA__gtk_icon_theme_get_for_screen: assertion `GDK_IS_SCREEN (screen)' failed

Pero no se si esto sea realmente la causa de que k3b no corra o no dibuje la ventana.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de kimm
+1
0
-1

Hola Jose Luis 1320,
En primer lugar gracias por contestar.
Discierno un poco en lo referente a la edición del título. Creo que expongo bien que mi problema es que no puedo abrir el k3b.Como un titular en un periódico, describo lo que me pasa en pocas palabras.Si después lo desarrollo mal , aquí si que estaría de acuerdo.Pero tampoco puedo explicar el motivo del problema porque...tampoco lo sé.

No abro las aplicaciones normalmente desde la consola y nunca con sudo, evidentemente. Si así lo hice fue para comprobar si podía lanzar dicha aplicación y si me daba mas datos que me ayudaran a solucionar el problema.
Tienes razón que la aplicación me sale mal traducida- está en su totalidad en Inglés-.

Dudo que sea al usar cinnamon .Antes con la distribución 12.10 me funcionaba sin ningún problema.

Lo que sí he querido hacer a sido instalar KDE .Pues antes lo tenia i ahora solamente tenia en inicio la opción "ubuntu, gnome i sus deivadados". La opción "kde plasma...No me aparecía ,-ahora me aparece pero no puedo entrar- he de analizar mas a fondo si he instalado mal alguna librería o puede que vengan de aquí los problemas con el k3b.

Analizando un poco, al final creo que por no esperar un live cd con algunos bugs y problemas solucionados.actualicé sin cambiar nada.
Voy a seguir probando y a ver si sale alguna actualización que corrija mi problema.

Gracias

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

En donde ponen encabezados mal redactados.

Tu habias escrito en el título "problemas /var/tmp/kdecache" ese no es un título descriptivo. Debes describir el problema que tienes, no describir que tienes problemas; todos tenemos problemas, pero si quieres ayudar y que te ayuden debes usar un titulo descriptivo para que quienes usen el foro sepan que problema tienes.

Se puede describir en pocas palabras el problema que tienes, y para eso no se necesita experiticia, si no puedes abrir k3b, tan sencillo como poner "No puedo abrir k3b".

Tampoco entiendo por que el comentario que sigues igual, no te he dado ninguna solución. Trato de diagnosticar tu problema a partir de la información que das, y esto también para por si se viene el veinte y das con la causa de tu problema.

¿Que hiciste? ¿Que has hecho? ¿antes funcionaba k3b? De nada sirve que tengas cinnamon y compiz con la opción de KDE activada, esa es para cuando abras compiz en KDE, cosa NO recomendada.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de kimm
+1
0
-1

No,no habia escrito "problemas/va/tmp/kdecache", como tu dices . Tengo escrito "No puedo abrir k3b por problemas en /var/tmp/kdecahe-kim". Que es lo que me ponía el error , para ser mas conciso
Pero... bién, que un árbol no nos deje ver el bosque.
Kim

+1
0
-1
Imagen de Jose Luis 1320
+1
+1
-1

Por que yo lo edité... ¬¬.

En el primer comentario que hice en tu hilo, te lo dije. No quieras pasarte de listo.

+1
+1
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de Jose Luis 1320
+1
0
-1

Ahora corriendo k3b desde Unity a mi me sale esto:

 
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
KGlobal::locale::Warning your global KLocale is being recreated with a valid main component instead of a fake component, this usually means you tried to call i18n related functions before your main component was created. You should not do that since it most likely will not work 
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
kbuildsycoca4 running...
kbuildsycoca4(5011) VFolderMenu::loadDoc: Parse error in  "/home/joseluis64/.config/menus/applications-merged/xdg-desktop-menu-dummy.menu" , line  1 , col  1 :  "unexpected end of file" 
kbuildsycoca4(5011)/kdecore (services) KServicePrivate::init: The desktop entry file  "/usr/share/applications/openbox.desktop"  has Type= "XSession"  instead of "Application" or "Service" 

Y k3b inicia correctamente.

No hagas caso a lo de opnebox, es que tengo Openbox y eso no se relaciona con tu problema.
¿Desinstalaste kde?

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de kimm
+1
0
-1

Hola,
No me actualizó a kde, o sea no me lo instaló .Ahora lo he hecho pe o no me deja entrar, como le he comentado al compañero José Luis 1320.
Sigo en ello...
gracias

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

Ese comentario también es mío ¬¬

En fin, no te entiendo ¿Tienes KDE o no? ¿Como es que tienes "kubuntu con cinnamon"? ¿desinstalaste KDE? por que Kubuntu tiene KDE por defecto no cinnamon.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de kimm
+1
0
-1

Hola jose luis,
Yo hasta ahora tenia kubuntu , evidentemente con kDE quise probar cinnamon porque me gusto y encontraba a faltar algo de gnome ( cuestión de gustos) y me gustó, no desinstale nada soloi nstale el cinnamon. O sea cuando tenia pantalla de inicio tenia la opción de entra en KDE(sin problemas), Gnome y cinnamon.
Y hasta ahora todo bién en cinnamon ,me abria todo junto con 3b. O sea sin ningún problema.Ahora al salir una nueva distro en fuentes y actualizaciones de li a actualizar a la versión 13.04 no eliminé nada.
No hubo problemas en la actualización. pero al intentar usar k3b no me lo abria y en smplayer tengo que hacer un cierre de programa forzozo, pues al cerrar normal me queda congelado, ( pero esto no és problema.

Ha sido al postear que me habéis comentado lo del kde.

Despues al reiniciar he querido entrar en KDE y mi sorpresa es que no lo he visto en inicio. Y he pensado he aquí la solución tengo kubuntu a medias me falta el kde. he ido a los repositorios y he instalado el kde standar junto con sus librerías.
Ahora en inicio me aparece kde pero al entrar no oigo como lee el disco y me queda solo el fondo de pantalla.
¿ he instalado mal los repositorios?
Lo único que creo pudiera haber pasado es que al terminar la actualización les pase el limpiador de ubuntu tweak y que no me hubiera borrado alguna librería (hasta ahora lo he usado siempre y nunca he tenido ningún problema).

Lo del kde del compiz fue por probar.

Gracias kim

+1
0
-1