Instalación de todo lo necesario para cocinar ROMS Android

Imagen de EEvo92
0 puntos

Buenas,

Soy usuario de linux desde hace años (empecé con Ubuntu hace muchos años, seguí OpenSuse y hasta hace poco he estado usando Fedora) y ahora llevo un par de semanas con Ubuntu 12.10, del cual no he tenido quejas hasta ahora.

Quiero instalar lo necesario para dedicarme a hacer ROMS de Android, y por ello he sseguido el tutorial que la propia Google proporciona en http://source.android.com/source/initializing.html , pero tengo un problema, en el paso "Installing required packages (Ubuntu 12.04)", que es el que estoy usando ya que no hay nada para 12.10, introduzco el codigo en el terminal, y me salta el siguiente mensaje:

No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios no han sido creados o han
sido movidos fuera de Incoming.
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
g++-multilib : Depende: gcc-multilib (>= 4:4.7.2-1ubuntu2) pero no va a instalarse
libc6-dev : Depende: linux-libc-dev pero no va a instalarse
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.

He estado mirando por esta pagina y otras tantas, y no he encontrado como solucionar este tema de dependencias, he probado de todo, pero nada.

¿Alguien sabría como arreglar este problema?

Añadir que dejé Fedora por otro problema de dependencias que no supe solucionar y por el cual cometí un error que me llevó a tenner que reinstalar linux si o si, por lo que decidí probar con Ubuntu.

Imagen de Jose Luis 1320
+1
0
-1

Borrar repositorios externos (los programas que instalaste de estos también) y programas que instalaste con make install.

E intenta de nuevo.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de EEvo92
+1
0
-1

¿Hay alguna forma de saber los repositorios externos que he instalado, asi como los programas del make install?

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

Tu los instalaste no yo.

En fin, en "orígenes del software" puedes saber que repositorios agregaste y deshabilitarlos.

Y los programas que instalaste desde código fuente, es obvio.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de Goyo
+1
0
-1

Siempre es igual, hay que comprobar si las dependencias que dan problemas están disponibles y tratar de instalarlas directamente. A veces se resuelve simplemente con hacer esto, tras veces se obtiene una descripción más detallada del problema.

+1
0
-1
Imagen de EEvo92
+1
0
-1

Ya lo he intentado, pero resulta que tras solucionar parte de las dependencia, una de ellas pide desinstalar lo que he instalado antes, y vuelta a empezar, es como un circulo infinito

+1
0
-1
Imagen de Goyo
+1
0
-1

Entonces estás en el segundo caso, ahora tienes una descripción más detallada del problema.

+1
0
-1
Imagen de cuentos
+1
0
-1

Viendo el hilo me dejo una duda, que sistema tienes 32 o 64 bits por el error que te da

g++-multilib : Depende: gcc-multilib (>= 4:4.7.2-1ubuntu2) pero no va a instalarse

que creo este es in archivo de 64 bits, para dar "soporte" a versiones de 32 bits

+1
0
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos