ubuntu 12.04 el paquete del sistema esta roto

Imagen de jonathanjd
0 puntos

Los siguientes paquetes tienen dependencias incumplidas:

wine1.6: PreDepends: dpkg (>= 1.15.7.2~) pero 1.16.1.2ubuntu7.1 está instalado
Depends: libc6 (>= 2.11) pero 2.15-0ubuntu10.4 está instalado
Depends: wine1.6-i386 (= 1.6~rc2-0ubuntu1~ppa4) pero 1.6~rc2-0ubuntu1~ppa1 está instalado
wine1.6-i386: PreDepends: dpkg (>= 1.14.12ubuntu3) pero 1.16.1.2ubuntu7.1 está instalado
Depends: libc6 (>= 2.11) pero 2.15-0ubuntu10.4 está instalado
Depends: libglib2.0-0 (>= 2.12.0) pero 2.32.3-0ubuntu1 está instalado
Depends: libgphoto2-2 (>= 2.4.10.1) pero 2.4.13-1ubuntu1.2 está instalado
Depends: libgphoto2-port0 (>= 2.4.10.1) pero 2.4.13-1ubuntu1.2 está instalado
Depends: liblcms1 (>= 1.15-1) pero 1.19.dfsg-1ubuntu3 está instalado
Depends: libldap-2.4-2 (>= 2.4.7) pero 2.4.28-1.1ubuntu4.2 está instalado
Depends: libmpg123-0 (>= 1.6.2) pero 1.12.1-3.2ubuntu1 está instalado
Depends: libopenal1 (>= 1:1.13) pero 1:1.13-4ubuntu3 está instalado
Depends: libpulse0 (>= 1:0.99.1) pero 1:1.1-0ubuntu15.3 está instalado
Depends: libxml2 (>= 2.7.4) pero 2.7.8.dfsg-5.1ubuntu4.4 está instalado
Depends: zlib1g (>= 1:1.1.4) pero 1:1.2.3.4.dfsg-3ubuntu4 está instalado
Depends: wine1.6 (= 1.6~rc2-0ubuntu1~ppa1) pero 1.6~rc2-0ubuntu1~ppa4 está instalado

-------- Coloco apt-get install -f me sale esto:
Los paquetes indicados a continuación se instalaron de forma automática y ya no son necesarios.
libbabl-0.0-0 libgegl-0.0-0 amarok-help-en amarok-help-es
Utilice «apt-get autoremove» para eliminarlos.
Se instalarán los siguientes paquetes extras:
wine1.6-i386
Se actualizarán los siguientes paquetes:
wine1.6-i386
1 actualizados, 0 se instalarán, 0 para eliminar y 14 no actualizados.
4 no instalados del todo o eliminados.
Se necesita descargar 0 B/24,4 MB de archivos.
Se utilizarán 0 B de espacio de disco adicional después de esta operación.
¿Desea continuar [S/n]? s
Configurando mysql-server-5.5 (5.5.31-0ubuntu0.12.04.2) ...
start: Job failed to start
invoke-rc.d: initscript mysql, action "start" failed.
dpkg: error al procesar mysql-server-5.5 (--configure):
el subproceso instalado el script post-installation devolvió el código de salida de error 1
No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
dpkg: problemas de dependencias impiden la configuración de wine1.6-i386:
wine1.6-i386 depende de wine1.6:any (= 1.6~rc2-0ubuntu1~ppa1); sin embargo:
La versión de `wine1.6' en el sistema es 1.6~rc2-0ubuntu1~ppa4.
dpkg: error al procesar wine1.6-i386 (--configure):
problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de wine1.6:
No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
wine1.6 depende de wine1.6-i386 (= 1.6~rc2-0ubuntu1~ppa4); sin embargo:
La versión de `wine1.6-i386' en el sistema es 1.6~rc2-0ubuntu1~ppa1.
dpkg: error al procesar wine1.6 (--configure):
problemas de dependencias - se deja sin configurar
No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
dpkg: problemas de dependencias impiden la configuración de mysql-server:
mysql-server depende de mysql-server-5.5; sin embargo:
El paquete `mysql-server-5.5' no está configurado todavía.
dpkg: error al procesar mysql-server (--configure):
problemas de dependencias - se deja sin configurar
No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
Se encontraron errores al procesar:
mysql-server-5.5
wine1.6-i386
wine1.6
mysql-server

Imagen de Jose Luis 1320
+1
0
-1

Lo que esta roto es el sistema entero o las partes que se ocupan de las dependencias de wine.

instala ppa-purge y borra ese repositorio de wine.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de jonathanjd
+1
0
-1

sudo ppa-purge ppa:wine1.6-i386 cual coloco jeje ayudame por favor

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

Yo no se como se llama, tu si.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de jonathanjd
+1
0
-1

Que problema con esto:
E: mysql-server-5.5: el subproceso instalado el script post-installation devolvió el código de salida de error 1
E: wine1.6-i386: problemas de dependencias - se deja sin configurar
E: wine1.6: problemas de dependencias - se deja sin configurar
E: mysql-server: problemas de dependencias - se deja sin configurar

+1
0
-1
Imagen de jonathanjd
+1
0
-1

Listo lo solucione con esto:

1- abro nautilus con privilegios de root: alt+f2 …y: gksu nautilus.
2- voy al directorio /var/lib/dpkg/info,
3- alli borro todos los archivos que hacen referencia a “nombre-del-paquete”.
4- cierro el nautilus y abro Synaptic.
5- ahora busco “nombre-del-paquete”, lo pongo marcado para eliminar y le doy a aplicar.
6- ahora si que se borra el “nombre-del-paquete”.
7- ya funciona correctamente el Synaptic, deja instalar, desinstalar, borrar, etc.

3ª Solución si no funciona la solución anterior, ( aportada por haobaobatusai ),

dentro del archivo var/lib/dpkg/status reemplazar la línea
Status: install reinstreq half-installed
por
Status: install ok installed
y solucionado

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

Al final te va a causar problemas en el sistema, lo mejor siempre es eliminar los repositorios innecesarios, como los de las versiones nuevas de programas que ya existen en los repositorios.

Los PPA esos siempre se reservan cuando necesitas programas que no están presentes en los repositorios de Ubuntu y no tienen equivalente, el tener repositorios para versiones nuevas de programas eso lo dejas para cuando entiendas las consecuencias de usarlos.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro