montar mi servidor para que se vea mi web

Imagen de calitos
0 puntos

Hola a todos
Soy nuevo en cuanto al tema del SO ubuntu, las razones por las cuales cambie a este sistema operativo son varias pero la principal es por que quiero tener mi servidor en mi casa y que se alcance a ver mi web a través de internet. Mucho se ha hablado de como hacerlo y les juro que me he cansado de leer e informarme sobre host local y sin embargo algo creo que me falta quizás que he obviado y no se que sera. pero he realizado de todo: instale apache2, php, myxsql, configure apache de tal forma que en mi intranet se vea mi web, pero quiero que se vea en internet, y es aqui donde estan mis dudas.

Mi intranet funciona de maravilla ya que mi web se ve, en otras palabras, no tengo problemas con apache en mi red local, el asunto es para verse a través de internet.

En primer lugar me informe en diversos foros en donde se habla de abrir puerto en mi router, redireccionar mi ip dinámica( lo hice en no-ip y en dyndns), se habla de instalar ddclient, la verdad he hecho de todo pero hasta ahora no consigo ver mi web en internet.
en este foro también se habla de ello pero se habla de las cosas que ya he realizado.
Si algun ubuntero que tenga su servidor funcionando pueda hacerme el favor de brindarme paso a paso las instalaciones y las configuraciones incluyendo los detalles como que puertos debo abrir en mi router y que direccion ip debo colocar, ya que con ubuntu al momento de colocar ifconfig me sale 192.168.1.35 y mas abajo sale 127.0.0.1 quisiera que lo envíen a mi correo XXXXX@XXXX, se lo voy agradecer. si la gente de este foro quiere darme sugerencias y aportar con detalles también se lo voy a agradecer.
Se que el tema es extenso por eso si alguien puede enviar los pasos a mi email gracias sino, preguntenme lo que no hice y asi poder contar con mi servidor.

disculpen que sea bastante extenso. saludos.

Imagen de rafagomezd
+1
0
-1

http://www.rafa.eficientes.com.mx

Hi, so basically apache server as default has port NO. 80 to web publish, so on your router you need to open port No. 80 and tell the router is for HTML web services, asap you do that, configure dyndns service on your router; dyndns needs to have updated your public ip address (router's public ip address). Then is very simple, your ip addres if is something like 272.195.1.456 needs to be searched as: 272.195.1.456:80 On your nick service you just need to establish the dns as 272.195.1.456:80 in order to have it attached, I hope this solves the situation, I added on my linux pc a web page just for testing what I am telling you and you can see it as:

http://eficientes.dyndns.info or http://201.137.165.242:80

I hope this solves your stuff and go for it!!

+1
0
-1
Imagen de slap
+1
0
-1

Hola rafagomezd.

Este foro es un foro hispano, por lo que la lengua que se debe usar en él es el español.
Por favor, respetad las normas.

Gracias.

Equipo de Ubuntu-es

+1
0
-1

Saludos.

0000 start out (+FD),A
           ld  BC, +7FFF
           jp 03CB, RAM-CHECK

http://www.injiniero.es

Imagen de calitos
+1
0
-1

Hey gente ubuntera, hay alguien que me pueda responder a mis preguntas??? parece que no hay nadie dispuesto.

tengo un pequeño problemita.
he configurado mi servidor apache de tal manera que se pueda ver mi web a traves de internet, pero cuando alguien pide mi pagina desde otra maquina (esta pc esta en otro lugar fuera de mi lan), le pide usuario y clave, aqui me he quedado. Please, alguien sabe por que sucede esto y que deberia hacer??

Urgente

+1
0
-1
Imagen de calitos
+1
0
-1

bueno a gradezco que me de la solucion en otro idioma, pero alguien posee un servidor actualmente en su casa?? por que a las personas que si tienen o a las personas hispanas que hunieran configurado su servidor en algun momento les pregunto: cuales son los pasos para montar un servidor?
yo he realizado desde la instalacion de apache2 y su respectiva configuracion local para que mi web aparezca al colocar localhost en mi red, pero ahora quiero que se vea a traves de internet.
he abierto los puertos de mi router( 80, 22) colocando el ip de mi maquina (eth0), he creado mi cuenta en dyndns con mi ip publica detectado por la misma web, he instalado ddclient configurandolo con dyndns, que mas debo hacer compañeros ubunteros??? cuando coloco en mi navegador: miweb.dyndns.org, me pide clave y me lleva a mi configuracion de router.
agradeceria alguien me de alguna informacion que derrepente obvie
saludos-

+1
0
-1
Imagen de topito_u
+1
0
-1

Movido desde el foro ubuntu-es al actual


Equipo de Ubuntu-es

+1
0
-1

carlos
presencia

Imagen de topito_u
+1
0
-1

Encontrarás las razones de la edición de tu correo dentro de las normas que te invito a leer y a cumplir para un mejor funcionamiento del foro


Equipo de Ubuntu-es

+1
0
-1

carlos
presencia

Imagen de juanjava
+1
0
-1

ya que alguioen mas (por ejemplo yo) tambien lo necesita, y es que me cambie de fedora a ubuntu porque me fue complicado echar a andar la web no la pude instalar y me esta pàsando lo mismo en ubuntu (http.conf vs apache2.conf) mas no se que me falta, puesto que son directorios diferentes, mil gracias por la ayuda nuevamente.

atte

juan jaimes

toluca mexico

+1
0
-1

atte

juan jaimes

toluca mexico

Imagen de calitos
+1
0
-1

bueno agradezco que les preocupe lo de las normas pero se debe comprender que soy nuevo aca, pero, tambien preocupense de dar alguna respuesta ya que soy usuario de ubuntu y como tal soy como ustedes. les pido que me ayuden y si lo estoy pidiendo es por que he leido de todo mas de 1 mes y sigo con detalles que me faltan.
espero alguna alternativa de solucion...gracias

+1
0
-1
Imagen de Joule
+1
0
-1

A ver... No se mucho de como configurar el servidor web, pero si tienes tu servidor en una maquina con una IP privada, lo que necesitas es que tu router (que tiene la IP real) te redireccione las peticiones en el puerto 80 hacia dicha maquina. Generalmente encontraras la opcion "Port Forwarding" en el router (dependiendo de cual sea este) en donde debes indicar la IP privada que tiene la maquina que hace de servidor y el numero de puerto que es el 80.

El mundo es como lo vemos porque existimos.

+1
0
-1
Imagen de calitos
+1
0
-1

Claro eso es lo que hice, cuando ingreso al nat de mi router aparecen tres lineas en donde las dos primeras es para colocar los puertos y la ultima para colocar la ip de la pc, he colocado 80 como puerto y 192.168.1.xx en ip, luego he reiniciado mi router, ahora cuando escribo en mi navegador midominio.dyndns.org (que es el dominio que he creado), o me pide clave o no carga nada. he probado desde una maquina fuera de mi red con conexion a internet y nada, desde el mismo servidor configurado me pide clave o no carga nada.

algo derrepente falta?
saludos

+1
0
-1
Imagen de viquez
+1
0
-1

¿podrías facilitarnos la marca y modelo del router?

Inicialmente, lo que pienso es que no estás redireccionando bien el puerto 80 y este por defecto ingrese a la configuración del router.

+1
0
-1
Imagen de Joule
+1
0
-1

Si estas en alguna maquina de tu intranet dices que funciona, verdad?

Entonces desde internet, si pones tu dominio, que IP te resuelve? Puedes hacer un telnet hacia el puerto 80? Que te responde?

El mundo es como lo vemos porque existimos.

+1
0
-1
Imagen de viquez
+1
0
-1

[eliminar comentario duplicado]

+1
0
-1
Imagen de calitos
+1
0
-1

buenas,

el modelo de mi router es de la firma: ZIXEL al ingresar a la configuracion de Advance setup escojo la opcion Nat, luego elijo: dentro de network adress hay tres opciones: None, Sua only y Full feature y el que esta seleccionado es Sua only el cual elijo para configurar , luego aparecen dos columnas una es: start port la otra end port y la otra columna es para colocar los ip adress.
lo que hago es colocar en la columna start port 80 en la columna end port 80 y en ip adress 192.168.1.xxx, luego guardo y reinicio mi router.

si esta mal lo que hice diganme por favor en que falle.
saludos

+1
0
-1
Imagen de calitos
+1
0
-1

el modelo de router que di lo conocen alguien usa este modelo y a liberado puertos???
alguna respuesta???

+1
0
-1
Imagen de Joule
+1
0
-1

Pero confirmaste que este bien configurado en NO-IP ?? Te resuelve correctamente las IP's???
Ni idea de ese equipo, pero parece q esta bien configurado el NAT.

________________________________________________________________________________________________________
Siempre hay un poco de locura en el amor... aunque siempre hay un poco de razón en la locura. (Nietzshe)

+1
0
-1
Imagen de calitos
+1
0
-1

MI ip es dinamica, por eso he creado en la web de dyndns mi dominio el cual lo he llamado: miweb.dyndns.org, la ip publica se autoreconoce en la web de dyndns quedando ahi, pero segun informes tenia que instalar ddclient en ubuntutu el cual lo hice. Al configurar ddclient me pide algunos datos como por ejemplo nombre de la pagina donde he creado mi dominio, mi dominio, el usuario y clave, etc. lo que supuestamente hace este programa es actualizar mi ip dinamica y la actualiza en la web de dyndns. pero ademas de eso hay que liberar puertos en mi router, sobre todo el 80 que es el de las web. ingrese a mi router y lo que explique anteriormente hice.
ahora cuando ingreso desde mi pc a mi dominio me pide clave y solo me lleva a mi router, si lo hago de otra maquina con conexion a internet no sale nada.
cuando hago telenet y apunto a mi ip se cierra el terminal.

La verdad no se que hacer, ya he grabado mi web en la carpeta de www, incluso he puesto nombre a mi host dentro de las configuraciones de apache2. bueno en realidad he realizado de todo y se supone que deberia ver mi web en otras maquinas atraves de internet.
si alguin sabe de configurar servidores me puede dar algunas alternativas se lo agradeceria...XD¡
saludos

+1
0
-1
Imagen de calitos
+1
0
-1

Bueno en vista de no tener respuestas, quiero que sepan que he averiguado un dato que me parece importante y en base a ello hare una nueva pregunta: la pagina de configuracion de mi router zyxel 650 se muestra a traves del puerto 80, la pregunta seria ¡cómo cambio ese puerto por otro para que de esa manera el puerto 80 sea para salida de mi web y ya no la salida de la pagina de configuracion de mi router? pero, haciendo que la pagina de configuracion del router salga a traves de un puerto diferente.

saludos y a la espera de una respuesta.

+1
0
-1
Imagen de novatotal
+1
0
-1

no es que no haya nadie dispuesto, es cuestión de que, la persona con el conocimiento adecuado lea tu post; ten calma ya llegara la ayuda
¿Porque mis impuestos acaban en la cuenta de el Sr. Gates?

emachines intel pentium d 925, sataII 320GB, acelerador de graficos intel 950,
1GB DDR, LCD 17" ethernet intel 10/100 Mbsp ubuntu hardy

+1
0
-1

Firma: ¿Porque mis impuestos acaban en la cuenta de el Sr. Gates?
http://doc.ubuntu-es.org/Documentaci%C3%B3n

Imagen de calitos
+1
0
-1

solo queria saber si existia alguien pero ya veo que si, jejejeje bueno esperare pex, pero igual gracias por responder

+1
0
-1
Imagen de calitos
+1
0
-1

Hola a todos

Ya hice todo para que mi servidor funcione y tenga salida a internet, al decir hice todo me refiero a la configuracion de apache pero, al hacer una prueba desde una pc fuera de mi lan muestra una pequeña ventana pidiendo usuario y contraseña. Esta ventana la cancelo y aparece el siguiente mensaje:

Protected Object
this object on the RomPager server is protected

A que se debe esto??? Qué debo hacer ????

Tengo un router zyxel 650
Ayudenme urgente

+1
0
-1
Imagen de relocoabry
+1
0
-1

hola, estoy intentando montar un servidor web casero para poner en practica lo que aparece en http://doc.ubuntu-es.org/LAMP y mi duda comienza cuando tengo que redireccionar los puertos:

la verdad no se si es que eso altere mi conexión de alguna manera, puedo hacerlo si tengo el servidor en una red casera?? el trabajo de mis padres depende mucho de que funcione bien la conexión y no quiero arriesgarme a tener problemas con eso.

mi modem es un pirelli drg a125

+1
0
-1
Imagen de josh771
+1
0
-1

A mi me pasaba lo mismo, trataba de ingresar fuera de mi red interna, ya que yo tengo el servicio de NO-IP. Al principio jalo bien el servidor, pero después que se interrumpió el servicio de energía lo que paso es que se desconfiguro el router y cada vez que quería acceder remotamente a mi servidor o a la pagina principal del susodicho me solicitaba un usuario y contraseña.

El procedimiento que realice fue el siguiente:

1. Reinicie el router con su configuraciones de fabrica.
2. En la configuracion del no-ip, di de baja el nombre del servidor que tenia y di de alta otro.
3. Baje una aplicación del no-ip, para mi distro de ubuntu y le di los parámetros que me solicito, los cuales son: nombre de la cuenta o correo, contraseña y el nuevo nombre del servidor.(Por default al logearse te reconoce el nombre del servidor).
4. Dentro del router, en las opciones de DNS, le especifique el servicio que estaba utilizando, en este caso, NO-IP y posteriormente di de alta la cuenta y la contraseña y el NUEVO nombre del servidor.
5. En la pestaña de dispositivos, active las aplicaciones de: Servidor web, servidor ftp, telnet, ssh y vnc, asignándole todas estas aplicaciones a mi servidor. (Por default, te abre el puerto 80).

Espero que te sirva de algo el comentario que realice, salu2...

+1
0
-1