Altavoces y auriculares sonando a la vez.

Imagen de hectorsales
22 puntos

Hola tengo el siguiente inconveniente, cuando enchufo los auriculares al panel frontal de mi torre los altavoces no se silencian siguen sonando. Mi sistema operativo es linux mint 13 Mate 64 bits (basado en ubuntu 12.04).

Tipo de tarjeta

cat /proc/asound/cards

0 [SB ]: HDA-Intel - HDA ATI SB
HDA ATI SB at 0xfbbf4000 irq 16
1 [HDMI ]: HDA-Intel - HDA ATI HDMI
HDA ATI HDMI at 0xfbdfc000 irq 19

Modelo de Tarjeta

cat /proc/asound/modules

0 snd_hda_intel
1 snd_hda_intel

Chip y codec

cat /proc/asound/card0/codec#0 | grep Code

Codec: VIA VT1708S

Según la información de esta página:
https://www.kernel.org/doc/Documentation/sound/alsa/HD-Audio-Models.txt

Para el modelo de chipset de VIA (VIA VT17xx/VT18xx/VT20xx) debo poner lo siguiente en el fichero /etc/modprobe.d /alsa-base.conf

options snd-hda-intel model=auto

He revisado también zless /usr/share/doc/alsa-base/driver/HD-Audio-Models.txt y también coincide con la información de la página es decir para el chipset via debo poner model=auto. Pero no he conseguido ningún avance. He probado diversas configuraciones:


options snd-hda-intel model=auto
options snd-hda-intel model=auto probe_mask=0x103
options snd-hda-intel model=auto probe_mask=0x103 enable_msi=0
options snd-hda-intel model=auto probe_mask=0x103 position_fix=1

Pero de momento no consigo solventar el problema .....

Saludos .

Imagen de LyingB
+1
0
-1

a usar alsamixer:

alsamixer

Luego oprime F6 para seleccionar la tarjeta de audio y luego F5 para que muestre todas las opciones; desplázate a la derecha hasta Auto-Mut y verifica que esté habilitado, si no lo está habilítalo y cierra alsamixer.

+1
0
-1


Agrega al final del título del post (solucionado) si has arreglado tu problema.

Imagen de hectorsales
+1
0
-1

Hola gracias, por la respuesta, tengo seleccionado todos los elementos y no encuentro la opción "Auto-Mut". aquí dejo un enlace con la captura de la imagen de alsamixer:

http://imageshack.us/photo/my-images/10/lkn7.png/

Gracias por responder ....

+1
0
-1

Linux Mint 13 Mate 64 Bytes

Imagen de LyingB
+1
0
-1

no está la opción.

Tendrías que modificar las opciones de tu tarjeta, pero no sé cuáles sean las que tengas que poner para ello.

+1
0
-1


Agrega al final del título del post (solucionado) si has arreglado tu problema.

Imagen de hectorsales
+1
0
-1

Ok, gracias de todas las maneras...

+1
0
-1

Linux Mint 13 Mate 64 Bytes