tarjeta wifi desactivada por interruptor físico (hard blocked)

Imagen de iamorrortu
0 puntos

Hola a todos,
A ver si alguien me puede ayudar con el siguiente problema, tengo un portátil Toshiba Satellite L500-20Z con Ubuntu 12.04 y no hay manera de que funcione la tarjeta wifi. En el icono de redes aparece "la red inalámbrica está desactivada por el interruptor físico". Realmente, en el portátil no hay ningún interruptor físico para activar la tarjeta wifi, como mucho, en Windows está la tecla win+F8.

-------------------------------------------------------------------------------------------

Al hacer un: "sudo lshw -c network" en la terminal aparece lo siguiente:

*-network DESACTIVADO
descripción: Interfaz inalámbrica
producto: RTL8191SEvB Wireless LAN Controller
fabricante: Realtek Semiconductor Co., Ltd.
id físico: 0
información del bus: pci@0000:14:00.0
nombre lógico: wlan0
versión: 10
serie: b4:82:fe:bd:16:7e
anchura: 32 bits
reloj: 33MHz
capacidades: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuración: broadcast=yes driver=rtl8192se driverversion=3.2.0-52-generic-pae firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
recursos: irq:19 ioport:4000(size=256) memoria:f2200000-f2203fff

------------------------------------------------------------------------------------

Al hacer un "lspci":

00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:1a.0 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.2 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1a.7 USB controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 (rev 03)
00:1c.5 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 6 (rev 03)
00:1d.0 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation 82801IBM/IEM (ICH9M/ICH9M-E) 4 port SATA Controller [AHCI mode] (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
0e:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)
14:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8191SEvB Wireless LAN Controller (rev 10)

------------------------------------------------------------------------

Con "rfkill list" aparece:

0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: yes

------------------------------------------------------------------------

Ya he probado con lo siguiente:
"sudo rfkill unblock all" y después reiniciar.
sin resultado.

"sudo rm /dev/rfkill" y después reiniciar.
sin resultado.

"sudo ifconfig wlan0 up"
resultado: "Operación imposible por estar la radiofrecuencia desactivada"

¿Alguna sugerencia?

Imagen de iamorrortu
+1
0
-1

Por lo que he leído en askubuntu:

http://askubuntu.com/questions/60800/toshiba-wireless-is-blocked

Parece ser que el problema viene de que el portátil no tiene interruptor físico para encender la tarjeta wifi, sino que hay que hacerlo con una combinación de teclas: FCN+F8.

Todas estas combinaciones de teclas que sirven para activar-desactivar wifi, activar-desactivar touchpad, bloquear la pantalla, entrar en modo suspension, etc... son lo que se llama "Toshiba Value Added Package"; un software de los portátiles Toshiba que sólo funciona bajo Windows.

En el hilo del link que he puesto arriba explica como un usuario ha solucionado este problema haciendo una partición nueva en la que ha instalado windows y el famoso TVAP (toshiba value added package). Después de hacer la instalación ha iniciado con windows, ha activado la tarjeta wifi con la combinación de teclas. Luego ha vuelto a iniciar con ubuntu y parece ser que ahora le funciona.

Desafortunadamente he buscado el software TVAP en internet pero no lo encuentro.

Seguiré buscándolo y si lo encuentro intentaré el método arriba mencionado. De todas formas me pregunto ¿funcionará el TVAP con wine?

+1
0
-1
Imagen de iamorrortu
+1
0
-1

He encontrado los drivers TVAP en el siguiente link:

http://www.toshiba.es/innovation/download_drivers_bios.jsp

De mo mento los estoy descargando. A ver si puedo hacerlos funcionar con wine. Sino habrá que instalar windows 7 en una partición aparte e intentar activar el wifi con FN+F8

+1
0
-1
Imagen de iamorrortu
+1
0
-1

Confirmado, no funciona con wine.

Habrá que instalar Windows 7, da mucha pereza pero a menos que a alguien se le ocurra otra solución...

+1
0
-1
Imagen de rioport
+1
0
-1

Encontré varios hilos que describen diferentes formas de activar la red, pero con equipos diferentes. En el caso del tuyo no hay mucho que hacer más que instalar Windows y desde ahí activar la red inalámbrica, es lo que pasa a veces cuando el equipo es Designed for Windows ....

+1
0
-1

-- GC --