Problemas al actualizar firefox 24 en Ubuntu 9.04

Imagen de la_flaca
0 puntos

Tengo ya algùn tiempo usando el Ubuntu 9.04 y me ha ido muy bien solo he tenido problemas ahora cuando tratè de actualizar el firefox. Tenia la version 3.6 y me pedia que lo actualizara. Descarguè la version actual 24.0 y ahora me sale esto cuando ejecuto por la terminal:

firefox: symbol lookup error: /opt/firefox/libxul.so: undefined symbol: gtk_widget_set_can_focus

Segui los siguientes pasos:
1.- Baje y descomprimí el tar. de firefox, que por ende te crea una carpeta con el mismo nombre.

2- Después moví la carpeta al directorio /opt

# sudo mv firefox /opt

3- Nos colocamos en la carpeta donde vamos a colocar un enlace simbólico:

# cd /usr/bin/

4- Creamos el enlace simbólico:

#sudo ln -s /usr/firefox/firefox

5.- Le damos permiso de ejecución

#?sudo chmod -R 775 /opt/firefox

6- Sólo nos queda crear el lanzador de la aplicación (Acceso directo), que lo hacemos con botón derecho en el escritorio->crear un lanzador. Colocamos los datos del programa. En comando le damos a examinar y buscamos el enlace simbólico de nombre firefox que esta en /opt/firefox/firefox

Que tendrè que hacer lo necesito ràpido auxilio !!!!

Imagen de rioport
+1
0
-1

No parece que sea un problema por falta de alguna biblioteca. Es lo que pasa cuando se usa una versión sin soporte; que un día los programas (que se actualizan frecuencia) dejan de ser compatibles. Una posible solución y que quizá no funcione es que te compiles firefox.

No estás pagando a nadie como para pedir que las cosas se te hagan rápido ¬¬ .

+1
0
-1

-- GC --