El teclado se desconfigura en cada inicio

Imagen de Kaiver
0 puntos

Entorno:
Tengo recién instalado Ubuntu Gnome 13.04 de 64 bits, actualizado hasta día de hoy y con el soporte de idioma completo. Mi teclado es un logitech K340.
La imagen que he usado para la instalación -> http://cdimage.ubuntu.com/ubuntu-gnome/releases/13.04/release/

Problema:
Nada más entrar el primer día, vi que el layout del teclado estaba mal (inglés), por lo que los caracteres estaban cambiados de sitio, había problemas con la "ñ", etc. Decidí ir a soporte de idioma e instalar bien el Español (al completo). Luego fui a la configuración del sistema -> región e idioma y puse "idioma, formato y distribución" en Español. Por último, en la pestaña de sistema le di a que copiase mi configuración para que todo el sistema estuviese configurado de ese modo (demás cuentas de usuario, etc).

Todo perfecto, mi teclado funcionaba perfectamente, pero al reiniciar el ordenador se vuelve a desconfigurar solito. Vuelvo a sistema -> región e idioma y todo parece estar OK, pero al darle a "copiar configuración" en la pestaña de sistema, vuelve a funcionar bien. Cómo veis nos encontramos en un típico bucle for... en el que me puedo tirar el resto de mi vida reconfigurando el teclado cada vez que inicio / reinicio el ordenador (me falta probar si también se desconfigura al cerrar sesión de usuario... xD).

He probado otra alternativa en terminal con "sudo dpkg-reconfigure keyboard-configuration" lo cual puso el teclado bien hasta el próximo reinicio.

Otras fuentes:
He estado leyendo foros y "googleando" un rato porque no me gusta molestar a la comunidad si se puede evitar y he encontrado algunas cosas interesantes, pero ninguna me ha servido (de las que he estado viendo). Por ejemplo en este hilo tienen el mismo problema y dicen que se soluciona cambiando el idioma en la pantalla de login de GDM en lugar de en región e idioma -> http://www.ubuntu-es.org/node/126166#.UYggbklEGV4 no obstante en mi versión de Gnome no hay selector de idioma en la pantalla de login (o al menos yo no lo veo... puede ser que no lo vea porque soy un poco torpe... xD)

Otro interesante en el que reconfiguran el Xorg -> http://andalinux.wordpress.com/2008/08/08/configurar-teclado-ubuntu-corr... pero creo que desde hace un tiempo en Ubuntu el xorg ya no está en ese fichero (disculpad mi ignorancia, no se mucho de Ubuntu a nivel de servicios y configuraciones) y no encuentro el equivalente que debería modificar para probar esa "solución" que no se si me funcionará.

Y como estos un sin fin de hilos en los que no doy encontrado una forma de solucionar el problema.

Opinión:
Creo que se puede tratar de algún tipo de conflicto entre la configuración de idioma de GDM y el sistema (Ubuntu) [Hablo desde mi poco conocimiento técnico de las tripas del sistema juzgando a partir de lo leído en este tiempo].

¿Alguien tiene alguna idea de como podría solucionarlo o qué podría estar sucediendo?
Necesito un dichoso "break;" en mi "for" para no perder horas y horas cada año reconfigurando el teclado con cada inicio.

Muchas gracias y disculpad por el ladrillo... pero lo quería explicar bien xD

Imagen de cuentos
+1
+2
-1

me paso algo similar con gnome, y lo resolvi de esta manera en idioma, selecione la opción de mas, volvia instalar el idioma español, (dejando dos idiomas español). y selecione el nuevo "español" y configure mi teclado latin-, con estgo resolvi el problema.
Espero y te funcione.

+1
+2
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de Kaiver
+1
0
-1

En idiomas no me aparece ni un más, ni un menos para añadir/eliminar idiomas. Tampoco me deja ordenarlos con drag & drop.
En las pestaña de Formatos me deja añadir y eliminar (y ya tengo seleccionado Español).
En la pestaña de Distribuciones me deja añadir/eliminar y ordenar (y tengo tan solo Español en la lista).

Es extraño, parece que algo sucede con la manipulación de idiomas ¿puede ser un problema de permisos que no me permita manipular esa pestaña y por eso no me aparecen botones para añadir/eliminar ni me deja ordenarlos con drag & drop?

El usuario de mi sesión es el administrador aunque todo esto lo hago sin estar como root al igual que el resto de usuarios supongo.

Gracias por el aporte de todos modos.

+1
0
-1
Imagen de .doc
+1
+1
-1

yo creo que te debería bastar ir NO a 'región e idioma' sino a 'teclado'. Ahi, añadir el teclado español, ponerlo como predeterminado e incluso eliminar el teclado-us.

+1
+1
-1
Imagen de Kaiver
+1
0
-1

Eso ya lo he hecho, me he cargado el teclado US y solo tengo el "Español" pero nada, ni con esas.

+1
0
-1
Imagen de Gabriel_M
+1
+1
-1

Ejecuta:

sudo su
apt-get install locales
dpkg-reconfigure locales
dpkg-reconfigure console-data
+1
+1
-1
Imagen de Kaiver
+1
0
-1

Hola tenía instalado ya el paquete locales.
No obstante no tenía instalado el paquete console-data.

Acabo de instalarlo y lanzar la reconfiguración. Voy a reiniciar y te cuento que pasa.

Muchísimas gracias por tu aporte de antemano.

+1
0
-1
Imagen de Kaiver
+1
0
-1

Hola Gabriel_M, no ha funcionado y además se puso el idioma del sistema en Inglés.
He seleccionado el teclado y el idioma en Español de nuevo y me mantiene el idioma en Español, pero el teclado me lo desconfigura con cada inicio al igual que antes.

Muchas gracias por tu aporte de todos modos.

+1
0
-1
Imagen de Kaiver
+1
0
-1

Se me ocurre... podría ser algún problema con los permisos de escritura de algún fichero (que desconozco cual podría ser) que al no poder ser escrito no puede hacer que los cambios sean persistentes ¿y solo duran mientras dura la sesión?

Por tratar de encontrar alguna explicación a que pierda la configuración cada vez que cierro sesión...

+1
0
-1
Imagen de Kaiver
+1
0
-1

Al ejecutar el comando sudo dpkg-reconfigure gdm no sucede nada.

Lo estaba intentando ejecutar para ver si al reconfigurar GDM por terminal como sudo había alguna opción del layout del teclado y los cambios persistían.

No se si es normal que dpkg-reconfigure gdm no haga nada, pero me da la espina que no... xD

+1
0
-1
Imagen de cuentos
+1
+1
-1

cuando estas en la parte de region e idioma, hay un simbolo de mas en la parte de abajo, si das click agregas un nuevo idioma.
http://s19.postimg.org/codmpt24j/gnome3.png

+1
+1
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de Kaiver
+1
0
-1

No me aparece ningún botón en la pestaña de idioma.
Ni para añadir, ni para eliminar, ni para ordenar.

Ese es uno de los problemas.

+1
0
-1
Imagen de cuentos
+1
+1
-1

Se me olvidaba

r ni me deja ordenarlos con drag & drop?

para ordenalros usa las tecla como flechas las que estan a en este orden:
+ - flecha arriba flecha abajo

+1
+1
-1

(recordatorio) -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-
Si el problema se soluciono, edita el 1° hilo, y agrega (Solucionado), para tener el foro mas ordenado.
Y finaliza poniendo la solución para que sirva para otros Usuarios.
Twitter @mcuentos

Imagen de Kaiver
+1
0
-1

Tampoco hay flechas jejeje

+1
0
-1
Imagen de Kaiver
+1
0
-1

Tengo que darle una solución al problema así que voy a reinstalar el sistema con la imagen oficial con Unity a ver si así me va bien el idioma.

Muchas gracias a todos por vuestra ayuda, pero no lo doy solucionado, así que me rindo.

Los moderadores si quieren que cierren el hilo o lo dejen abierto por si a alguien le sucede algo parecido pueda usarlo como referencia y no partir de cero.

Un saludo.

P.D:-> Os doy +1 a los que me habéis aportado ideas como agradecimiento.

Un saludo!

+1
0
-1
Imagen de GaboSeh
+1
0
-1

anda a "Buscar en su equipo y en linea" --> teclado---> Configuración de distribución ---> eliminar el idioma inglés y mantener sólo el espeñaol (latinoamericano).

+1
0
-1