Problema instalación driver AMD Radeon HD 7600M Series en Ubuntu 12.04 lts

Imagen de Robertomcat
0 puntos

Hola chicxs, hace dos días instalé los drivers que descargué de la web de AMD para esta tarjeta AMD Radeon HD 7600M Series en Ubuntu 12.04 lts (Soy novato). Una vez instalados los drivers me apareció la pantalla negra, como a muchos les pasa. Creo que al instalar los drivers pequé de la falta de experiencia en el tema, porque creo que estos drivers funcionan en Ubuntu 12.04 lts. Pasé un día entero buscando por internet (y en este foro) como poder quitar dichos drivers para poder volver a entrar en Ubuntu.

Éstos son los comandos que ejecuté en la terminal para poder desinstalar los drivers, una vez entrado en modo recovery. Antes que nada me pidió el login y contraseña.

cd /usr/share/ati
sudo sh ./fglrx-uninstall.sh

Una vez ejecutados estos comandos me dejó entrar con normalidad al S.O.

Me gustaría que me echarais un cable a la hora de instalar este driver. En los detalles de Ubuntu, me dice que estoy utilizando la tarjeta gráfica de Intel.

Mi ordenador es un notebook HP Pavilion g6 con el procesador Intel i5 3210M. En cuanto a las tarjetas gráficas hay dos: la Intel HD Graphics 4000 y la AMD Radeon HD 7600M Series.

Tengo una duda, y no se si descargué los drivers correctos desde la web, ya que están los de la GPU y APU. Este es el archivo que utilicé para la instalación: amd-driver-installer-catalyst-13-4-x86.x86_64.run lo instale dándole permisos de ejecución.

Me gustaría que me echarais una mano a la hora de instalar los drivers o decirme si éstos no son buenos para mi PC. Muchas gracias.

Imagen de MrTulias
+1
0
-1

Buenas.

Me pasó lo mismo al instalar el privativo, http://www.ubuntu-es.org/node/180068

Creo que el más problemático de los privativos es el de 'actualizaciones post-lanzamiento', es con el que se me iba la pantalla a negro.
El driver de ati que trae 'de serie' está bastante actualizado.

Saludos

+1
0
-1

"To do is to be" (Nietzsche)
"To be is to do" (Kant)
"Do be do be do" (Sinatra)

Imagen de Robertomcat
+1
0
-1

Hola, yo no probé a instalar el que me sale en los privativos del centro de software, ya que solo me sale uno y esta en fase experimental. Decidí descargar el de la web oficial. Después lo instalé ejecutando el .run y no me funcionó. Per eso pregunto a ver si he descargado el correcto. Yo instalé el GPU, pero no sé si será el correcto, ya que bien puedes elegir el GPU o el APU porque no se si mi pc usa híbrida o no.

+1
0
-1
Imagen de MrTulias
+1
0
-1

Creo que viene a ser el mismo que el que aparece en controladores adicionales (fglrx), con un .run me lo cargué también.

Los enlaces que me pasaron puede que te sirvan
http://ubuntuforums.org/showthread.php?t=1930450
http://wiki.cchtml.com/index.php/Ubuntu_Precise_Installation_Guide

Saludos

+1
0
-1

"To do is to be" (Nietzsche)
"To be is to do" (Kant)
"Do be do be do" (Sinatra)

Imagen de alfill_2000
+1
0
-1

Hola MrTulias, he seguido los pasos del primer link, pero cuando llego al paso de crear los paquetes me dice esto:
: not foundr-installer-12-4-x86.x86_64.run: 1: ./amd-driver-installer-12-4-x86.x86_64.run:
./amd-driver-installer-12-4-x86.x86_64.run: 2: ./amd-driver-installer-12-4-x86.x86_64.run: Syntax error: redirection unexpected
Tambien soy un novato, pero con ideas..., en Ubuntu y estoy con la ver. Ubuntu 12.04.4 LST en un laptop HP pavilion g6 core I7. Puedes echarme una mano para instalar el dichoso driver???
Gracias de antemano, un saludo.
Alfill.

+1
0
-1
Imagen de Jose Luis 1320
+1
0
-1

y también por que no te pertenece, abre un hilo nuevo publicando tu pregunta, especificando los detalles de tu problema.

+1
0
-1

"Yo sólo se que no se nada"
-Sócrates, filósofo griego.
-Normas del foro

Imagen de Robertomcat
+1
0
-1

Hola MrTulias, están muy bien los tutoriales de las webs, lo que pasa es que me dan un poco de miedo. Habría algún problema al instalar el que está en fase experimental del Centro de software? Te lo pregunto por si has tenido alguna experiencia con este tipo de drivers. Muchas gracias.

+1
0
-1
Imagen de MrTulias
+1
0
-1

La experiencia que he tenido ha sido que en cuanto instalaba los privativos se me quedaba la pantalla en negro al reiniciar, así que estoy con el genérico.
No he probado todo lo del segundo enlace, sólo el paso 5, como soy novatillo también me da yuyu cuando arranca con la pantalla en negro. Lo recupero entrando en modo recuperación, pero prefiero experimentar con gaseosa :p

Si decices borrar el privativo y dejar el genérico puedes ver si detecta bien la tarjeta con lspci, lsmod y mirando algunos logs, el de x, /var/log/Xorg.0.log, el de arranque /var/log/dmesg
No entiendo la mitad de lo que pone, pero si aparecen líneas con la gráfica quiero creer que la reconoce bien.

El mayor problema que vas a tener probando los drivers es que la pantalla se vaya a negro al reiniciar, nada que no se solucione desinstalando lo instalado y volviendo a la configuración inicial.

Saludos

+1
0
-1

"To do is to be" (Nietzsche)
"To be is to do" (Kant)
"Do be do be do" (Sinatra)

Imagen de Robertomcat
+1
0
-1

Hola mrtulias, pues ahora mismo tengo el problema de la pantalla en negro, con la diferencia de que ahora no sé como quitarla. Intenté instalar el driver del centro de software y ahora ya no puedo entrar. Cómo hago para volver a la situjación de antes?? Muchas gracias por todo.

+1
0
-1
Imagen de Robertomcat
+1
0
-1

Hola, lo he podido solucionar, pero he intentado instalar el driver que me he descargado de la web oficial, y en el proceso de instalación me dice una pantalla pequeñita que tengo un driver instalado y que lo tengo que desinstalar para poder llevar a cabo la instalación del nuevo. Cómo puedo eliminar cualquier rastro de los drivers de ATI/AMD?

+1
0
-1
Imagen de MrTulias
+1
0
-1

En el primer link que te puse me dijeron cómo borrar lo de fglrx http://www.ubuntu-es.org/comment/511033#comment-511033

Saludos

+1
0
-1

"To do is to be" (Nietzsche)
"To be is to do" (Kant)
"Do be do be do" (Sinatra)

Imagen de Robertomcat
+1
0
-1

Hola MrTulias, he puesto el comando: "sudo sh /usr/share/ati/fglrx-uninstall.sh" pero me dice esto:
"One or more files have been altered since installation.
Uninstall will not be completed. See /etc/ati/fglrx-uninstall.log for details."

Despúes he ido a ver la carpeta y me sale todo esto:
http://imageshack.us/photo/my-images/31/75ig.png/

Veo que hay muchos archivos repetidos. Qué puedo hacer? Gracias.

+1
0
-1
Imagen de MrTulias
+1
0
-1

...del mensaje:
"Uno o más archivos han sido alterados desde la instalación.
La desinstalación no será completada. Vea /etc/ati/fglrx-uninstall.log para detalles."

Deberías ver los logs de desinstalación, tienes unos cuantos... ¿Repetidos? Puede que sean los intentos de desinstalación realizados (no lo sé). Quizá te ponga en qué falló y puedas apañarlo.

Saludos

+1
0
-1

"To do is to be" (Nietzsche)
"To be is to do" (Kant)
"Do be do be do" (Sinatra)

Imagen de Robertomcat
+1
0
-1

Hola. Pues si, en la carpeta hay un montón de archivos repetidos, creo que 12. Que es lo que debo hacer?? He intentado borrar los repetidos, pero no me dejaba.

+1
0
-1
Imagen de MrTulias
+1
0
-1

Primero deberías leerlos, a ver qué te cuentan. Es más que posible que te digan en qué falló el proceso de desinstalación, si no seguirás teniendo problemas para terminar de desinstalar (con lo que tendrás problemas para intentar instalar el otro).

Mira a ver el propietario y los permisos de los ficheros, igual tienes que quitarlos usando sudo (como superusuario)

Insisto... ¿Qué problema tienes con el genérico? Sobre todo dándote tantos problemas el privativo...

Saludos

+1
0
-1

"To do is to be" (Nietzsche)
"To be is to do" (Kant)
"Do be do be do" (Sinatra)

Imagen de Robertomcat
+1
0
-1

Es que no soy muy entendido, que hago, abro el archivo y veo lo que me pone?

Tengo interés en poner este driver porque el ordenador se me calienta bastante y el ventilador está siempre más acelerado de lo normal (en comparación con el Windows 8.1) y creo que el problema radica en la tarjeta gráfica; a no ser que esté equivocado y se derive de otro problema. La cosa es que como soy bastante inexperto no puedo afirmarlo concretamente, sería engañarme a mí mismo. Esto lo cuento por la experiencia de otros usuarios, los cuales he podido leer por ahí. Muchas gracias.

+1
0
-1
Imagen de Robertomcat
+1
0
-1

Hola buenas tardes, quería volver a reemprender el tema de poder desinstalar completamente los drivers que se me han quedado instalados, y que de ninguna manera puedo desinstalar. En la carpeta donde están los drivers, me sale que se han repetido un montón de veces, ahora os dejo la imagen de dicha carpeta. Qué solución puedo darle a esto?

http://imageshack.us/photo/my-images/31/75ig.png/

+1
0
-1
Imagen de davidso82
+1
0
-1

Hola yo tengo el mismo procesador y la misma tarjeta gráfica, a mi me paso algo similar, intenté instalar los controladores de la pagina de AMD dandole permiso de ejecución (todo lo hice en entorno gráfico) y al cargar el instalador me dice que tengo un driver ya instalado, lo que hice fue mirar en " configuración del sistema > controladores adicionales " y me dí cuenta de que tenía activado los controladores privativos de ATI/AMD, luego los desactive y pude instalar el driver con el instalador de la pagina de AMD, corre mucho mejor, de pronto su problema es mas complicado pero mi comentario le puede servir a alguien que apenas este comenzando en Ubuntu como yo.

+1
0
-1
Imagen de davidso82
+1
0
-1

Para reinstalar los drivers que venían por defecto de ATI/AMD en la instalación de Ubuntu puedes usar los siguientes comandos:

sudo aptitude reinstall xserver-xorg-video-radeon xserver-xorg-video-radeonhd
sudo dpkg-reconfigure xserver-xorg

y los de Intel por si acaso:

sudo aptitude reinstall xserver-xorg-video-intel
sudo dpkg-reconfigure xserver-xorg

esto te los reinstala y probablemente te deje instalar los de la pagina de AMD .

+1
0
-1