Adaptador ide_usb no reconoce disco.

Imagen de Josep.M
0 puntos

Buenos días, he comprado uno de esos adaptadores IDE/SATA a USB que pululan por la red, con la intención de utilizar varios HD viejos que tengo en desuso como discos externos. Bien pues no hay manera de que ubuntu los monte.
Los he formateado como "ext4" y en gparted los puedo ver, pero no me los monta.
El error que me aparece en pantalla cuando lo intento es este:

Error mounting /dev/sdg at /media/castegi/etd: Command-line `mount -t "ext4" -o "uhelper=udisks2,nodev,nosuid" "/dev/sdg" "/media/castegi/etd"' exited with non-zero exit status 32: mount: wrong fs type, bad option, bad superblock on /dev/sdg,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

Incluso me aparece el icono en la barra de lanzadores, montándolo manualmente, pero no se puede abrir.
¿sabeis que puede estar pasando? ¿qizás sea un problema de drivers?

Saludos y gracias por edelantado.

Imagen de Gabriel_M
+1
0
-1

Enchufa el disco
Inicia gparted
Accede al disco
Elimina la tabla de particiones
Crea una nueva tabla msdos
Crea luego una partición sistema de archivos ext4
Aplicados los cambios tendría que quedar montado y accesible.
Para poder escribir es necesario crear un directorio y darle permisos, para escribir siempre dentro de ese directorio.

sudo su
mkdir /media/castegi/etd/datos
chmod -Rf 777 /media/castegi/etd/datos
+1
0
-1
Imagen de Josep.M
+1
-1
-1

Hola, perdona no haberte contestado antes, pero dejé un poco de lado este tema y no ví tu respuesta.
Acabo de probar lo que me dices, después de borrar las particiones y al intentar crear una nueva con gparted me devuelve este error:
Error de entrada/salida durante la escritura en /dev/sdg

Gracias y saludos

+1
-1
-1
Imagen de .doc
+1
0
-1

pues sospecho que tocaría pensar en que lo que tienes es un problema de hardware (el disco duro, la falta de alimentación suficiente o el aparato que te compraste) ¿has probado formatearlo en fat32, a ver si así te lo reconoce?

+1
0
-1
Imagen de Josep.M
+1
0
-1

Creo que debe ser el adaptador, ya que he probado con varios discos y con todos lo mismo...incluso con alguna memoria flash ide 40 y nada.
Sí he probado a formatear en fat y más de lo mismo.
de todas maneras gracias por tu ayuda.

Saludos.

+1
0
-1