problema con imlib2

Imagen de r3k07
0 puntos

buenas,

pues es q tengo problemas con esta libreria en el momento d instalar enlightenment CVS i al ejecutar el autogen.sh me da este error:

checking for pkg-config... /usr/bin/pkg-config
checking for imlib2 >= 1.2.0... Package @requirements@ was not found in the pkg-config search path.
Perhaps you should add the directory containing `@requirements@.pc'
to the PKG_CONFIG_PATH environment variable
Package '@requirements@', required by 'imlib2', not found

configure: error: Library requirements (imlib2 >= 1.2.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.

con el pkg-config no me entiendo. alguien me puede decir los pasos a seguir.
por favor, una ayudita
muxas gracias

Imagen de js.toledano
+1
0
-1

Te faltan librerías de desarrollo. Si es el único paquete que tiene problemas con hacer sudo apt-get install libimlib2-dev seria suficiente.

De hecho, cada vez que veas un problema parecido debes hacer lo mismo:

apt-cache search imlib2
...
sudo apt-get install libimlib2

O puedes intentar con auto-apt run ./configure ;)

apt-cache show auto-apt

SapoDriLo
Tlaxcala, México
+1
0
-1

En esta vida solo puedes tener dos cosas: razones y resultados.
Las razones no cuentan.

Imagen de bull3tpr00f
+1
0
-1

En pocas palabras SapoDrilo, ¿en que consiste el auto-apt? ¿tal vez resuelve dependencias el solito?

Un saludo
________________________________________
JabberID: cut0ff@jabberes.org
visita mi blog

+1
0
-1
Imagen de js.toledano
+1
0
-1

Se supone que busca todos los archivos que un programa solicita y si no lo encuentra lo instala.
En pocas palabras: instala bajo demanda. Suena interesante, no?


SapoDriLo
Tlaxcala, México
+1
0
-1

En esta vida solo puedes tener dos cosas: razones y resultados.
Las razones no cuentan.

Imagen de Anónimo
+1
0
-1

Hola a todos.
Al parecer esto se debe a un bug en el famoso imlib2.
Para solucionarlo unikamente borra la linea k te pide el @requierements@.pc en el archivo imlib.pc

A mi me funciono espero a ustedes tmb.

Saludos desde Morelia, Michoacan, México :D

+1
0
-1
Imagen de Anónimo
+1
0
-1

Hola a todos.
Al parecer esto se debe a un bug en el famoso imlib2.
Para solucionarlo unikamente borra la linea k te pide el @requierements@.pc en el archivo imlib.pc

A mi me funciono espero a ustedes tmb.

Saludos desde Morelia, Michoacan, México :D

+1
0
-1
Imagen de r3k07
+1
0
-1

pues creo q me he explicado mal.
me baje la libreria imlib2 n tar.gz y hice lo de siempre configure && make && make install. luego n elightenment pues autogen.sh y me daba el error igualmente.

en los repositorios de ubuntu (hoary), solo me sale libimlib2-1.1.2.2-1 y enlightenment necesita la 1.2.0, es por eso q me la baje y compile y nada.
tb he de decir uso un powerbook, o sea, arquitectura ppc i no i386 q hubiera sido muxo más facil.
creo q el problema radica en cuando compilo la libreria, no debe instalarse bien y el pkg-config no la ve.

pues gracias de nuevo.

por cierto el auto-apt no me lo deja instalar, creo q no lo encuentra en el ftp

+1
0
-1
Imagen de js.toledano
+1
0
-1

Bueno, en tal caso tal vez si intentas hacer lo que dice el mensaje de error.
Los programas que uno compila e instala, a menos que se indique otra cosa al momento de preparar los Makefile, se instalan en /usr/local

Por lo tanto, los archivos .pc se encuentran en la ruta /usr/local/lib/pkgconfig/

Podrías intentar agregar esa ruta a la variable PKG_CONFIG_PATH.

Claro primero verifica que dichos archivos existan.

Total que cuando termines de instalar el programa que quieres, tendrás mucha experiencia :)


SapoDriLo
Tlaxcala, México
+1
0
-1

En esta vida solo puedes tener dos cosas: razones y resultados.
Las razones no cuentan.

Imagen de Corso
+1
0
-1

debo decir que tengo exactamente el mismo problema.
si llegas a encontrar la solución anotala aquí si no es mucho problema.

el 1.2.0 no se ve aparentemente :(

+1
0
-1

:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:

Un Rincon Mas

Hoary Hedgehog&Dapper Drake mandan!!

:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:

Imagen de Corso
+1
0
-1

intenté configurar PKG_CONFIG_PATH (pomposo nombre para ser solo un archivo de texto en blanco)asignandole la ruta hacia el usr/local/lib/pkgconfig...donde está el requirements.pc...y tampoco funca,pero por el informe de error que da no parece buscar un archivo de texto sinó un paquete ejecutable (@requirements@.pc).
Locate @requirements@.pc....nada....ese paquete,no se porqué diablos o no se configura o en ubuntu no hay manera de que aparezca.

Observé la instalación del imlib2 y un error salta a la vista;no encuentra bzip2 instalado,aunque segun synaptic si lo está.Muchas fallas,creo que el error está en la compatibilidad de imlib2 y ubuntu(por algo no está en los repositorios hoary,mucho menos warty)y no creo que sea porque es muy nuevo que digamos.

Hay alguna esperanza de que lo incluyan algún día entre las continuas actualizaciones de hoary??.De esa manera significará que han logrado compatibilizarlos por completo.

dejo el log de "requirements.pc" por si alguien ha logrado instalar enlightenment 16.7 en ubuntu.

prefix=/usr/local
exec_prefix=${prefix}
libdir=/usr/local/lib
includedir=${prefix}/include

Name: imlib2
Description: Powerful image loading and rendering library
Requires: @requirements@
Version: 1.2.0
Libs: -L${libdir} -lImlib2
Cflags: -I${includedir}

+1
0
-1

:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:

Un Rincon Mas

Hoary Hedgehog&Dapper Drake mandan!!

:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:

Imagen de Corso
+1
0
-1

y he podido ver que bzip2 es una herramienta de descompresión...quizá el famoso @requirements@ no se descomprime al darle a ./configure del imlib2...el caso es que bajé el bzip2 en tar.gz,lo instalé sin problema,mas aún al reinstalar el imlib2 me sigue saliendo el mismo error "WARNING:***native bzip2 support will not be built(bzip2 library not found)***"
Mas adelante el configure lo vuelve a recalcar:

"Image loaders
JPEG....................: yes
PNG.....................: yes
TIFF....................: yes
GIF.....................: yes
ZLIB....................: yes
BZIP....................: no
Esto me hace suponer que el bzip actualizado es parte importante incluso para la instalación del enlightenment 16.7(en la propia web es uno de los requisitos indispensables).
Sigo intentando,saludos.

+1
0
-1

:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:

Un Rincon Mas

Hoary Hedgehog&Dapper Drake mandan!!

:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:

Imagen de Corso
+1
0
-1

navegando por ahí he encontrado un repositorio desde donde se pueden descargar e16.7 y librerías del e17.
Seguramente al faltarle varias librerías será cuestión de irlo acomodando con el tiempo pues de primera instalado,es bastante inestable(al menos para mi).

##Librerias E17 CVS
deb http://j.portalier.free.fr/debian testing main
deb-src http://j.portalier.free.fr/debian testing main

Mucha suerte!!!

+1
0
-1

:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:

Un Rincon Mas

Hoary Hedgehog&Dapper Drake mandan!!

:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:

Imagen de bull3tpr00f
+1
0
-1

Si te interesa instalar E17, en mi diario he creado un Howto.

Salu2
________________________________________
JabberID: cut0ff@jabberes.org
visita mi blog

+1
0
-1
Imagen de Corso
+1
0
-1

la .dev da demasiados problemas y le faltan muchas cosas así que a sudar un poco :D

Muchas gracias!!!

+1
0
-1

:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:

Un Rincon Mas

Hoary Hedgehog&Dapper Drake mandan!!

:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+:+: