No puedo instalar OpenOffice

Imagen de maxvall
0 puntos

Hola.

Descargue la nueva version de Openoffice (2.1) y desinstale la version que tiene instlada predterminadamente el Ubuntu. No se como instalar la suite, ya que solo tiene archivos RPM, y Ubuntu, si no me equivoco, usa paquetes DEB.
Ya se que tambien se puede instalar con el comando "sudo aptitude install openoffice.org" pero esto me instala la version 2.0 y YO QUIERO LA 2.1.
¿ALGUNA SOLUCION?

Imagen de Anónimo
+1
0
-1

Pues... podrías convertir el rpm en .deb... aunque a veces no es muy "limpio esto"

en los repositorios bajate "alien" te instalará varias chunches...

y en la consola sobre el directorio donde se encuentra el rpm ejecuta:

sudo alien --scripts archivo.rmp

y te creará el archivo.deb

es tardado pero FUNCIONA xD

Suerte... y que Tux te acompañe.

www.cyberneto.org .net .com

+1
0
-1
Imagen de Anónimo
+1
0
-1

Hola a todos.

Mira, yo no soy usuario de openOffice, soy de StarOffice, pero te dire que mi staroffice tambien viene con rpm, pero hay una solucion para instalarlo, al menos conmigo, y te aseguro que funciona perfectamente, carga el synaptic y busca " alien " sin comillas y instalalo,tambien puedes instalarlo desde un terminal con "sudo apt-get install alien" sin comillas, y despues de la instalacion ya puedes instalar los rpms..
Espero haberte ayudado...

Saludos... jorge

+1
0
-1
Imagen de Anónimo
+1
0
-1

Yo en la descarga veo que es un tar.gz, pero si os gusta más el alien...
¿Que tiene de imprescindible la versión 2.1?
_________________________
Mas información en...
el64.blogspot.com
_________________________
CUIDADO: NO COMPRES dispositivos con DRM.

+1
0
-1
Imagen de Anónimo
+1
0
-1

alien como dije no es la forma más límpia de instalarlo, preferible desde el tar.gz pero al consumidor lo que quiera... jajajaja.

En lo personal no veo GRAN cosa... lo mismo la 2 que la 2.000001.3.1 ;) del OpenOffice.

Suerte... y que Tux te acompañe.

www.cyberneto.org .net .com

+1
0
-1
Imagen de RagonichaFulva
+1
0
-1

Al menos tengo entendido que puede abrir bases de datos de access 2003, que con el 2.0 sólo puedes importarlas...

"La perseverancia es un árbol de raíces amargas, pero de frutos muy dulces."

+1
0
-1

"La perseverancia es un árbol de raíces amargas, pero de frutos muy dulces."

Imagen de tolesco
+1
0
-1

Saludos, yo te recomendaria instalar Openoffice.org desde un paquete .tar.gz, eso de convertir con Alien pues... si funciona, pero en algunas ocasiones como dijeron por ahi "no es muy limpio esto". Asi que, si no encontramos un .deb, instalar desde tar.gz es la mejor opcion. Desconozco si Openoffice.org venga precompilado (como en el caso de Firefox), en donde solo tenemos que ponerlo en el directorio /opt y crear los enlaces, si no es el caso, lo que tienes que hacer es bajar el tar.gz de Openoffice.org para luego compilar e instalar, lo puedes bajar desde:

http://es.openoffice.org/programa/index.html

Luego descomprimes y en terminal te vas al directorio descomprimido, una ves dentro usas el configure:

./configure

Si no te marca errores ni librerias faltantes:

make

Y para instalar:

make install

Openoffice.org deberia haberse instalado sin problemas, saludos.

+1
0
-1

Tolesco. JAx.

Imagen de RagonichaFulva
+1
0
-1

Yo lo he instalado con ALIEN, ya que al descomprimir el .tar.gz sólo encontraba archivos .rpm en una carpeta llamada, como no... RPM.

De momento va bien...

No sabía que con esos comandos podía instalar directamente desde .RPMs...

"La perseverancia es un árbol de raíces amargas, pero de frutos muy dulces."

+1
0
-1

"La perseverancia es un árbol de raíces amargas, pero de frutos muy dulces."

Imagen de Anónimo
+1
0
-1

Veo que alguno de este foro no está muy convencido con la conversión a -deb de los RPM con Alien. Yo, como novato intentaré hacer de la forma "correcta", pero a la hora de ejecutar

./configure

Me da un error como este:

bash: ./configure: No such file or directory

Y lo ejecuto en una carpeta donde tengo descomprimido el tar.gz

¿Qué hago mal?

+1
0
-1
Imagen de RagonichaFulva
+1
0
-1

Mi consejo -como no ;)- es que pruebes con ALIEN.

No he tenido el más mínimo problema de funcionamiento desde que escribí mi post.

Me gustaría que los detractores del sistema de instalación mediante ALIEN me explicaran los con más detalle el por qué es peor este sistema, ya que no soy experto en Linux y todo conocimiento es bienvenido.

"La perseverancia es un árbol de raíces amargas, pero de frutos muy dulces."

+1
0
-1

"La perseverancia es un árbol de raíces amargas, pero de frutos muy dulces."

Imagen de philips
+1
0
-1

Hola,

Yo he seguido los pasos descritos (alien -d, i dpkg -i) y parece que actualiza, pero al ejectuar openoffice (witer, database.... todos) se me habre la version antigua (2.0.4).
He probado desinstalando todo lo relacionado con openoffice desde synaptic i tampoco funciona.

PD.Intento instalar el archivo que trae el java incorporado.

Gracias

+1
0
-1
Imagen de RagonichaFulva
+1
0
-1

Instalaste el archivo que te integra OPENOffice en Gnome?

Has intentado abrir openoffice 2.1 desde consola? sería:

/etc/openoffice.org-2.1/share/xdg/base.desktop

para OO Base.

"La perseverancia es un árbol de raíces amargas, pero de frutos muy dulces."

+1
0
-1

"La perseverancia es un árbol de raíces amargas, pero de frutos muy dulces."

Imagen de RagonichaFulva
+1
0
-1

Hola Philips,

A ver... he intentado encontrar el link en el que me basé para realizar mi instalación, pero me temo que estaba en inglés.

http://trustworthy.net/blog/2007/01/openoffice-21-on-ubuntu/

En este enlace te habla de cómo instalar OPENOFFICE 2.1 en Ubuntu. No me gusta demasiado, ya que sólo habla de la instalación, no de la desinstalación del paquete de ofimática anterior.

http://zegnus.blogspot.com/2007/01/openoffice-210-para-ubuntu.html

Yo hice la desinstalación de mi OpenOffice antiguo mediante consola porque Synaptic no me lo hacía bien. Para ello te aconsejo el enlace en inglés que te comentaba más arriba:

http://trustworthy.net/blog/2007/01/openoffice-21-on-ubuntu/

Pero creo que el mejor enlace que puedes seguir es éste:

http://69.60.114.106/www.kubuntu-es.org/public_html/?q=node/1828

Es una instalación para Kubuntu, pero supone una síntesis de las webs que leí yo. Lo único que cambia es que en el paso en que hace la integración a tu escritorio, en lugar de realizarte la integración en KDE te realiza la integración en GNOME, pero a efectos prácticos el proceso será el mismo.

Por cierto, asegúrate de tener los repositorios Universe y Multiverse activados en sources.list (por si hace falta algo).

Oh! y no te hace falta bajarte OpenOffice con java, ya que ya tienes la máquina de Java instalada con el antiguo OpenOffice. Luego puede que al arrancar OpenOffice te pida que le digas la máquina de Java que ha de emplear, pero como te pone en un menú las que tienes para que elijas (sólo sale una, o al menos eso en mi Ubuntu), la seleccionas y listos. Ya no te preguntará más.

Descárgate OpenOffice desde este enlace (es el que usé yo):

http://openoffice.bouncer.osuosl.org/?product=OpenOffice.org&os=linuxint...

Y no te bajes el language pack. Es mejor que te instales los lenguajes (diccionarios) desde el asistente de OpenOffice una vez lo tengas instalado. Es más sencillo.

Si sigues estas instrucciones seguro que te funciona a las mil maravillas.

"La perseverancia es un árbol de raíces amargas, pero de frutos muy dulces."

+1
0
-1

"La perseverancia es un árbol de raíces amargas, pero de frutos muy dulces."

Imagen de philips
+1
0
-1

No me deja convertir a .deb por la arquitectura. Que no hay openoffice 2.1 para 64 bits :S?? Porque he mirado en la web de openoffice i solo hay una única version.

Esta es la párrafada pero vamos que el problema es por la arquitectura segun he entendido...

phil@phil-desktop:~/Desktop/OOE680_m6_native_packed-1_es.9095/RPMS$ fakeroot alien -d *.rpm
Package build failed. Here's the log:
dh_testdir
dh_testdir
dh_testroot
dh_clean -k -d
dh_installdirs
dh_installdocs
dh_installchangelogs
find . -maxdepth 1 -mindepth 1 -not -name debian -print0 | \
xargs -0 -r -i cp -a {} debian/openoffice.org-base
dh_compress
dh_makeshlibs
dh_installdeb
dh_shlibdeps
dpkg-shlibdeps: warning: format of `NEEDED libvcl680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libtl680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libsvt680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libsvl680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libsfx680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libcomphelp4gcc3.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libtk680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libutl680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libstlport_gcc.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libsvt680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libvcl680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libtl680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libsvl680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libsfx680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libdbtools680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libcomphelp4gcc3.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libstlport_gcc.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libsvx680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libsfx680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libsb680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libsvt680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libtk680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libvcl680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libgo680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libsvl680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libsot680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libutl680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libtl680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libucbhelper3gcc3.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libdbtools680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libcomphelp4gcc3.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libso680li.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libvos3gcc3.so' not recognized
dpkg-shlibdeps: warning: format of `NEEDED libstlport_gcc.so' not recognized
dpkg-shlibdeps: warning: could not find any packages for libuno_sal.so.3
dpkg-shlibdeps: warning: unable to find dependency information for shared library libuno_sal (soname 3, path libuno_sal.so.3, dependency field Depends)
dpkg-shlibdeps: warning: could not find any packages for libuno_cppu.so.3
dpkg-shlibdeps: warning: unable to find dependency information for shared library libuno_cppu (soname 3, path libuno_cppu.so.3, dependency field Depends)
dpkg-shlibdeps: warning: could not find any packages for libuno_cppuhelpergcc3.so.3
dpkg-shlibdeps: warning: unable to find dependency information for shared library libuno_cppuhelpergcc3 (soname 3, path libuno_cppuhelpergcc3.so.3, dependency field Depends)
dpkg-shlibdeps: warning: could not find any packages for libuno_cppuhelpergcc3.so.3
dpkg-shlibdeps: warning: unable to find dependency information for shared library libuno_cppuhelpergcc3 (soname 3, path libuno_cppuhelpergcc3.so.3, dependency field Depends)
dpkg-shlibdeps: warning: could not find any packages for libuno_cppu.so.3
dpkg-shlibdeps: warning: unable to find dependency information for shared library libuno_cppu (soname 3, path libuno_cppu.so.3, dependency field Depends)
dpkg-shlibdeps: warning: could not find any packages for libuno_sal.so.3
dpkg-shlibdeps: warning: unable to find dependency information for shared library libuno_sal (soname 3, path libuno_sal.so.3, dependency field Depends)
dpkg-shlibdeps: warning: could not find any packages for libuno_cppuhelpergcc3.so.3
dpkg-shlibdeps: warning: unable to find dependency information for shared library libuno_cppuhelpergcc3 (soname 3, path libuno_cppuhelpergcc3.so.3, dependency field Depends)
dpkg-shlibdeps: warning: could not find any packages for libuno_cppu.so.3
dpkg-shlibdeps: warning: unable to find dependency information for shared library libuno_cppu (soname 3, path libuno_cppu.so.3, dependency field Depends)
dpkg-shlibdeps: warning: could not find any packages for libuno_sal.so.3
dpkg-shlibdeps: warning: unable to find dependency information for shared library libuno_sal (soname 3, path libuno_sal.so.3, dependency field Depends)
dh_gencontrol
dpkg-gencontrol: error: current build architecture amd64 does not appear in package's list (i386)
dh_gencontrol: command returned error code 65280
make: *** [binary-arch] Error 1
find: openoffice.org-base-2.1.0: No existe el fichero ó directorio

Gracias!!

+1
0
-1
Imagen de RagonichaFulva
+1
0
-1

Vaya...

Pues tienes razón. efectivamente el problema está en la arquitectura de tu PC. Desgraciadamente no hay instaladores de OpenOffice para AMD64.

He visto este enlace:

http://www.badopi.org/node/669

La solución parece ser instalar a partir de los binarios.

Podrías mirar en los foros de OpenOffice o poner un mensaje a ver si te pueden ayudar si el enlace que te he pasado no te sirve.

"La perseverancia es un árbol de raíces amargas, pero de frutos muy dulces."

+1
0
-1

"La perseverancia es un árbol de raíces amargas, pero de frutos muy dulces."

Imagen de RagonichaFulva
+1
0
-1

Bueno... he mirado por ahi y creo que hay binarios para la versión de 32 bits (que funcionaría con tu PC) pero no para 64bits.

"La perseverancia es un árbol de raíces amargas, pero de frutos muy dulces."

+1
0
-1

"La perseverancia es un árbol de raíces amargas, pero de frutos muy dulces."

Imagen de Anónimo
+1
0
-1

-Descomprime el paquete
-Vas a la carpeta llamada "RPMS", ves qeu hay un monton.
-Te preguntaras...que hago yo con todos eso rpms?!?! bueno pues es muy sencillo...

Posicionate en esa carpeta con la consola y ejecuta como root:
rpm -Uvih *.rpm

Ahora entra en la carpeta llamada "desktop-integration",que esta dentro de la de RPMS,y busca el archivo de tu distro.Y lo instlas con el mismo comando de antes,pero esta vez sustituye el * por el nombre del archivo.Por ejemplo par amandriva sera:

rpm -Uvih openoffice.org-mandriva-menus-2.0.0-3.noarch.rpm

Ahora tendras el nuevo Openoffice en tu menu de programas con el resto ;)

+1
0
-1
Imagen de RagonichaFulva
+1
0
-1

Pero eso es igual que usar ALIEN. El problema aquí es que no coincide la arquitectura con los paquetes precompilados, ya que éstos están hechos para arquitectura de 32 bits.

"La perseverancia es un árbol de raíces amargas, pero de frutos muy dulces."

+1
0
-1

"La perseverancia es un árbol de raíces amargas, pero de frutos muy dulces."

Imagen de maxvall
+1
0
-1

Hola. Logre instalar el OpenOffice 2.1 en Ubuntu.

Lo primero que hice fue transformar los archivos RPM en DEB con el alien, y luego los instalé. EL unico problema que tenia era que al instlaar la integracion de debian, no me lo ponia en el menu. Este problema lo solucione de una forma muy sencilla: el problema era que estaba instalando un paquete de integracion de KDE, asi que desinstale todo, y lo volvi a instlar, sin ese paquete y EXITO!!!!!

+1
0
-1

Hasta la victoria siempre