Configuración Tarjeta TV (How-To)

+1
0
-1

Hace poco reinstalé Ubuntu y, para variar, tuve que volver a configurar la tarjeta de TV. Vuelta a los foros de ubuntu-es.org, sin embargo, esta vez no me funcionaba... El problema era simple; estaba situando el tipo de sintonizador en PAL cuando acá en Chile usamos NTSC. Pero más allá, el problema no estaba solo en mi ignorancia, sino en la gran cantidad de información desordenada que hay sobre este tema. Así que navegando encontré la documentación oficial de video4linux, donde hay una lista de los parámetros para el módulo bttv. Entonces, he aquí un pequeño how-to para configurar la tarjeta de TV, basado en mi humilde experiencia.

1.- Lo primero, agregar las fuentes debian en /etc/apt/sources.list:

deb ftp://ftp.rediris.es/debian/ unstable main contrib non-free
deb-src ftp://ftp.rediris.es/debian/ unstable main non-free contrib

2.- Obtener modconf:

$apt-get update
$apt-get install modconf

3.- Asegurarse de no tener cargado el módulo bttv:

$rmmod -f bttv

4.- Ejecutar modconf ($modconf) y cargar el módulo bttv, que se encuentra en el apartado kernel/drivers/media/video.

5.- Cuando pregunte sobre opciones adicionales para el módulo, colocar las opciones según el tipo de hardware que tengan.

(ejemplo) card=10 type=2

La lista de opciones se encuentra en esta dirección:

http://enpc3240.eas.asu.edu/lxr/linux/http/source/Documentation/video4li...

6.- Salir de modconf y ejecutar $scantv (en caso de ocupar XawTV). Si el sistema comienza a reconocer los canales, la configuración es correcta (es como obvio).

Con esto debiera funcionar la tarjeta... El sonido va a depender de cómo sea la conexión de audio en el PC, por ejemplo, mi tarjeta se conecta con un cable externo a la entrada de línea de mi controladora de audio. Al cargar por primera vez xawtv, me fui al control de volumen y subí el nivel en la entrada de línea. Después, al momento de cerrar el programa, automáticamente silenciará la entrada.

Espero que esto sirva... y contribuya a hacer un mundo más Ubuntizado... y feliz!

Comentarios

Imagen de Anónimo

hola al cargar el modulo bttv, puse el numero de tarjeta y el type le doy a enter y me da el siguiente error:

Instalando el módulo bttv. Si el dispositivo no existe, o no está configurado correctamente, podría suponer que su sistema se pausase hasta un minuto.

FATAL: Error inserting bttv (/lib/modules/2.6.10-5-386/kernel/drivers/media/video/bttv.ko): Unknown symbol in module, or unknown parameter (see dmesg)

Falló la instalación.

Imagen de Anónimo

en vez de poner type hay que sustituirlo por tuner

Imagen de kenmaster

quitar cualquier modulo bttv o saa7134

y

sudo modprobe -v saa7134 tuner=43 card=54

y instalar tvtime. en tvtime no sale la tv a menos que ponga composite2
en xawtv no me sale imagen, recordar que con antena es us-bro-... y con cable es us-cable

hasta aca todo ok

----------------------------------------------------------------
Blog http://kubuntu-chile.blogspot.com/
Descargas directas de Cedega, Crossover, Maya, Limewire pro y mas.

Imagen de Anónimo

He seguido todos tus pasos y como opciones he puesto "card=1 tuner=5" y en ningún momento consigo sintonizar nada, evidentemente el hard funciona pues en otras distribuciones y en windows ha funcionado sin ningún problema, el scantv sintoniza todos los canales sin encontrar nada.
Por cierto he tenido que poner la opción "scantv -C /dev/vbi0" ya que por defecto el vbi no lo tengo creado.

Alguna idea ???

Imagen de Anónimo

Hola, les cuento que logre hacer andar mi placa de tv, pero no puedo cambiar de canal cuando pongo el escaneo de canales pasan los numeros pero el canal siempre es el mismo, tengo una placa phoebe tv master + fm, pero no tengo idea del sintonizador que tiene, en windows me pasaba lo mismo pero el dscaler me permitia elegir el sintonizador asi que fui probando haste que me andubo el temic pal auto + fm, si alguien me puede ayudar o decirme como puedo configurar el sintonizador se lo voy a agradecer muchisimo, no pude hacer esto 3.- Asegurarse de no tener cargado el módulo bttv:

$rmmod -f bttv
me tiro el siguiente error :
ERROR: Removing 'bttv': Resource temporarily unavailable
asi que si hay otra forma de editarlo avisenme, gracias y aguante ubuntu!!!

Imagen de Anónimo

He instalado una vieja tarjeta de capturadora y sintonizadora de TV en mi PC. No tengo en /dev ningún dispositivo que señale a ese hardware. ¿Algunos de los pasos que sugieres crean algún dispositivo allí?
Algo más, la tarjeta de video es marca Genius (modelo Video Wonder Pro TV II). En la lista de hardware no hay listada ninguna tarjeta Genius, ni siquiera el hardware más nuevo de esa empresa. ¿Sabes de alguna equivalencia como para poner en "opciones adicionales"?

Imagen de rookie

A ver si alguien me puede hechar un cable. Me pasa una cosa muy curiosa. Tengo la pinnacle PCTV funcionando con el bttv. Tengo el kernel 2.6.15 y no he tenido que instalar modulos, lo tenía recompilado con los modulos cargados. Os copio lo que me devuelve el dmesg:
bttv: Bt8xx card found (0).
ACPI: PCI Interrupt 0000:04:05.0[A] -> GSI 20 (level, low) -> IRQ 217
bttv0: Bt878 (rev 17) at 0000:04:05.0, irq: 217, latency: 32, mmio: 0xf45ff000
bttv0: detected: Pinnacle PCTV [card=39], PCI subsystem ID is 11bd:0012
bttv0: using: Pinnacle PCTV Studio/Rave [card=39,autodetected]
bttv0: gpio: en=00000000, out=00000000 in=00ffffff [init]
bttv0: i2c: checking for MSP34xx @ 0x80... not found
bttv0: pinnacle/mt: id=1 info="PAL / mono" radio=no
bttv0: using tuner=33
bttv0: i2c: checking for MSP34xx @ 0x80... not found
bttv0: i2c: checking for TDA9875 @ 0xb0... not found
bttv0: i2c: checking for TDA7432 @ 0x8a... not found
Real Time Clock Driver v1.12
input: PC Speaker as /class/input/input1
tda9887 1-0043: chip found @ 0x86 (bt878 #0 [sw])
tuner 1-0060: Chip ID is not zero. It is not a TEA5767
tuner 1-0060: chip found @ 0xc0 (bt878 #0 [sw])
tuner 1-0060: microtune: companycode=4d54 part=04 rev=04
tuner 1-0060: microtune MT2032 found, OK
bttv0: registered device video0
bttv0: registered device vbi0
bttv0: PLL: 28636363 => 35468950 .<6>mice: PS/2 mouse device common for all mice
. ok
bt878: AUDIO driver version 0.0.0 loaded
bt878: Bt878 AUDIO function found (0).
ACPI: PCI Interrupt 0000:04:05.1[A] -> GSI 20 (level, low) -> IRQ 217
bt878(0): Bt878 (rev 17) at 04:05.1, irq: 217, latency: 32, memory: 0xf45fe000
saa7130/34: v4l2 driver version 0.2.14 loaded
saa7134 ALSA driver for DMA sound loaded
saa7134 ALSA: no saa7134 cards found

Mi problema es, aunque parezca increible, que el sonido, no me funciona bien, capturo todos los canales, pero solo oigo tve1 y tve2, el resto no los oigo, solo ruido. Se os ocurre alguna solucion?? Gracias de antemano.

Imagen de Anónimo

En los kernels mas recientes se debe añadir el tipo de sintonizador con el parametro tuner y no con type
Yo por ejemplo tengo una pixel view play tv pro con un sintonizador temic ntsc que no tiene radio asi que los parametros serian asi
(ejemplo) card=37 tuner=6 radio=0

si por alguna extraña razon no se descarga el moduo con
rmmod -f bttv
como en mi caso me decia que erea porque estaba siendo usado por otro modulo el bt878
asi que primero debi hacer
rmmod -f bt878

Imagen de IkEr

Tengo un problema es k cuando intento instalar el modconf de los repositorios me da l siguiente error:

iker@IkEr:/$ apt-get install modconf
E: No se pudo abrir el fichero de bloqueo '/var/lib/dpkg/lock' - open (13 Permiso denegado)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
iker@IkEr:/$ sudo apt-get install modconf
Leyendo lista de paquetes... ¡Error!
E: Dynamic MMap ran out of room
E: Ocurrió un error mientras se procesaba xterm (NewVersion1)
E: Problem with MergeList /var/lib/apt/lists/ftp.rediris.es_debian_dists_unstable_main_binary-i386_Packages
E: No se pudieron analizar o abrir las listas de paquetes o el archivo de estado.

Espero k podais ayudarme, Gracias.

Saludos