Instalación de lm-sensors

Imagen de herje
0 puntos

Imposible hacer funcionar lm_sensors por ahora. He instalado lm-sensors, i2c está soportado en nucleo, pero lo que no he encontrado es el paquete i2c que creo que hace falta también.
Al hacer una busqueda en las fuentes me tira esto:

------------------
root@platas /home/herje # apts i2c
eep24c - read and write serial I2C eeprom devices
gdesklets-data - displays and sensors for gdesklets
kernel-patch-2.4-i2c - Drivers for the i2c bus
libglui2c102 - GLUI, a C++ GLUT based GUI library - runtime support
lm-sensors - Utilities to read temperature/voltage/fan sensors
sensord - Hardware sensor information logging daemon
smartcard - A smartcard utility for Linux
wmgtemp - Temperature sensor dockapp for Window Maker
xml-rpc-api2cpp - Generate C++ wrapper classes for XML-RPC servers.
root@platas /home/herje #
------------

De todos modos he tratado de correr "sensors-detect" y me dice lo siguiente:

-------------
root@platas /home/herje # sensors-detect
No i2c device files found. Use prog/mkdev/mkdev.sh to create them.
root@platas /home/herje #
-------------

El caso es que he visto Googleando que debía también añadir la linea "/usr/local/lib" al fichero /etc/ld.so.conf y tanbién está hecho, pero si trato de correr el dichoso "prog/mkdev/mkdev.s" o "prog/mkdev/mkdev.s" me da por respuesta "No existe el fichero o el directorio" y efectivamente haciendo un "locate" tras updatear la db no existe.

¿Será simplemente que me falta el paquete i2c?

Las fuentes que tengo en Ubuntu son las siguientes:

-------------
deb http://archive.ubuntu.com/ubuntu warty main restricted
deb-src http://archive.ubuntu.com/ubuntu warty main restricted
deb http://archive.ubuntu.com/ubuntu warty universe multiverse
deb-src http://archive.ubuntu.com/ubuntu warty universe multiverse

deb http://security.ubuntu.com/ubuntu warty-security main restricted

deb-src http://security.ubuntu.com/ubuntu warty-security main restricted

(las lineas seguidas, claro está)
-----------------------

¿Alguna idea?

Imagen de herje
+1
0
-1

Corriendo con:

Linux platas 2.6.8.1-3-686-smp #1 SMP Tue Oct 12 13:40:26 BST 2004 i686 GNU/Linux

Un PIV a 3.4 Ghz procesador SMP

Saludos
Herje
http://www.herje.com

+1
0
-1

Saludos
Herje
http://www.herje.com

Imagen de insulae
+1
0
-1

te paso un howto que parece estar bueno: http://www.ubuntuforums.org/showthread.php?t=2780&highlight=sensor yo estoy con el mismo problema, esta tarde voy a probar este how to asi que no se si funciona, si queres ir probando vos, aca lo tenes, saludos y espero que funcione!!

insulae

LO HE PROBADO AL TUTORIAL, Y BARBARO, FUNCIONA BIEN EL LMSENSORS DE LA FORMA EXPLICADA, AUNQUE EN MI MOTHER TUVE UN PROBLEMILLA CON SOLUCION, EL QUE TENGA UNA MSI K7N2 DELTA U OTRA CON CHIPSET NFORCE2 QUE NO PUEDA HACER FUNCIONAR ME PREGUNTA insulae at gmail . com

+1
0
-1

Juan Matias Granda
http://www.insulae.com.ar