No me lo puedo creer, no arranca el entorno gráfico

Imagen de salvared
0 puntos

Estoy verdaderamente desesperado. Actualice de Ubuntu 6.06 a 6.10 sin el mas absoluto problema. Instale Beryl y el escritorio en 3d sin ningún problema. He reinciado varias veces el ordenador y todo siempre ha ido sobre ruedas, pero hoy sin ninguna explicación tras un corte de luz he vuelto a encender el ordenador y las X no se pueden cargar y no se inicia el entorno gráfico. He intentado sin ningún éxito realizar la instrucción "sudo dpkg-reconfigure xserver-xorg" he intentado modificar de nvidia, que es la tarjeta que tengo instalada con sus driver correspondientes y aceleracion gráfica, ha "nv" y a "vesa" pero nada no hay ningún resultado.
Ruego me echeis una mano ya que he instalado desde el principio Ubuntu cuatro veces, esta vez iba todo estupendamente y tengo mucha información importantísima que no puedo borrar. ¡Ayuda! y gracias anticipadas.

*********************************
Te muevo al Foro Correspondiente.
Gracias por tu comprensión.
Editado por dracool.
*********************************

Imagen de BXS1001
+1
0
-1

Hazme un favor, pega si puedes tu xorg.conf lo encontrarás en /etc/X11/xorg.conf

Creo que es un tema de resoluciones.
¿Qué mensaje te da cuando intentas ejecutar el comando startx?
Un saludo

Descubriendo Linux día a día.
Day after day, discovering Linux

+1
0
-1

Descubriendo Linux día a día.
Day after day, discovering Linux

Imagen de salvared
+1
0
-1

Ante todo muchas gracias por tu ayuda. Al realizar la operación startx me da estos errores:
/usr/bin/startx: line 132:nose puede crear archivo temporal para este documento: Sistema de solo lectura
xauth: error in locking authority file /home/salvared/-xaurthority
/usr/bin/startx:line 144: (aqui me dice lo mismo que en la primera liena)

Fatal server error:
Could not create lock file in /tmp/..tx0-lock

Giving up.
xinit: Connection refused (erno 111):unable to connect to X server
xinit: No such process (erno 3): Server error.
xauth: error in licking authority file /home/salvared/.Xauthority

Nuevamente muchisimas gracias por tu ayuda.

+1
0
-1
Imagen de BXS1001
+1
0
-1

Esta es la única solución que he encontrado googleando y encima en Ruso

IF this server is no longer running, remove /tmp/.X0-lock and start again

Trata de borrar el .x0-lock y busca el ..tx0-lock y reinicia. A ver si hay suerte.

Cuentame más cosas si esto no va.

Descubriendo Linux día a día.
Day after day, discovering Linux

+1
0
-1

Descubriendo Linux día a día.
Day after day, discovering Linux

Imagen de salvared
+1
0
-1

Al realizar "rm /tmp/.x0-lock", me dice que no se puede realizar ya que no existe directorio o el fichero. :-(

+1
0
-1
Imagen de BXS1001
+1
0
-1

Prueba con esto

$ sudo rm /tmp/..tx0-lock

o bien

$ sudo rm /tmp/.tx0-lock (Es un 0 no una o)

Descubriendo Linux día a día.
Day after day, discovering Linux

+1
0
-1

Descubriendo Linux día a día.
Day after day, discovering Linux

Imagen de salvared
+1
0
-1

Pues no va, ya que dice que el fichero no existe. Lo he puesto con uno y con dos puntos y da el mismo mensaje. Se resiste el asunto.

+1
0
-1
Imagen de salvared
+1
0
-1

Pero si lo pongo "sudo rm /tmp/.X0.lock" me dice que es un sistema solo de lectura. :-o

+1
0
-1
Imagen de BXS1001
+1
0
-1

No! No!, Fíjate bien

necesitas borrar esto

$ sudo rm /tmp/..tx0-lock

o bien

$ sudo rm /tmp/.tx0-lock

y tu tratas de borrar

$ sudo rm /tmp/.X0.lock

¡Ese es otro fichero!. También te he puesto abajo una "sulusión" para bajar la resolución de momento de las X. Luego la volveremos a acelerar y a subir.

No decaigas... hay que seguir hasta el final. Por mis muelas que la arrancamos.

Descubriendo Linux día a día.
Day after day, discovering Linux

+1
0
-1

Descubriendo Linux día a día.
Day after day, discovering Linux

Imagen de salvared
+1
0
-1

Pongo las instrucciones que me indicas y me dice que el fichero no existe. "sudo rm /tmp/.tx0-lock" y también con ..tx0-lock. Se resiste el puñetero modo gráfico. Lo que tampoco entiendo es por que no me deja de modificar xorg.conf, en otras ocasiones con 6.06 lo he hecho y sin problema. Esto es un poco caótico.

+1
0
-1
Imagen de salvared
+1
0
-1

#nvidia-xconfig: X configuration file generated by nvidia-xconfig
#nvidia-xconfig: version 1.0 (buildmeister"builder3) Fri Dec 15 10:12:14 PS$
# /etc/X11/xorg.conf (xorg X Window System server
configuration file)
#
# This file was generated by dexconf, the Debian X
Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf
manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package
upgrades *only*
# if it has not been modified since the last upgrade of the
xserver-xorg
# package.
#
# If you have edited this file but would like it to be
automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
EndSection

Section "Files"
# path to defoma fonts
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/cyrillic"
FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/usr/share/X11/fonts/100dpi"
FontPath "/usr/share/X11/fonts/75dpi"
FontPath "/usr/share/fonts/X11/misc"
FontPath:"/var/lib/defomax-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "es"
Option "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
# /dev/input/event
# for USB
Identifier "stylus"
Driver "wacom"
Option "Device" "/dev/wacom" # Change to
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet
PC ONLY
EndSection

Section "InputDevice"
# /dev/input/event
# for USB
Identifier "eraser"
Driver "wacom"
Option "Device" "/dev/wacom" # Change to
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet
PC ONLY
EndSection

Section "InputDevice"
# /dev/input/event
# for USB
Identifier "cursor"
Driver "wacom"
Option "Device" "/dev/wacom" # Change to
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet
PC ONLY
EndSection

Section "Monitor"
Identifier "DELL E171FPb"
Option "DPMS"
EndSection

Section "Device"
Identifier "NVIDIA Corporation NV34 [GeForce FX
5200]"
Driver "nvidia"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "NVIDIA Corporation NV34 [GeForce FX
5200]"
Monitor "DELL E171FPb"
DefaultDepth 24
Oprion "AddARGBGLXVisuals" "True"
SubSection "Display"
Depth 1
Modes "1280x1024" "1152x864"
"1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x1024" "1152x864"
"1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1152x864"
"1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024" "1152x864"
"1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1152x864"
"1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1152x864"
"1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
EndSubSection

Y esto es todo, perdona que no lo halla mandado antes pero lo he tenido que realizar a mano.
EndSection

+1
0
-1
Imagen de BXS1001
+1
0
-1

Guarda una copia de seguridad de tu xorg.conf antes de hacer esto.

Bien, si después de aplicar la solución que te he dado sigue sin arrancar, vamos a probar a bajar la resolución.

Log como Root
$ nano /etc/X11/xorg.conf

Busca lo siguente

Section "Device"
Identifier "NVIDIA Corporation NV34 [GeForce FX
5200]"
Driver "nvidia"
EndSection

sustitúyelo por esto

Section "Device"
Identifier "NVIDIA Corporation NV34 [GeForce FX
5200]"
Driver "nv"
EndSection

Vale con esto nos cargamos el Driver acelerado. Ahora vamos a darle una resolución más baja para ver si conseguimos arrancar aunque sea bajo mínimos.

Busca en la sección "Screen" esto:

Depth 24
Modes "1280x1024" "1152x864"
"1280x1024" "1152x864" "1024x768" "800x600" "720x400" "640x480"
EndSubSection

Substituyelo por esto:

Depth 24
Modes "1024x768" "800x600"
EndSubSection

Con esto reducimos la resolución que usará el monitor.

Ctrl + O para guardar, Ctrl + X para cerrar
$ reboot

La máquina se "rebotará" y te debe arrancar... Si quieres prueba startx, pero... Y si hay algún módulo que se ha quedado atontado y requiere releer el xorg.conf... por eso prefiero reboot.

Dime si no te pirula. Seguiremos dándole hasta que lo consigamos... Estamos cerca... lo presiento :-D

Descubriendo Linux día a día.
Day after day, discovering Linux

+1
0
-1

Descubriendo Linux día a día.
Day after day, discovering Linux

Imagen de salvared
+1
0
-1

No lo entiendo para nada. Cuando intento modificar xorg.conf "nano /etc/X11/xorg.conf" me dice que error que el sistema es solo de lectura. ¡No lo entiendo!

+1
0
-1
Imagen de BXS1001
+1
0
-1

Mmm.. Esto se nos está resistiendo.
Bien. Asegúrate de que estás logeado como ROOT. No fuese a ser que intentaras escribir como usuario.

Si estás como ROOT, mira los atributos del fichero a ver si está como solo lectura. Si no sabes como mirarlo, avísame y te lo miro.

Arríba te he puesto una apreciación sobre el fichero que tratabas de borrar. Escribías mal el nombre.

Descubriendo Linux día a día.
Day after day, discovering Linux

+1
0
-1

Descubriendo Linux día a día.
Day after day, discovering Linux

Imagen de BXS1001
+1
0
-1

Prueba el comando

$ sudo chmod (nombre fichero) -rw

Esto es para convertir al fichero en cuestión de lectura y escritura. ¿Cómo va la operación? Me tienes en vilo!.

Descubriendo Linux día a día.
Day after day, discovering Linux

+1
0
-1

Descubriendo Linux día a día.
Day after day, discovering Linux

Imagen de salvared
+1
0
-1

He reiniciado el ordenador en modo root. En el directorio /etc/X11/ he puesto la instrucción chmod xorg.conf -rw y la respuesta que me da es que es un fichero solo de lectura. Esto es frustante.

+1
0
-1
Imagen de BXS1001
+1
0
-1

Vaya!. Pues no sabría darte una solución ahora. Estoy en el trabajo y no tengo mi linux a mano. Espero esta noche meterme en consola, ver como está mi xorg.conf y rebuscar algo más. Dame unas horitas y veo que puedo hacer por ti. Te paso mi correo para que no creas que me despisto de esto. dir_general@spantax.org

Esta noche buscaré en casa a ver porque sucede esto. También buscaré en la biblia de Ubuntu a ver si dice algo.

Descubriendo Linux día a día.
Day after day, discovering Linux

+1
0
-1

Descubriendo Linux día a día.
Day after day, discovering Linux

Imagen de BXS1001
+1
0
-1

De todas maneras... Prueba al arrancar a intentar modificar el xorg.conf pero arrancando desde modo de recuperación, no con el kernel usual, sino con el de recuperación.
Arrancarás solo en consola.
Modifica el fichero y reboot

a ver que pasa... Es una prueba.

Descubriendo Linux día a día.
Day after day, discovering Linux

+1
0
-1

Descubriendo Linux día a día.
Day after day, discovering Linux

Imagen de salvared
+1
0
-1

Si eso es lo que hice por eso estoy en root y no me da opción de modificación. Mañana seguire intentandolo, por que yo también tengo que trabajar pero mañana y bien tempranito. Muchisimas gracias por tu ayuda y mañana tarde leere tus sugerencias para ver si esto llega a funcionar. Saludos.

+1
0
-1
Imagen de BXS1001
+1
0
-1

Haré lo que pueda, y si no lo conseguimos... Llamaremos a los supertacañones.

Descubriendo Linux día a día.
Day after day, discovering Linux

+1
0
-1

Descubriendo Linux día a día.
Day after day, discovering Linux

Imagen de salvared
+1
0
-1

Buenos dias, he estado recapitulando desde cuando y por que tengo este problema y pienso que puede ser solo un problema de permisos que bien no se como resolver.
Antes de ayer tenia un problema al pasar archivos de mi ordenador a un disco duro externo que tengo, ya que me decia que era solo de escritura, por lo que decidí poner un post para ver si me daban alguien alguna solución (este es el hilo http://www.ubuntu-es.org/index.php?q=node/39863), entonces seguía alguna de las recomendaciones y me di cuenta que no me dejaba ni siquiera de reiniciar el equipo. En el escritorio al dar al icono de apagar no daba ninguna respuesta y al intentar hacer "reboot" desde el terminal este no se ejecutaba, por lo que decidí apagar y reiniciar manualmente. Y es esa la situación en la que me encuentro. Ante todo quiero darte las gracias por tu paciencia y tu ayuda, que aunque no haya dado frutos (aun) me esta sirviendo para entender mas, debido a mi novatez, linux y mas concretamente Ubuntu. Gracias.

+1
0
-1
Imagen de nael
+1
0
-1

Tomando en cuenta que no puedes escribir el archivo xorg.conf, además del mensaje:
Fatal server error:
Could not create lock file in /tmp/..tx0-lock

y que el problema se inició con un mal cierre del sistema... cabe preguntar: ¿has corrido un fsck para ver el estado de la partición de sistema?
Otra: al ejecutar "mount", ¿aparece la partición correspondiente con permiso de escritura?

+1
0
-1
Imagen de salvared
+1
0
-1

Primeramente gracias por tu ayuda. Al realizar la operación "mount" la respuesta del oredandor es:
/dev/hda1 on / type ext3 (rw, errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
/sys on /sys type sysfs (rw,noexec,nosuid,nodev)
varrum on /var/run type tmpfs (rw,noexec,nosuid,nodev,mode=0755)
varlock on /var/lock type tmpfs (rw,noexec,nosuid,nodev,mode=1777)
procbususb on /proc/bus/usb type usbfs (rw)
udev on /dev type tmpfs (rw,mode=0755)
devshm on /dev/shm type tmpfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
lrm on /lib/modules/2.6.17-11.generic/volatile type tmpfs (rw)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
/dev/sda1 on /media/LACIE type vfat (rw,nosuid,nodev,quiet,shortname=mixed,unid=1
000,gid=1000,umask=077,iocharset=utf8)

Eso es lo que me sale. Gracias por tu ayuda.

+1
0
-1
Imagen de salvamir
+1
0
-1

Prueba desde consola a forzar la comprobación del sistema de ficheros:
sudo e2fsck /dev/hdb1 (donde hdb1 es la partición de tu disco duro en donde está Ubuntu.

Saludos.
Hemos venido a pasar el rato

+1
0
-1

Saludos.
Hemos venido a pasar el rato

Imagen de salvared
+1
0
-1

Gracias ante todo, con hdb1 me da errores al hacer hdba1 me dice:
e2fsck 1-39 (29-May-2006)
/dev/hda1:clean, 175271/14467072 files, 23950927/28927032 blocks

Pero tanto si reinicio, como cuando intento modificar xorg.conf, sigue dandome los mismos errores, no arranca las X y al intentar modificar xorg me dice que es solo de lectura. Gracias.

+1
0
-1
Imagen de salvamir
+1
0
-1

Mucho mas no entiendo, pero igual hay un error irreparable en el sistema de archivos. A ver si algien con más conocimientos nos ayuda.
¿Que haría yo? Colocar el CD/DVD de instalación y actualizar (sin borrar).
Saludos.
Hemos venido a pasar el rato

+1
0
-1

Saludos.
Hemos venido a pasar el rato

Imagen de kavra
+1
0
-1

El problema de no poder editar el fichero xorg.conf posiblemente se deba a un reinicio del sistema cuando te encontrabas editandolo. Se crean unas copias de respaldo del mismo con atributos de oculto haciendo imposible la edición del original. Lo que debes hacer es buscar las copias de respaldo, están en la misma carpeta pero como archivos ocultos, borrarlas y editar el archivo de configuración. el nombre de los archivos te lo dice cuando te da el mensaje de que no puedes editar el archivo, de todas formas borra todo lo que esté oculto en ese directorio (/etc/X11) y a correr.

"El pueblo que está dispuesto a cambiar su libertad por seguridad no merece ninguna de las dos" Benjamín Franklin
http://www.karnekruda.blogspot.com

+1
0
-1

____________________
Anarquía != Desorden

Imagen de salvared
+1
0
-1

Ante todo muchas gracias, pero perdona mi inexperiencia ¿como puedo ver o saber cuales son estos archivos ocultos?. Me da miedo de borrar algo que sea importante. Nuevamente muchas gracias, kavra.

+1
0
-1
Imagen de kavra
+1
0
-1

ls -a

"El pueblo que está dispuesto a cambiar su libertad por seguridad no merece ninguna de las dos" Benjamín Franklin
http://www.karnekruda.blogspot.com

+1
0
-1

____________________
Anarquía != Desorden

Imagen de salvared
+1
0
-1

Gracias kavra, lo intentara esta tarde dado que ahora no estoy donde tengo mi ordenador personal. Gracias nuevamente y ya te diré si me ha funcionado.

+1
0
-1
Imagen de salvared
+1
0
-1

Ya estoy en casa y he probado lo que me decias los dos únicos archivos que me salen diferentes con la instrucción "ls -a" con respesto a "ls" son "." y ".." cuando hago "sudo rm .", o "sudo rm .." me dice que el archivo no se puede borrar. Concretamente estos son los archivos que me salen en el directorio /etc/X11: En azul: .,..,app-defaults, cursors,fonts,xinit,xkb,Xresources y Xsession. En blanco: default-display-manager, rgb.txt, xorg.conf,xorg-conf-backup, xorg.conf.backup.beryl-script, Xsession.options,XvMCConfig y Xwrapper.config. En zul claro: gdm y X. Y en verde: Xsession.
¿Que debo de borrar? ¿Que le pasa al ordenador? La verdad es que cada vez lo entiendo menos. Gracias y un saludo.

+1
0
-1
Imagen de kavra
+1
0
-1

Ok. Dentro de /etc/X11 logeate como root y edita el archivo xorg.conf con el comando vi

#vi /etc/X11/xorg.conf

Una vez dentro del archivo tienes que pulsar la tecla "a" para editar, con los cursores te mueves, modificas lo que necesites, tecla "Esc" para salir del modo edición, tecla ":" para pasarle parámetros al entorno, tecla "w" para guardar los cambios en el archivo, "enter", tecla ":" para pasarle parámetros al entorno, tecla "q" para salir, "enter" y ya lo tienes modificado.

"El pueblo que está dispuesto a cambiar su libertad por seguridad no merece ninguna de las dos" Benjamín Franklin
http://www.karnekruda.blogspot.com

+1
0
-1

____________________
Anarquía != Desorden

Imagen de salvared
+1
0
-1

Al terminar de modificar y realizar : w, me dice "E45: 'readonly' option is set (add ! to override) y cuando hago : q me dice E37: No write since lasta chage (add ! to override). Y no me ha grabado nada. Esto es desesperante, no hay una sola instrucción que me deje modificar xorg.conf.

+1
0
-1
Imagen de kavra
+1
0
-1

¿Eres root?

"El pueblo que está dispuesto a cambiar su libertad por seguridad no merece ninguna de las dos" Benjamín Franklin
http://www.karnekruda.blogspot.com

+1
0
-1

____________________
Anarquía != Desorden

Imagen de salvared
+1
0
-1

Lo realicé con la instrucción sudo -i, creo que con eso debería haber valido. ¿Es así?

+1
0
-1
Imagen de kavra
+1
0
-1

Debería, pero logeate como root para hacer las operaciones por si acaso.
Si sigue sin dejarte, continua como root y ejecuta dpkg-reconfigure xserver-xorg

Otra opción si lo anterior falla es cepillarte el xorg.conf
rm -f /etc/X11/xorg.conf
edita con vi el archivo xorg.conf.bak
vi /etc/X11/xorg.conf.bak
cuando lo guardes al escribir "w" añade el nombre nuevo del archivo xorg.conf-------> :w xorg.conf

"El pueblo que está dispuesto a cambiar su libertad por seguridad no merece ninguna de las dos" Benjamín Franklin
http://www.karnekruda.blogspot.com

+1
0
-1

____________________
Anarquía != Desorden

Imagen de salvared
+1
0
-1

Cuando realizo la opcion dpkg-reconfigure xserver-xorg, he cambiado "nvidia" por "nv" y la resolución la he puesto 1024x768 y 800x600, pues nada me dice:"cp: caonnot create regular file '/etc/X11/xorg.conf.20070310181157' Read-only file system" y cuando intento cepillarme la xorg.conf, me dice prácticamente lo mismo: "rm: cannot remove '/etc/X11/xorg.conf': Read-only file system". Gracias por tu paciencia, aunque yo estoy ya que me subo por las ramas, pero bueno no voy a desfallecer.

+1
0
-1
Imagen de kavra
+1
0
-1

mmmmm..extraño e interesante a la vez.
Dime el contenido que te da ls -a /etc/X11
Dime el contenido del archivo /etc/fstab y del archivo /etc/mtab
Doy por sentado que eres root.

"El pueblo que está dispuesto a cambiar su libertad por seguridad no merece ninguna de las dos" Benjamín Franklin
http://www.karnekruda.blogspot.com

+1
0
-1

____________________
Anarquía != Desorden

Imagen de salvared
+1
0
-1

El contenido de /etc/X11 te lo indiqué antes pero te lo vuelvo a reproducir:
En azul: .,..,app-defaults, cursors,fonts,xinit,xkb,Xresources y Xsession. En blanco: default-display-manager, rgb.txt, xorg.conf,xorg-conf-backup, xorg.conf.backup.beryl-script, Xsession.options,XvMCConfig y Xwrapper.config. En zul claro: gdm y X. Y en verde: Xsession.

En /etc/fstab:
# /etc/fstab: static file system information.
#
#
proc /proc proc default 0 0
# /dev/hda1
UUID=655176a0-054c-4c1b-be48-e9f244ee7e18 / ext3 default, error$
# /dev/hda5

UUID=28d95678-af63-431f-a707-17243c7e4624 none swap sw $
/dev/hdc /media/cdrom0 udf,iso9660 user,nonauto 0 0
/dev/hdd /media/cdrom1 udf,iso9660 user,nonauto 0 0

Y por último en /etc/mtab
/dev/hda1 / ext3 rw,errors=remount-ro 0 0
proc /proc proc rw,noexec,nosuid,nodev 0 0
/sys /sys sysfs rw,noexec,nosuid,nodev 0 0
varrun /var/run tmpfs rw,noexec,nosuid,nodev,mode=0755 0 0
varlock /var/lock tmpfs rw,noexec,nosuid,nodev, mode=1777 0 0
procbususb /proc/bus/usb usbfs rw 0 0
udev /dev tmpfs rw,mode=0755 0 0
devshm /dev/shm tmpfs rw 0 0
devpts /dev/pts devpts rw,gid=5,mode=620 0 0
lrm /lib/modules/2.6.17-11-generic/volatile tmpfs rw 0 0
binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc rw 0 0
/dev/sda1 /media/LACIE vfat rw,nosuid,nodev,quiet,shortname=mixed,uid=1000,gid=$

Y eso es todo. Para mi que a lo mejor solo es un problema de permisos, que bien no se como solucionar.

+1
0
-1
Imagen de kavra
+1
0
-1

Vamos a encerrar el problema.
Intenta editar el archivo /etc/fstab con el comando vi y sustituye la línea

UUID=655176a0-054c-4c1b-be48-e9f244ee7e18 / ext3 default, error$

por

UUID=655176a0-054c-4c1b-be48-e9f244ee7e18 / ext3 default, errors=remount-ro 0 1

guarda el archivo (si nos deja), ejecuta mount -a y vuelve a intentar editar xorg.conf

"El pueblo que está dispuesto a cambiar su libertad por seguridad no merece ninguna de las dos" Benjamín Franklin
http://www.karnekruda.blogspot.com

+1
0
-1

____________________
Anarquía != Desorden

Imagen de salvared
+1
0
-1

Kavra, perdona al ponerte el archivo fstab yo lo vi ejecutando la opción "nano" y claro la linea de UUID que al final ponia "error$" quería decir que ya no cabían mas campos, cuando la he editado con "vi" estaba correcta con la edición que tu me dabas "errors=remount-ro 0 1". De todas formas he realizado "mount -a" y he intentado de editar xorg.conf y nada dice que es un archivo de solo escritura :-(

+1
0
-1
Imagen de kavra
+1
0
-1

Intenta editar el archivo de todas formas, añadele basura en las lineas comentadas e intenta salvarlo, quiero ver si puedes editarlo o tambien da problemas.

"El pueblo que está dispuesto a cambiar su libertad por seguridad no merece ninguna de las dos" Benjamín Franklin
http://www.karnekruda.blogspot.com

+1
0
-1

____________________
Anarquía != Desorden

Imagen de salvared
+1
0
-1

Al hacer el intento de edición me dice lo mismo que cuando lo intente la otra vez (es que realmente no he podido realizar ninguna nueva operación)o sea al terminar de modificar y realizar : w, me dice "E45: 'readonly' option is set (add ! to override) y cuando hago : q me dice E37: No write since lasta chage (add ! to override)

+1
0
-1
Imagen de kavra
+1
0
-1

intenta crear o editar algún archivo en /home/tuusuario y cuentame el resultado. Si no eres capaz de crear o editar ahí tenemos un problema en el montaje de la unidad. Deberemos entrar en el modo safemode y comprobar que es lo que falla.

"El pueblo que está dispuesto a cambiar su libertad por seguridad no merece ninguna de las dos" Benjamín Franklin
http://www.karnekruda.blogspot.com

+1
0
-1

____________________
Anarquía != Desorden

Imagen de salvared
+1
0
-1

Efectivamente no he sido capaz ni de crear ni de modificar. ¿Que debería entonces hacer?.

+1
0
-1
Imagen de kavra
+1
0
-1

Existe un problema al montar el sistema de ficheros, cuando aparece el grub tienes una opción en la que aparece (recovery mode) utilizala.
Llegará un momento en el que te pedirá pulsar Control-D o el pass del root para continuar...utiliza el pass del root y vamos a trabajar desde ahí.
Entra en nuestro perseguido directorio y prueba a editarlo ahora.

"El pueblo que está dispuesto a cambiar su libertad por seguridad no merece ninguna de las dos" Benjamín Franklin
http://www.karnekruda.blogspot.com

+1
0
-1

____________________
Anarquía != Desorden

Imagen de salvared
+1
0
-1

Me he ido a recovery mode pero no me ha pedido ni control-d ni el pass, sino que directamente me aparece en root. He probado a editar y me dice lo mismo que el archivo es solo de lectura Para colmo no me deja tampoco editar ningún archivo ni crear nuevo. Esto se esta resistiendo mucho, no se que hacer.

+1
0
-1
Imagen de kavra
+1
0
-1

Me da la sensación de que esté cascado el sistema de ficheros y lo monte sólo como lectura, mi sugerencia, a estas horas y con un catarro del doce :-(, es que desde un live CD (hay varias distros de recuperación de datos, googlea) salves los documentos importantes y pruebes a reinstalar. Si no te atreves, tal vez mañana esté más lúcido, lo siento.

"El pueblo que está dispuesto a cambiar su libertad por seguridad no merece ninguna de las dos" Benjamín Franklin
http://www.karnekruda.blogspot.com

+1
0
-1

____________________
Anarquía != Desorden

Imagen de salvared
+1
0
-1

Esperare mejor a mañana ya que me da miedo a perder información importante. Si se pudiera al menos pasar esta información desde Ubuntu con el live cd hasta mi disco duro externo, lo haría. Lo que pasa que no solo tengo archivos, sino también correos electrónicos que no se bien como los podría pasar. Bueno lo dicho mañana será otro día, que te recuperes y descanses y ante todo muchísimas gracias por tu ayuda y paciencia ;-)

+1
0
-1
Imagen de salvared
+1
0
-1

Salvamir gracias, pero ¿como puedo actualizar sin borrar (muy importante para mi este detalle)?, yo lo que tengo es el CD live de Ubuntu 6.10 y una vez pregunte como podia actualizar mi Ubuntu 6.06 con el CD live 6.10 y me dijeron que no se podia. Saludos.

+1
0
-1
Imagen de migueldor
+1
0
-1

Algo que siempre funciona.... formatea y reinstala

+1
0
-1

Páginas