ventanas mal dibujadas con XGL en una ati 200m

Imagen de vnmx
0 puntos

hola,

Mi problema es que hay determinadas ocasiones en que las ventanas no se dibujan de forma correcta cuando estoy en XGL, dejan un tipo de rastro todo el tiempo y es imposible trabajar así. Cuando esto sucede reinicio y si las ventanas siguen dibujándose mal vuelvo a reiniciar hasta que las ventanas están bien dibujadas, una vez que el sistema se decidió a estar bien, no tengo problemas, puedo trabajar por horas sin ninguna ventana mal pintada.

he instalado ubuntu edgy en una máquina compaq nx6125, la cual trae una tarjeta ati 200m. Me decidí a instalar xgl/beryl, y lo logré con los repositorios svn de beryl en la página de treviño.

Creo que el problema no es con beryl, ya que hay ocasiones que entro a XGL sin activar beryl y hay ventanas mal dibujadas, de hecho desinstalé por completo beryl y el problema seguía. Cuando entro al sistema de ventanas sin XGL todo es correcto en todas las ocasiones, por lo que definitivamente creo que el problema lo tengo con XGL.

Para activar la aceleración 3d he usado tanto los drivers libres, como los drivers propietarios, con ambos tengo problemas con XGL. Repito esto no sucede siempre, solo algunas ocasiones.

Les dejo unos links ha unos screenshots de mi pantalla, ventanas mal dibujadas y este con ventanas bien dibujadas

Quisiera si alguien más ha reportado este error.

Gracias

vnmx

Imagen de Johan0xff
+1
0
-1

que problemon tienes, mira, yo trabajo reparando notebook y aveces pasa algo similar en windows cuando hay problemas de hardware que generalmente son:

* Chip de video
* RAM

le has hecho mantencion alguna vez a tu equipo? te has fijado en la temperatura que toma cuando trabajas con aplicaciones graficas?

saludos

+1
0
-1
Imagen de vnmx
+1
0
-1

la temperatura es normal, porque de hecho cuando recién prende por primera vez la laptop está fría.

Y después de unos cuántos reinicios las ventanas se dibujan bien.

Yo creo que es XGL porque he probado a instalar feisty, y tengo el mismo problema con las sesiones XGL, asímismo he probado mandriva one, y tiene también problemas de pintado únicamente cuando se activa XGL. En ninguna otra ocasión más. Ahora mismo llevo varias horas con XGL/Beryl funcionando y todo es normal.

Gracias por responder JohanOxff, ¿alguna otra idea?

Saludos... vnmx

Amplificación del conocimiento. Lo que él aprende, todos lo aprendemos. Lo que él sabe, nos beneficia a todos.

Su nombre... LINUX

+1
0
-1

Amplificación del conocimiento. Lo que él aprende, todos lo aprendemos. Lo que él sabe, nos beneficia a todos.

Su nombre... LINUX

Imagen de Johan0xff
+1
0
-1

Esto es muy raro, estas seguro de que configuraste bien la sesion XGL?, yo por ejemplo poseo una radeon 9550 y configure de la siguiente manera mi sesion XGL:

$ sudo gedit /usr/share/xsessions/xgl.desktop

*Dentro ponemos lo siguiente:

[Desktop Entry]
Encoding=UTF-8
Name=Xgl
Exec=/usr/bin/startxgl.sh
Icon=
Type=Application

*Guardamos y cerramos

$ sudo gedit /usr/bin/startxgl.sh

*Dentro ponemos lo siguiente:

#!/bin/sh
Xgl -fullscreen :1 -ac -accel glx:pbuffer -accel xv:pbuffer & sleep 2 && DISPLAY=:1
cookie="$(xauth -i nextract - :0 | cut -d ' ' -f 9)"
xauth -i add :1 . "$cookie"
# Iniciar Gnome
exec gnome-session

*Guardamos y cerramos. Ahora les damos permisos de ejecucion:

$ sudo chmod 755 /usr/share/xsessions/xgl.desktop
$ sudo chmod 755 /usr/bin/startxgl.sh

Lo mejor es que remuevas el servidor XGL de la siguiente manera y lo re instales:

$ sudo apt-get remove xserver-xgl libgl1-mesa xserver-xorg
$ sudo aptitude install xserver-xgl libgl1-mesa xserver-xorg

Deberia funcinar, sino, entonces verifica que tengas correctamente instalados los drivers de tu tarjeta y el driver fglrx en el xorg. EJ:

$ sudo gedit /etc/X11/xorg.conf

y modifica la linea Section "Device" para que te quede asi:

Section "Device"
Identifier “AQUI NO MUEVAS NADA”
Driver “fglrx”<=================

saludos y espero que respondas como te fue

+1
0
-1
Imagen de vnmx
+1
0
-1

reinstalé el sistema para tenerlo desde 0 por enésima vez, y configurar XGL como lo recomiendas y sigue el problema, algunas veces todas las ventanas se dibujan bien, y otras veces tengo que reiniciar varias veces por las ventanas mal dibujadas.

Encontré por ahí que alguien tenía problemas con letras borrosas en XGL, y la solución era que la profundidad de colores fueran 24 bits, solo que yo desde el principio tengo los 24 bits, por lo que esa no es una solución para mí. Sigo buscando sin encontrar solución.

Gracias por tu tiempo Johan0xff

Saludos... vnmx

Amplificación del conocimiento. Lo que él aprende, todos lo aprendemos. Lo que él sabe, nos beneficia a todos.

Su nombre... LINUX

+1
0
-1

Amplificación del conocimiento. Lo que él aprende, todos lo aprendemos. Lo que él sabe, nos beneficia a todos.

Su nombre... LINUX