Instalar ubuntu+apache+tomcat+php+mysql ¿pero cuales?

Imagen de Furadan
0 puntos

Hola a todos, soy nueva en esto del uso del Ubuntu y aún más en la instalación de un servidor, así que si alguien me puede ayudar...
Vereis me he pegado unos dias mirando las compatibilidades de lo que quiero montar y he acabado loca de tanta versión.
Quiero montar Ubuntu v6.0 con Apache, y sale el primer problema.. Leo que Apache versión 1.3.xx es más robusta con Unix y que la versión 2.0 aún no está suficientemente probada, y que la utilización de variables con la versión 1.3.xx es mejor.
Luego la instalación de Tomcat me declino por la versión 5.5 y en cuanto a PHP depende, pero me declino por utilizar la 4.4.6.
Por último está MySQL quisiera utilizar la versión 5.0.
En fin que en este baile de versiones aún no se si queda alguna incompatibilidad pendiente.
Si alguien tiene montado algo parecido podría ayudarme en las versiones y montaje del servidor ?????

Gracias a todos :)

Imagen de ed.granada
+1
0
-1

Furadan, si el servidor que quieres montar es un entorno de producción (Una empresa, o algo suceptible de ser atacado), un Ubuntero nato te recomienda que no metas Ubuntu Desktop. Mete Ubuntu Server, que es un paquetito LAMP (Linux Apache Mysql PHP) y trae todo preconfigurado. Una vez instalado, si no te aclaras en consola, le metes un terminal grafico, tipo xfce, que pesa poquito, haciendo un

sudo apt-get install xubuntu-desktop

(creo)

y esta distro, ya esta -casi- a la ultima. ¿Casi? Sip, una vez instalado, con internet rulando, haces

sudo apt-get update && upgrade

para actualizar paquetes y todo.

Mas info?

https://help.ubuntu.com/6.10/pdf/ubuntu/C/serverguide.pdf

----------------

No entiendo a la gente. ¿Porqué preguntan como preguntan?
Cómo preguntar bien

+1
0
-1

 ----------------------------------

anacron.wordpress.com
 No entiendo a la gente. ¿Porqué preguntan como preguntan? Cómo preguntar bien

Imagen de Furadan
+1
0
-1

Siento ser un plomo otra vez pero ya había pensado la instalación LAMP dudo con esta solución porque aún tendría que instalar Tomcat y no tengo muy claro que se intale correctamente usando la instalación LAMP.

+1
0
-1
Imagen de Gould
+1
0
-1

Totalmente de acuerdo con ed.granada (por cierto me reí un rato con un enlace que recomendaste a alguien, hablaba de Dios y gatitos...)

Furadan, te recomiendo también consultar este post

http://www.ubuntu-es.org/index.php?q=node/26845

ya que en él, hablan de LAMP en entornos más caseros (sin necesidad de montar un Server).

En cuanto a versionado... te hablaría de mi experiencia bajo windows para montar una wiki pero no recuerdo los numeros. Básicamente era Apache 2, php 5 y mysql 5 sino recuerdo mal... y algun problema tuve con mysql a nivel de compatibilidades con el producto mediawiki... pero solventable.

Memoria de pez, lo siento.

+1
0
-1
Imagen de ed.granada
+1
0
-1

Nueva iniciativa: No mates mas gatitos! el enlace es este gould:

www.usaelputogoogle.com/domokun.php

-----------
No entiendo a la gente. ¿Porqué preguntan como preguntan?
Cómo preguntar bien

+1
0
-1

 ----------------------------------

anacron.wordpress.com
 No entiendo a la gente. ¿Porqué preguntan como preguntan? Cómo preguntar bien

Imagen de Gould
+1
0
-1

ed.Granada, me apropié del enlace...! ;)

Furadan, aqui tienes una secuencia de pasos de instalación de quiza lo más complejo, Apache + Tomcat sobre linux...

Enlace

Por el tema php y mysql no creo que te lleve mucho lío...

-----------------

Salud.

Antes de nada recuerda que..

+1
0
-1
Imagen de Furadan
+1
0
-1

Gracias por todo :), lo del gatito ya ya....

+1
0
-1
Imagen de cath_dark
+1
0
-1

 freeradius-mysql
 gforge-db-postgresql
 gforge-web-apache
E: Sub-process /usr/bin/dpkg returned an error code (1)

 

 

 

 

 

arriba el anime y ubuntu

+1
0
-1

arriba el anime y ubuntu