memoria swap no inicia sola (solucionado)

Imagen de Milo Antares
0 puntos

Bueno mi problema es como dice el tema.

Bueno lo que pasa es que ontale ubuntu 8.04 y ise sus particiones normales / 10 g, swap 5 g, y lo que quedo a home y todo salio bien cargava sola la memoria swap pero medi cuenta que era mucho 10g a el sistema ya que cunado mucho ocupa 5g asi que modifique su tamaño con el cd live a 7 y le puse los otros 3 a swap y desde ahy no inicia sola tengo que entrar a editor de particiones y activarla simepre que inicio secion y eso no me gusta como puedo acer para que esto se componga.

Mi laptop cuenta con 250g de disco duro, 3g de ram y es doble core duo, a se me olvido decirles que despues lo actualize al estado beta de 8.10 pero ese no fue el problema es cuando remodifique las particiones.

De antemano gracias por todas sus respuestas y espero no dar mucha lata y encontre un post del mismo problema pero con los comando que me dice es algo de dev/dax allgo asi lo pongo en terminal y me dice paquete no encontrado. asi que ayudenme y perodn por la ortografia o por si esta en un lugar mal acomodado el tema.

Imagen de ketk
+1
0
-1

Abre un terminal:
Lo primero hacer una copia de seguridad del fstab (por si la liamos):

sudo cp /etc/fstab /etc/fstab.copia
sudo fdisk -l

Para asegurarte de cuál es la partición swap.
Introduces ahora (sustituye sdax por el que corresponda a tu swap: sda1, sda2, etc.). Ésto para conocer el UUID de la partición que necesitaremos posteriormente.

sudo vol_id -u /dev/sdax

Pasas entoces a modificar el fstab:

sudo gedit /etc/fstab

Buscas la partición que corresponde a swap y comparas el UUID que aparece en el archivo con el que de la salida del comando anterior, en caso de ser diferentes, lo cambias y ya debería funcionar.
Suerte.


Hay tres tipos de personas: las vivas, las muertas y las que caminan sobre el mar. 6b 65 74 6b

+1
0
-1

TuVela.com información, tutoriales, curiosidades y más sobre Ubuntu, GNU/Linux y otros temas de mi interés. 6b 65 74 6b


Imagen de Milo Antares
+1
0
-1

mira amigo gracias por todo, el problema es que en terminal me dice que mi unidad swap es sda2 y en lista = osea me imagino que el problema es el UUID pero como ya avias echo ese prosedimiento antes el problema es que no entra este comando sudo vol_id -u /dev/sdax
ya que me dice operacion no valida o avcese me dice fichero no encontrado on que este en root. el problema de que no encuentra el fichero yo creo que deve de ser que tengo el beta de ubuntu 8.10 espero una respuesta y gracias.

+1
0
-1

Que tengan suertecita.
Imagen de ketk
+1
0
-1

Creo que introduciendo antes de nada (sustituyendo la X por lo que proceda, como siempre):

sudo mkswap /dev/sdaX

Y volviendo a hacer los pasos anteriores puedes solucionarlo. No creo que esté relacionado con la beta (aunque podría estarlo).
Ya nos contarás.


Hay tres tipos de personas: las vivas, las muertas y las que caminan sobre el mar. 6b 65 74 6b

+1
0
-1

TuVela.com información, tutoriales, curiosidades y más sobre Ubuntu, GNU/Linux y otros temas de mi interés. 6b 65 74 6b


Imagen de Milo Antares
+1
0
-1

grax amigo elproblema era que no sustitui la x por el numero 2 jejeejeje perdon mi gran error pero ya quedo y si como supucieron era que el UUID era distinto solo copie, pege y reinicie y resulto todo grac y hasta la otra duda bye.

+1
0
-1

Que tengan suertecita.
Imagen de ketk
+1
0
-1

Una vez solucionado el problema añade (solucionado) al final para que otros encuentren respuesta fácilmente si tienen un problema parecido al tuyo.
(cerrado) lo usamos los moderadores cuando cerramos un hilo por no cumplir las normas.

Te edito yo el título cambiando (cerrado) por (solucionado)

Equipo de Ubuntu-es

+1
0
-1

TuVela.com información, tutoriales, curiosidades y más sobre Ubuntu, GNU/Linux y otros temas de mi interés. 6b 65 74 6b