Problema con SoundBlaster X-Fi Extreme Audio

Imagen de pfpons75
0 puntos

Saludos:
Este es mi primer mensaje en este foro y espero ser bien recibido por todos, tengo algo de experiencia en Linux pero este problema me supera (de momento), gracias anticipadas por la/las respuesta(s) que consiga, como también espero que la solución pueda satisfacer a otros usuarios de Ubuntu. Gracias.
Tengo instalada la distro Ubuntu 8.04.1 Hardy Heron en máquina Intel de 64bit todo funciona correctamente pero no tengo sonido, el problema es que no consigo instalar el driver XFiDrv_Linux_US-1.18.tar.gz, según el README de las instrucciones y después de descomprimir el archivo debo ejecutar en un Terminal y como root este comando ./installer o (en caso de problemas) este otro ./installer --with-alsainc=[ALSA_include_directory] donde 'ALSA_include_directory' debe ser (supongo) el path (ruta) de los archivos descomprimidos, pues bien, lo conseguido es lo siguiente:

Installation is in progress. Please wait...

checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking for ranlib... ranlib
checking for a BSD-compatible install... /usr/bin/install -c
checking how to run the C preprocessor... gcc -E
checking for egrep... grep -E
checking for ANSI C header files... yes
checking for an ANSI C-conforming const... yes
checking for inline... inline
checking whether time.h and sys/time.h may both be included... yes
checking whether gcc needs -traditional... no
checking for current directory... /opt/Creative/XFiDrv_Linux_US-1.18/drivers
checking cross compile...
checking for directory with kernel source... /lib/modules/2.6.24-19-generic/build
checking for directory with kernel build...
checking for directory with ALSA include files... /home/pere/XFiDrv_Linux_US-1.18/
checking for kernel linux/version.h... yes
checking for kernel linux/autoconf.h... yes
checking for kernel version... 2.6.24-19-generic
checking for GCC version... Kernel compiler: Used compiler: gcc (GCC) 4.2.3 (Ubuntu 4.2.3-2ubuntu7)

*** NO PREDEFINED KERNEL COMPILER IS DETECTED
*** Assuming the same compiler is used with the current system compiler.

*** Please make sure that the same compiler version was used for building kernel.

checking for built-in ALSA... no
checking for existing ALSA module... no
checking to modify of kernel linux/kmod.h... no
checking for kernel linux/compiler.h... yes
checking for kernel linux/pm.h... yes
checking for kernel linux/spinlock.h... yes
checking for kernel linux/irq.h... yes
checking for kernel linux/threads.h... yes
checking for kernel linux/rwsem.h... yes
checking for kernel linux/gameport.h... yes
checking for kernel linux/devfs_fs_kernel.h... no
Creating a dummy ...
checking for kernel linux/highmem.h... yes
checking for kernel linux/workqueue.h... yes
checking for kernel linux/dma-mapping.h... yes
checking for kernel asm/hw_irq.h... yes
checking for kernel linux/device.h... yes
checking for kernel linux/platform_device.h... yes
checking for kernel linux/jiffies.h... yes
checking for kernel linux/compat.h... yes
checking for kernel linux/adb.h... yes
checking for kernel linux/cuda.h... yes
checking for kernel linux/pmu.h... yes
checking for kernel linux/moduleparam.h... yes
checking for kernel linux/syscalls.h... yes
checking for kernel linux/firmware.h... yes
checking for kernel linux/err.h... yes
checking for kernel linux/bitmap.h... yes
checking for kernel linux/mutex.h... yes
checking for kernel module symbol versions... yes
checking for PCI support in kernel... yes
checking for I2C driver in kernel... module
checking for firmware loader... yes
checking for input subsystem in kernel... yes
checking for directory to store kernel modules... /lib/modules/2.6.24-19-generic/kernel/sound
checking for ISA support in kernel... no
checking for processor type... x86_64
checking for ISA DMA API... yes
checking for 32bit compat support... yes
checking for SMP... yes
checking for Video device support in kernel... yes
checking for strlcpy... no
checking for snprintf... no
checking for vsnprintf... no
checking for scnprintf... no
checking for sscanf... no
checking for vmalloc_to_page... no
checking for old kmod... yes
checking for PDE... no
checking for pci_set_consistent_dma_mask... no
checking for pci_dev_present... no
checking for msleep... no
checking for msecs_to_jiffies... no
checking for tty->count is the atomic type... no
checking for video_get_drvdata... no
checking for io_remap_pfn_range... no
checking for new io_remap_page_range... no
checking for kcalloc... no
checking for kstrdup... no
checking for kzalloc... no
checking for create_workqueue with flags... no
checking for saved_config_space in pci_dev... no
checking for register_sound_special_device... no
checking for RTC callback support in kernel... no
checking for HPET support... yes
checking for Procfs support... yes
checking for class_simple... no
checking for old driver suspend/resume callbacks... no
checking for removal of page-reservation for nopage/mmap... no
checking for nested class_device... no
checking for new unlocked/compat_ioctl... no
configure: creating ./config.status
config.status: creating Makefile.conf
make: *** [all] Error 2
make: *** [install] Error 2
Installation Complete
root@pere-desktop:/home/pere/XFiDrv_Linux_US-1.18#

Y ahora pregunto: ¿porqué se produce el error y no se instala? ¿debo compilar el núcleo y cómo? ¿cuál es la equivocación que he cometido?

Imagen de jamesfrank
+1
0
-1

saludos yo recien compre una tarjeta de sonido sound blaster x-fi extreme notebook para el puerto pci express card de mi portatil pero en windows me la reconoce pero al iniciar linux no la detecta parece ser q este puerto esta como deshabilitdo porque no me indica nada, tambien me faltan los drivers de la tarjeta para linux, no se si tu ya has resuelto tu problema pero mi pregunta es si me sabes algo que pueda hacer yo para que me reconosca mi tarjeta de sonido o se active este puerto o si hay algun enlace para buscar los driver de mi tarjeta para linux gracias amigo espero tu ayuda o la de alguien q me pueda ayudar a solucionar mi problema un saludo.

+1
0
-1
Imagen de HB
+1
0
-1

Yo tampoco he podido instalar esta tarjeta, la Creative SB Xfi Xtreme PCI Express en Ubuntu 9,10..
Es detectada pero no suena nada
¿Algún tipo de informaciòn?

HB();

+1
0
-1

HB();

Imagen de BlueBird
+1
0
-1

hay un driver que hace funcionar , aunque sea solo parcialmente , esta tarjeta. yo estoy usando linux mint 9 que tiene como base el ubuntu 10.04. dicho driver es " alsa-driver-1.0.15.tar.bz2 " y puede ser descargado gratuitamente desde " http://alsa-project.org/main/index.php/Main_Page " . Es un driver con el que funciona el modelo de sound blaster " audigy " . espero que esta aportacion le pueda ayudar a alguien. gracias

+1
0
-1